<!doctype html><html lang="en-US"><head><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, viewport-fit=cover"><link rel="profile" href="https://gmpg.org/xfn/11"><link rel="pingback" href="https://socialitelife.com/xmlrpc.php"><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /><link media="all" href="https://socialitelife.com/wp-content/cache/autoptimize/css/autoptimize_ea8a708f5359e2e3f5659ca8da72ccb8.css" rel="stylesheet" /><title>The Great British Baking Show — Biscuit Week (TV Talk) &ndash; Socialite Life</title><meta name="description" content="The Great British Baking Show — Biscuit Week! Biscuits. Cookies. Whatever you call them, they’re delicious. So how did all the bakers fare?" /><link rel="canonical" href="https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="The Great British Baking Show — Biscuit Week (TV Talk)" /><meta property="og:description" content="The Great British Baking Show — Biscuit Week! Biscuits. Cookies. Whatever you call them, they’re delicious. So how did all the bakers fare?" /><meta property="og:url" content="https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/" /><meta property="og:site_name" content="Socialite Life" /><meta property="article:publisher" content="https://www.facebook.com/SocialiteLife" /><meta property="article:published_time" content="2022-09-27T23:37:02+00:00" /><meta property="article:modified_time" content="2022-09-27T23:37:04+00:00" /><meta property="og:image" content="https://socialitelife.com/wp-content/uploads/2022/09/Bake-Off-4085-Large.jpeg" /><meta property="og:image:width" content="1280" /><meta property="og:image:height" content="705" /><meta property="og:image:type" content="image/jpeg" /><meta name="author" content="Miu von Furstenberg" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:title" content="The Great British Baking Show — Biscuit Week (TV Talk)" /><meta name="twitter:creator" content="@socialitelife" /><meta name="twitter:site" content="@socialitelife" /><meta name="twitter:label1" content="Written by" /><meta name="twitter:data1" content="Miu von Furstenberg" /><meta name="twitter:label2" content="Est. reading time" /><meta name="twitter:data2" content="3 minutes" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Article","@id":"https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/#article","isPartOf":{"@id":"https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/"},"author":{"name":"Miu von Furstenberg","@id":"https://socialitelife.com/#/schema/person/7e6d93b3f872488ecabc5ea258d616f3"},"headline":"The Great British Baking Show — Biscuit Week (TV Talk)","datePublished":"2022-09-27T23:37:02+00:00","dateModified":"2022-09-27T23:37:04+00:00","mainEntityOfPage":{"@id":"https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/"},"wordCount":474,"publisher":{"@id":"https://socialitelife.com/#organization"},"image":{"@id":"https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/#primaryimage"},"thumbnailUrl":"https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/Bake-Off-4085-Large.jpeg?fit=1280%2C705&ssl=1","keywords":["The Great British Baking Show","TV Talk"],"articleSection":["TV"],"inLanguage":"en-US"},{"@type":"WebPage","@id":"https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/","url":"https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/","name":"The Great British Baking Show — Biscuit Week (TV Talk) &ndash; Socialite Life","isPartOf":{"@id":"https://socialitelife.com/#website"},"primaryImageOfPage":{"@id":"https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/#primaryimage"},"image":{"@id":"https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/#primaryimage"},"thumbnailUrl":"https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/Bake-Off-4085-Large.jpeg?fit=1280%2C705&ssl=1","datePublished":"2022-09-27T23:37:02+00:00","dateModified":"2022-09-27T23:37:04+00:00","description":"The Great British Baking Show — Biscuit Week! Biscuits. Cookies. Whatever you call them, they’re delicious. So how did all the bakers fare?","breadcrumb":{"@id":"https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/"]}]},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/#primaryimage","url":"https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/Bake-Off-4085-Large.jpeg?fit=1280%2C705&ssl=1","contentUrl":"https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/Bake-Off-4085-Large.jpeg?fit=1280%2C705&ssl=1","width":1280,"height":705,"caption":"The Great British Baking Show — Biscuit Week"},{"@type":"BreadcrumbList","@id":"https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://socialitelife.com/"},{"@type":"ListItem","position":2,"name":"The Great British Baking Show — Biscuit Week (TV Talk)"}]},{"@type":"WebSite","@id":"https://socialitelife.com/#website","url":"https://socialitelife.com/","name":"Socialite Life","description":"Pop Culture Shaken, Not Stirred","publisher":{"@id":"https://socialitelife.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://socialitelife.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"Organization","@id":"https://socialitelife.com/#organization","name":"Socialite Life","url":"https://socialitelife.com/","sameAs":["https://www.instagram.com/socialitelife/","https://www.pinterest.com/socialitelife/","https://www.youtube.com/channel/UC7ew27fEz_OXF4kkxczb3Eg/","https://www.facebook.com/SocialiteLife","https://twitter.com/socialitelife"],"logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://socialitelife.com/#/schema/logo/image/","url":"https://i0.wp.com/socialitelife.com/wp-content/uploads/2020/04/SL-Wig-Logo-300.jpg?fit=300%2C87&ssl=1","contentUrl":"https://i0.wp.com/socialitelife.com/wp-content/uploads/2020/04/SL-Wig-Logo-300.jpg?fit=300%2C87&ssl=1","width":300,"height":87,"caption":"Socialite Life"},"image":{"@id":"https://socialitelife.com/#/schema/logo/image/"}},{"@type":"Person","@id":"https://socialitelife.com/#/schema/person/7e6d93b3f872488ecabc5ea258d616f3","name":"Miu von Furstenberg","url":"https://socialitelife.com/author/miu/"}]}</script> <link rel='dns-prefetch' href='//scripts.mediavine.com' /><link rel='dns-prefetch' href='//cdn.plyr.io' /><link rel='dns-prefetch' href='//use.typekit.net' /><link rel='dns-prefetch' href='//s.w.org' /><link rel='dns-prefetch' href='//i0.wp.com' /><link rel='dns-prefetch' href='//c0.wp.com' /><link rel="alternate" type="application/rss+xml" title="Socialite Life &raquo; Feed" href="https://socialitelife.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Socialite Life &raquo; Comments Feed" href="https://socialitelife.com/comments/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/socialitelife.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0.2"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);</script> <link rel='stylesheet' id='thb-typekit-css'  href='https://use.typekit.net/crc4abh.css?ver=1.6.7' type='text/css' media='' /> <script type='text/javascript' async="async" data-noptimize="1" data-cfasync="false" src='https://scripts.mediavine.com/tags/socialite-life.js?ver=6.0.2' id='mv-script-wrapper-js'></script> <script type='text/javascript' src='https://socialitelife.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script> <link rel="https://api.w.org/" href="https://socialitelife.com/wp-json/" /><link rel="alternate" type="application/json" href="https://socialitelife.com/wp-json/wp/v2/posts/74581" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://socialitelife.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://socialitelife.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 6.0.2" /><link rel='shortlink' href='https://socialitelife.com/?p=74581' /><link rel="alternate" type="application/json+oembed" href="https://socialitelife.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsocialitelife.com%2Fthe-great-british-baking-show-biscuit-week-tv-talk%2F" /><link rel="alternate" type="text/xml+oembed" href="https://socialitelife.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsocialitelife.com%2Fthe-great-british-baking-show-biscuit-week-tv-talk%2F&#038;format=xml" /><meta name="cdp-version" content="1.3.2" /><link rel="preconnect" href="https://fonts.googleapis.com"><link rel="preconnect" href="https://fonts.gstatic.com">  <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-78592632-1', 'auto');
			ga('send', 'pageview');</script> <meta name="pubexchange:image" content="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/Bake-Off-4085-Large.jpeg?fit=800%2C441&ssl=1"><meta name="pubexchange:title" content="The Great British Baking Show — Biscuit Week (TV Talk)"><link rel="icon" href="https://i0.wp.com/socialitelife.com/wp-content/uploads/2020/04/cropped-SL-square-favicon.jpg?fit=32%2C32&#038;ssl=1" sizes="32x32" /><link rel="icon" href="https://i0.wp.com/socialitelife.com/wp-content/uploads/2020/04/cropped-SL-square-favicon.jpg?fit=192%2C192&#038;ssl=1" sizes="192x192" /><link rel="apple-touch-icon" href="https://i0.wp.com/socialitelife.com/wp-content/uploads/2020/04/cropped-SL-square-favicon.jpg?fit=180%2C180&#038;ssl=1" /><meta name="msapplication-TileImage" content="https://i0.wp.com/socialitelife.com/wp-content/uploads/2020/04/cropped-SL-square-favicon.jpg?fit=270%2C270&#038;ssl=1" /> <noscript><style>.wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head><body class="post-template-default single single-post postid-74581 single-format-standard aawp-custom thb-dropcap-off fixed-header-on fixed-header-scroll-off thb-dropdown-color-light right-click-off thb-borders-off thb-pinit-off thb-boxed-off thb-dark-mode-off thb-capitalize-off thb-parallax-off thb-single-product-ajax-on thb-article-sidebar-mobile-on wpb-js-composer js-comp-ver-6.6.0 vc_responsive"> <svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><div id="wrapper" class="thb-page-transition-on"><header class="header fixed fixed-article header-full-width fixed-header-full-width-on light-header thb-fixed-shadow-style1"><div class="row full-width-row"><div class="small-12 columns"><div class="thb-navbar"><div class="fixed-logo-holder"><div class="mobile-toggle-holder"><div class="mobile-toggle"> <span></span><span></span><span></span></div></div><div class="logo-holder fixed-logo-holder"> <a href="https://socialitelife.com/" class="logolink" title="Socialite Life"> <img src="https://socialitelife.com/wp-content/uploads/2020/04/SL-Wig-banner-600.jpg" class="logoimg logo-dark" alt="Socialite Life" data-logo-alt="https://socialitelife.com/wp-content/uploads/2020/04/SL-Wig-banner-600.jpg" /> </a></div></div><div class="fixed-title-holder"> <span>Now Reading</span><div class="fixed-article-title"><h6 id="page-title">The Great British Baking Show — Biscuit Week (TV Talk)</h6></div></div><div class="fixed-article-shares"><div class="thb-social-fixed sharing-counts-off"><div class="social-button-holder"> <a href="https://www.facebook.com/sharer.php?u=https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/" class="social social-facebook"
 > <span class="thb-social-icon"> <i class="thb-icon-facebook"></i> </span> </a></div><div class="social-button-holder"> <a href="https://twitter.com/intent/tweet?text=The%20Great%20British%20Baking%20Show —%20Biscuit%20Week (TV%20Talk)&#038;via=socialitelife&#038;url=https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/" class="social social-twitter"
 > <span class="thb-social-icon"> <i class="thb-icon-twitter"></i> </span> </a></div><div class="social-button-holder"> <a href="https://pinterest.com/pin/create/bookmarklet/?url=https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/&#038;media=https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/Bake-Off-4085-Large.jpeg?fit=1280%2C705&#038;ssl=1" class="social social-pinterest"
 > <span class="thb-social-icon"> <i class="thb-icon-pinterest"></i> </span> </a></div><div class="social-button-holder"> <a href="https://reddit.com/submit?url=https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/" class="social social-reddit"
 > <span class="thb-social-icon"> <i class="thb-icon-reddit"></i> </span> </a></div><div class="social-button-holder"> <a href="https://share.flipboard.com/bookmarklet/popout?v=2&#038;title=The%20Great%20British%20Baking%20Show —%20Biscuit%20Week (TV%20Talk)&#038;url=https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/" class="social social-flipboard"
 > <span class="thb-social-icon"> <i class="thb-icon-flipboard"></i> </span> </a></div><div class="social-button-holder"> <a href="https://www.linkedin.com/cws/share?url=https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/" class="social social-linkedin"
 > <span class="thb-social-icon"> <i class="thb-icon-linkedin"></i> </span> </a></div><div class="social-button-holder"> <a href="/cdn-cgi/l/email-protection#0b34787e69616e687f365f636e2e393b4c796e6a7f2e393b4979627f6278632e393b496a6062656c2e393b5863647cc9abe98b9f2e393b496278687e627f2e393b5c6e6e60c9ab235f5d2e393b5f6a6760222d283b38333069646f72365f636e2e393b4c796e6a7f2e393b4979627f6278632e393b496a6062656c2e393b5863647cc9abe98b9f2e393b496278687e627f2e393b5c6e6e60c9ab235f5d2e393b5f6a6760222e393b637f7f7b78312424786468626a67627f6e67626d6e25686466247f636e266c796e6a7f266979627f62786326696a6062656c267863647c26696278687e627f267c6e6e60267f7d267f6a676024" class="social social-email"> <span class="thb-social-icon"> <i class="thb-icon-mail"></i> </span> </a></div></div></div></div></div></div></header><div class="subheader style1 light subheader-mobile-off subheader-full-width-on"><div class="row subheader-row"><div class="small-12 medium-6 columns subheader-leftside"><ul id="menu-footer-menu" class="thb-full-menu"><li id="menu-item-2856" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2856"><a href="https://socialitelife.com/about-socialite-life/">About</a></li><li id="menu-item-397" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-397"><a href="https://socialitelife.com/contact/">Contact</a></li><li id="menu-item-398" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-398"><a href="https://socialitelife.com/terms/">Terms</a></li><li id="menu-item-399" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-399"><a href="https://socialitelife.com/privacy-policy-2/">Privacy</a></li></ul></div><div class="small-12 medium-6 columns subheader-rightside"></div></div></div><div class="mobile-header-holder"><header class="header header-mobile header-mobile-style1 light-header"><div class="row"><div class="small-3 columns"><div class="mobile-toggle-holder"><div class="mobile-toggle"> <span></span><span></span><span></span></div></div></div><div class="small-6 columns"><div class="logo-holder mobile-logo-holder"> <a href="https://socialitelife.com/" class="logolink" title="Socialite Life"> <img src="https://socialitelife.com/wp-content/uploads/2020/04/SL-Wig-banner-300.jpg" class="logoimg logo-dark" alt="Socialite Life" data-logo-alt="https://socialitelife.com/wp-content/uploads/2020/04/SL-Wig-banner-300.jpg" /> </a></div></div><div class="small-3 columns"><div class="secondary-area"><div class="thb-search-holder"> <svg version="1.1" class="thb-search-icon" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" viewBox="0 0 14 14" enable-background="new 0 0 14 14" xml:space="preserve" width="14" height="14"> <path d="M13.8,12.7l-3-3c0.8-1,1.3-2.3,1.3-3.8c0-3.3-2.7-6-6.1-6C2.7,0,0,2.7,0,6c0,3.3,2.7,6,6.1,6c1.4,0,2.6-0.5,3.6-1.2l3,3
 c0.1,0.1,0.3,0.2,0.5,0.2c0.2,0,0.4-0.1,0.5-0.2C14.1,13.5,14.1,13,13.8,12.7z M1.5,6c0-2.5,2-4.5,4.5-4.5c2.5,0,4.5,2,4.5,4.5
 c0,2.5-2,4.5-4.5,4.5C3.5,10.5,1.5,8.5,1.5,6z"/> </svg></div></div></div></div></header></div><header class="header style2 thb-main-header light-header"><div class="row"><div class="small-4 columns"><div class="mobile-toggle-holder"><div class="mobile-toggle"> <span></span><span></span><span></span></div></div></div><div class="small-4 columns"><div class="logo-holder"> <a href="https://socialitelife.com/" class="logolink" title="Socialite Life"> <img src="https://socialitelife.com/wp-content/uploads/2020/04/SL-Wig-banner-600.jpg" class="logoimg logo-dark" alt="Socialite Life" data-logo-alt="https://socialitelife.com/wp-content/uploads/2020/04/SL-Wig-banner-600.jpg" /> </a></div></div><div class="small-4 columns"><div class="secondary-area"><div class="thb-follow-holder"><ul class="thb-full-menu thb-standard"><li class="menu-item-has-children"> <a><span>Follow</span></a><ul class="sub-menu"><li><div class="thb-social-links-container thb-social-vertical mono-icons"><div class="thb-social-link-wrap"> <a href="https://facebook.com/socialitelife" target="_blank" class="thb-social-link social-link-facebook" rel="noreferrer"><div class="thb-social-label-container"><div class="thb-social-icon-container"><i class="thb-icon-facebook"></i></div><div class="thb-social-label">Facebook</div></div> </a></div><div class="thb-social-link-wrap"> <a href="https://twitter.com/socialitelife" target="_blank" class="thb-social-link social-link-twitter" rel="noreferrer"><div class="thb-social-label-container"><div class="thb-social-icon-container"><i class="thb-icon-twitter"></i></div><div class="thb-social-label">Twitter</div></div> </a></div><div class="thb-social-link-wrap"> <a href="https://instagram.com/socialitelife" target="_blank" class="thb-social-link social-link-instagram" rel="noreferrer"><div class="thb-social-label-container"><div class="thb-social-icon-container"><i class="thb-icon-instagram"></i></div><div class="thb-social-label">Instagram</div></div> </a></div><div class="thb-social-link-wrap"> <a href="https://pinterest.com/socialitelife" target="_blank" class="thb-social-link social-link-pinterest" rel="noreferrer"><div class="thb-social-label-container"><div class="thb-social-icon-container"><i class="thb-icon-pinterest"></i></div><div class="thb-social-label">Pinterest</div></div> </a></div><div class="thb-social-link-wrap"> <a href="https://youtube.com/channel/UC7ew27fEz_OXF4kkxczb3Eg" target="_blank" class="thb-social-link social-link-youtube" rel="noreferrer"><div class="thb-social-label-container"><div class="thb-social-icon-container"><i class="thb-icon-youtube"></i></div><div class="thb-social-label">Youtube</div></div> </a></div></div></li><li class="subscribe_part"><aside class="thb-article-subscribe thb-newsletter-form"><div class="thb-subscribe-icon-container"><svg version="1.1" class="thb-subscribe-icon" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
 viewBox="0 0 90 68" style="enable-background:new 0 0 90 68;" xml:space="preserve"> <path d="M89.9,7.9c0-4.3-3.6-7.9-7.9-7.9L7.8,0.1C3.5,0.1,0,3.8,0,8.1l0.1,52c0,4.3,3.6,7.9,7.9,7.9l74.2-0.1c4.3,0,7.8-3.6,7.8-8
 L89.9,7.9z M7.8,4.4l74.2-0.1c0.4,0,0.8,0.1,1.2,0.2L48.9,39.4c-1,1.1-2.4,1.6-3.9,1.6c-1.5,0-2.8-0.5-3.9-1.6L6.7,4.6
 C7,4.5,7.4,4.4,7.8,4.4z M82.2,63.6L7.9,63.8c-2,0-3.7-1.7-3.7-3.7l-0.1-52l34,34.4c1.8,1.8,4.3,2.9,6.8,2.9c2.5,0,5-1.1,6.8-2.9
 L85.7,7.9l0.1,52C85.8,61.9,84.2,63.6,82.2,63.6z M80.5,55.7L62.9,40c-0.8-0.7-2.2-0.7-2.9,0.2c-0.7,0.8-0.7,2.2,0.2,3l17.6,15.7
 c0.4,0.3,0.9,0.5,1.4,0.5c0.6,0,1.1-0.2,1.6-0.7C81.4,57.8,81.4,56.4,80.5,55.7z M26.9,40.3L9.5,55.8c-0.8,0.7-0.9,2.1-0.2,3
 c0.5,0.5,1,0.7,1.7,0.7c0.5,0,0.9-0.2,1.4-0.5l17.3-15.5c0.8-0.7,0.9-2.1,0.2-3C29.1,39.6,27.8,39.5,26.9,40.3z"/> </svg></div><h4> Subscribe to our newsletter!</h4><p> A weekly recap of pop culture delivered straight to your inbox every Friday evening.</p><form class="newsletter-form" action="#" method="post" data-security="06513d6bf9"> <input placeholder="Your E-Mail" type="text" name="widget_subscribe" class="widget_subscribe large"> <button type="submit" name="submit" class="btn large">SIGN UP</button><div class="thb-preloader"> <svg class="material-spinner" width="50px" height="50px" viewBox="0 0 66 66" xmlns="http://www.w3.org/2000/svg"> <circle class="material-path" fill="none" stroke-width="6" stroke-linecap="round" cx="33" cy="33" r="30"></circle> </svg></div></form><div class="thb-custom-checkbox"> <input type="checkbox" id="thb-newsletter-privacy-969" name="thb-newsletter-privacy" class="thb-newsletter-privacy"  checked='checked' > <label for="thb-newsletter-privacy-969"> I would like to receive news and special offers. </label></div></aside></li></ul></li></ul></div><div class="thb-trending-holder"><ul class="thb-full-menu"><li class="menu-item-has-children"> <a><span><svg version="1.1" class="thb-trending-icon thb-trending-icon-style3" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
 viewBox="0 0 20 28" xml:space="preserve"><path d="M6.9,28C2.9,26.7,0,23,0,18.7C0,10.6,8,9.6,7.7,0c8.5,4.7,7.4,12.7,7.4,12.7S17,11.7,17,9.4c2.1,3.3,3,6.6,3,9.3
 c0,4.3-2.9,8-6.9,9.3c1.7-1,2.8-2.8,2.8-4.8c0-4.8-4.5-5.4-4.6-10.9c-4.6,3.5-3.3,9.4-3.3,9.4s-2.3-0.7-2-3.9
 c-1.3,2-1.8,3.8-1.8,5.4C4.1,25.2,5.2,27,6.9,28z"/></svg></span></a><div class="sub-menu"><div class="thb-trending
 " data-security="86e7752674"><div class="thb-trending-tabs"> <a data-time="2" class="active">Now</a> <a data-time="7">Week</a> <a data-time="30">Month</a></div><div class="thb-trending-content"><div class="thb-trending-content-inner"><div class="post thumbnail-style3 post-74437 type-post status-publish format-standard has-post-thumbnail hentry category-eye-candy category-fashion tag-jake-hobbs tag-male-model-spotlight tag-models tag-photos tag-video mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <a href="https://socialitelife.com/jake-hobbs-male-model-spotlight/"> <img width="90" height="90" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/jake-hobbs-photos-09212022-1.jpg?resize=20%2C20&amp;ssl=1" class="attachment-theissue-thumbnail size-theissue-thumbnail thb-lazyload lazyload wp-post-image" alt="Jake Hobbs" loading="lazy" sizes="(max-width: 90px) 100vw, 90px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/jake-hobbs-photos-09212022-1.jpg?resize=90%2C90&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/jake-hobbs-photos-09212022-1.jpg?resize=90%2C90&amp;ssl=1 90w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/jake-hobbs-photos-09212022-1.jpg?resize=20%2C19&amp;ssl=1 20w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/jake-hobbs-photos-09212022-1.jpg?zoom=2&amp;resize=90%2C90&amp;ssl=1 180w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/jake-hobbs-photos-09212022-1.jpg?zoom=3&amp;resize=90%2C90&amp;ssl=1 270w" /> </a></figure><div class="thumbnail-style2-inner"><div class="post-title"><h5><a href="https://socialitelife.com/jake-hobbs-male-model-spotlight/" title="Jake Hobbs: Male Model Spotlight"><span>Jake Hobbs: Male Model Spotlight</span></a></h5></div></div></div><div class="post thumbnail-style3 post-74527 type-post status-publish format-standard has-post-thumbnail hentry category-celebrity category-eye-candy tag-aaron-taylor-johnson tag-andrew-matarazzo tag-austin-mahone tag-brandon-flynn tag-derek-hough tag-dylan-efron tag-evan-lamicella tag-insta-snaps tag-jose-manuel-rincon tag-ludi-lin tag-man-candy tag-photos tag-pietro-boselli tag-romulo-arantes-neto tag-usher tag-zane-phillips mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <a href="https://socialitelife.com/pietro-boselli-dylan-efron-aaron-taylor-johnson-and-more-insta-snaps/"> <img width="90" height="90" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/pietroboselli_1663861250_1.jpg?resize=20%2C20&amp;ssl=1" class="attachment-theissue-thumbnail size-theissue-thumbnail thb-lazyload lazyload wp-post-image" alt="Pietro Boselli" loading="lazy" sizes="(max-width: 90px) 100vw, 90px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/pietroboselli_1663861250_1.jpg?resize=90%2C90&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/pietroboselli_1663861250_1.jpg?resize=90%2C90&amp;ssl=1 90w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/pietroboselli_1663861250_1.jpg?resize=20%2C19&amp;ssl=1 20w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/pietroboselli_1663861250_1.jpg?zoom=2&amp;resize=90%2C90&amp;ssl=1 180w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/pietroboselli_1663861250_1.jpg?zoom=3&amp;resize=90%2C90&amp;ssl=1 270w" /> </a></figure><div class="thumbnail-style2-inner"><div class="post-title"><h5><a href="https://socialitelife.com/pietro-boselli-dylan-efron-aaron-taylor-johnson-and-more-insta-snaps/" title="Pietro Boselli, Dylan Efron, Aaron Taylor Johnson and more Insta Snaps"><span>Pietro Boselli, Dylan Efron, Aaron Taylor Johnson and more Insta Snaps</span></a></h5></div></div></div><div class="post thumbnail-style3 post-74457 type-post status-publish format-standard has-post-thumbnail hentry category-celebrity category-eye-candy category-featured tag-alan-ritchson tag-antonio-sotillo tag-ashley-parker-angel tag-bruno-alcantara tag-chris-salvatore tag-christian-chavez tag-henry-golding tag-insta-snaps tag-jamie-dornan tag-jesus-luz tag-noah-fearnley tag-photos tag-polo-morin tag-ryan-phillippe tag-sam-vartholomeos tag-thomas-doherty mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <a href="https://socialitelife.com/alan-ritchson-antonio-sotillo-chris-salvatore-and-more-insta-snaps/"> <img width="90" height="90" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/alanritchson_1663596512.jpg?resize=20%2C20&amp;ssl=1" class="attachment-theissue-thumbnail size-theissue-thumbnail thb-lazyload lazyload wp-post-image" alt="Alan Ritchson" loading="lazy" sizes="(max-width: 90px) 100vw, 90px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/alanritchson_1663596512.jpg?resize=90%2C90&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/alanritchson_1663596512.jpg?resize=90%2C90&amp;ssl=1 90w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/alanritchson_1663596512.jpg?resize=20%2C19&amp;ssl=1 20w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/alanritchson_1663596512.jpg?zoom=2&amp;resize=90%2C90&amp;ssl=1 180w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/alanritchson_1663596512.jpg?zoom=3&amp;resize=90%2C90&amp;ssl=1 270w" /> </a></figure><div class="thumbnail-style2-inner"><div class="post-title"><h5><a href="https://socialitelife.com/alan-ritchson-antonio-sotillo-chris-salvatore-and-more-insta-snaps/" title="Alan Ritchson, Antonio Sotillo, Chris Salvatore, and more Insta Snaps"><span>Alan Ritchson, Antonio Sotillo, Chris Salvatore, and more Insta Snaps</span></a></h5></div></div></div><div class="post thumbnail-style3 post-74393 type-post status-publish format-standard has-post-thumbnail hentry category-celebrity category-featured tag-adam-levine tag-behati-prinsloo tag-sumner-stroh mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <a href="https://socialitelife.com/i-used-poor-judgment-adam-levine-admits-to-talking-to-instagram-model-sumner-stroh-denies-affair/"> <img width="90" height="90" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/74393-origin_1.jpg?resize=20%2C20&amp;ssl=1" class="attachment-theissue-thumbnail size-theissue-thumbnail thb-lazyload lazyload wp-post-image" alt="" loading="lazy" sizes="(max-width: 90px) 100vw, 90px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/74393-origin_1.jpg?resize=90%2C90&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/74393-origin_1.jpg?resize=90%2C90&amp;ssl=1 90w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/74393-origin_1.jpg?resize=20%2C19&amp;ssl=1 20w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/74393-origin_1.jpg?zoom=2&amp;resize=90%2C90&amp;ssl=1 180w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/74393-origin_1.jpg?zoom=3&amp;resize=90%2C90&amp;ssl=1 270w" /> </a></figure><div class="thumbnail-style2-inner"><div class="post-title"><h5><a href="https://socialitelife.com/i-used-poor-judgment-adam-levine-admits-to-talking-to-instagram-model-sumner-stroh-denies-affair/" title="‘I used poor judgment’: Adam Levine admits to talking to Instagram model Sumner Stroh, denies affair"><span>‘I used poor judgment’: Adam Levine admits to talking to Instagram model Sumner Stroh, denies affair</span></a></h5></div></div></div><div class="post thumbnail-style3 post-74507 type-post status-publish format-standard has-post-thumbnail hentry category-celebrity tag-lil-nas-x tag-madonna mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <a href="https://socialitelife.com/lil-nas-x-and-madonnas-pre-gig-catch-up-interrupted-by-his-nervous-poop/"> <img width="90" height="90" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/madonna-lil-nas-x.jpg?resize=20%2C20&amp;ssl=1" class="attachment-theissue-thumbnail size-theissue-thumbnail thb-lazyload lazyload wp-post-image" alt="Madonna and Lil Nas X" loading="lazy" sizes="(max-width: 90px) 100vw, 90px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/madonna-lil-nas-x.jpg?resize=90%2C90&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/madonna-lil-nas-x.jpg?resize=90%2C90&amp;ssl=1 90w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/madonna-lil-nas-x.jpg?resize=20%2C19&amp;ssl=1 20w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/madonna-lil-nas-x.jpg?zoom=2&amp;resize=90%2C90&amp;ssl=1 180w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/madonna-lil-nas-x.jpg?zoom=3&amp;resize=90%2C90&amp;ssl=1 270w" /> </a></figure><div class="thumbnail-style2-inner"><div class="post-title"><h5><a href="https://socialitelife.com/lil-nas-x-and-madonnas-pre-gig-catch-up-interrupted-by-his-nervous-poop/" title="Lil Nas X and Madonna&#8217;s pre-gig catch-up interrupted by his nervous poop"><span>Lil Nas X and Madonna&#8217;s pre-gig catch-up interrupted by his nervous poop</span></a></h5></div></div></div></div><div class="thb-preloader"> <svg class="material-spinner" width="50px" height="50px" viewBox="0 0 66 66" xmlns="http://www.w3.org/2000/svg"> <circle class="material-path" fill="none" stroke-width="6" stroke-linecap="round" cx="33" cy="33" r="30"></circle> </svg></div></div></div></div></li></ul></div><div class="thb-search-holder"> <svg version="1.1" class="thb-search-icon" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" viewBox="0 0 14 14" enable-background="new 0 0 14 14" xml:space="preserve" width="14" height="14"> <path d="M13.8,12.7l-3-3c0.8-1,1.3-2.3,1.3-3.8c0-3.3-2.7-6-6.1-6C2.7,0,0,2.7,0,6c0,3.3,2.7,6,6.1,6c1.4,0,2.6-0.5,3.6-1.2l3,3
 c0.1,0.1,0.3,0.2,0.5,0.2c0.2,0,0.4-0.1,0.5-0.2C14.1,13.5,14.1,13,13.8,12.7z M1.5,6c0-2.5,2-4.5,4.5-4.5c2.5,0,4.5,2,4.5,4.5
 c0,2.5-2,4.5-4.5,4.5C3.5,10.5,1.5,8.5,1.5,6z"/> </svg></div></div></div></div><div class="row"><div class="small-12 columns"><div class="thb-navbar"><nav class="full-menu"><ul id="menu-site-wide-menu" class="thb-full-menu thb-standard"><li id="menu-item-1743" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-1743"><a href="https://socialitelife.com/category/entertainment/"><span>Entertainment</span></a><ul class="sub-menu "><li id="menu-item-16713" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16713"><a href="https://socialitelife.com/category/entertainment/celebrity/"><span>Celebrity</span></a></li><li id="menu-item-16125" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16125"><a href="https://socialitelife.com/category/entertainment/movies/"><span>Movies</span></a></li><li id="menu-item-16124" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-16124"><a href="https://socialitelife.com/category/entertainment/tv/"><span>TV</span></a></li><li id="menu-item-16123" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16123"><a href="https://socialitelife.com/category/entertainment/music/"><span>Music</span></a></li><li id="menu-item-16126" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16126"><a href="https://socialitelife.com/category/fashion/"><span>Fashion</span></a></li><li id="menu-item-20600" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20600"><a href="https://socialitelife.com/tag/podcasts/"><span>Podcasts</span></a></li><li id="menu-item-23688" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23688"><a href="https://socialitelife.com/category/real-housewives/"><span>Real Housewives</span></a></li><li id="menu-item-528" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-528"><a href="https://socialitelife.com/category/sl-flashback/"><span>SL Flashback</span></a></li></ul></li><li id="menu-item-16712" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-16712"><a href="https://socialitelife.com/category/drag-queens/"><span>Drag Queens</span></a><ul class="sub-menu "><li id="menu-item-14251" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14251"><a href="https://socialitelife.com/tag/the-week-in-drag/"><span>The Week in Drag</span></a></li><li id="menu-item-10323" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10323"><a href="https://socialitelife.com/tag/rupauls-drag-race/"><span>RuPaul&#8217;s Drag Race</span></a></li><li id="menu-item-41509" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41509"><a href="https://socialitelife.com/tag/rupauls-drag-race-all-stars/"><span>RuPaul&#8217;s Drag Race All Stars</span></a></li><li id="menu-item-23598" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23598"><a href="https://socialitelife.com/tag/rupauls-drag-race-uk/"><span>RuPaul&#8217;s Drag Race UK</span></a></li></ul></li><li id="menu-item-326" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-326"><a href="https://socialitelife.com/category/eye-candy/"><span>Eye Candy</span></a><ul class="sub-menu "><li id="menu-item-1762" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1762"><a href="https://socialitelife.com/tag/man-candy"><span>Insta Snaps</span></a></li><li id="menu-item-1760" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1760"><a href="https://socialitelife.com/tag/instahottie"><span>Instahottie</span></a></li><li id="menu-item-1761" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1761"><a href="https://socialitelife.com/tag/male-model-monday"><span>Male Model Monday</span></a></li><li id="menu-item-73349" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-73349"><a href="https://socialitelife.com/tag/male-model-spotlight/"><span>Male Model Spotlight</span></a></li></ul></li><li id="menu-item-7032" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-7032"><a href="https://socialitelife.com/category/interviews/"><span>Interviews</span></a><ul class="sub-menu "><li id="menu-item-25651" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-25651"><a href="https://socialitelife.com/tag/socialite-seven/"><span>Socialite Seven</span></a></li></ul></li><li id="menu-item-1765" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1765"><a href="https://socialitelife.com/tag/photos"><span>Photos</span></a></li><li id="menu-item-51007" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-51007"><a href="#"><span>Videos</span></a><ul class="sub-menu "><li id="menu-item-51008" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51008"><a href="https://socialitelife.com/category/viral-video/"><span>Viral Video</span></a></li><li id="menu-item-35309" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35309"><a href="https://socialitelife.com/celebrity-news/"><span>Celebrity News</span></a></li><li id="menu-item-35314" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35314"><a href="https://socialitelife.com/movie-trailer-park/"><span>Movie Trailer Park</span></a></li><li id="menu-item-35311" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35311"><a href="https://socialitelife.com/tv-highlights-and-trailers/"><span>TV Highlights and Trailers</span></a></li><li id="menu-item-35308" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35308"><a href="https://socialitelife.com/netflix-and-chill/"><span>Netflix and Chill</span></a></li><li id="menu-item-35310" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35310"><a href="https://socialitelife.com/sls-pop-music-playlist/"><span>SL’s Pop Music Playlist</span></a></li><li id="menu-item-38919" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38919"><a href="https://socialitelife.com/in-real-life/"><span>In Real Life</span></a></li><li id="menu-item-35312" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35312"><a href="https://socialitelife.com/male-models/"><span>Fashion</span></a></li><li id="menu-item-35313" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35313"><a href="https://socialitelife.com/drag-queen-fabulosity/"><span>Drag Queen Fabulosity</span></a></li></ul></li><li id="menu-item-14069" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14069"><a href="https://amzn.to/2RI8nUF"><span>SL Shop</span></a></li><li id="menu-item-49221" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49221"><a href="https://socialitelife.com/partners/"><span>Partners</span></a></li></ul></nav></div></div></div></header><div role="main"><div id="infinite-article" data-infinite="off" data-security="5c7097d77a"><div class="post-detail-row has-article-padding"><div class="row"><div class="small-12 columns"><article itemscope itemtype="http://schema.org/Article" class="post post-detail post-detail-style4 post-74581 type-post status-publish format-standard has-post-thumbnail hentry category-tv tag-the-great-british-baking-show tag-tv-talk mv-content-wrapper thb-post-share-style1" id="post-74581" data-id="74581" data-url="https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/"><div class="post-title-container"><aside class="post-category post-detail-category"> <a href="https://socialitelife.com/category/entertainment/tv/" rel="category tag">TV</a></aside><header class="post-title entry-header"><h1 class="entry-title" itemprop="headline"> The Great British Baking Show — Biscuit Week (TV Talk)</h1></header><div class="thb-post-title-bottom thb-post-share-style1"><div class="thb-post-title-inline-author"><div class="author-and-date"><div class="post-author thb-post-author-4"> <em>by</em> <a href="https://socialitelife.com/author/miu/" title="Posts by Miu von Furstenberg" rel="author">Miu von Furstenberg</a></div><div class="thb-post-date"> September 27, 2022</div></div></div></div></div><div class="article-container"><div class="post-content-wrapper"><div class="thb-article-featured-image "
 data-override="off"> <img width="1280" height="705" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/Bake-Off-4085-Large.jpeg?fit=20%2C11&amp;ssl=1" class="attachment-theissue-full-x2 size-theissue-full-x2 thb-lazyload lazyload wp-post-image" alt="The Great British Baking Show — Biscuit Week" sizes="(max-width: 1280px) 100vw, 1280px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/Bake-Off-4085-Large.jpeg?fit=1280%2C705&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/Bake-Off-4085-Large.jpeg?w=1280&amp;ssl=1 1280w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/Bake-Off-4085-Large.jpeg?resize=800%2C441&amp;ssl=1 800w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/Bake-Off-4085-Large.jpeg?resize=1160%2C639&amp;ssl=1 1160w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/Bake-Off-4085-Large.jpeg?resize=370%2C204&amp;ssl=1 370w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/Bake-Off-4085-Large.jpeg?resize=20%2C11&amp;ssl=1 20w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/Bake-Off-4085-Large.jpeg?resize=185%2C102&amp;ssl=1 185w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/Bake-Off-4085-Large.jpeg?resize=740%2C408&amp;ssl=1 740w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/Bake-Off-4085-Large.jpeg?resize=400%2C220&amp;ssl=1 400w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/Bake-Off-4085-Large.jpeg?resize=87%2C48&amp;ssl=1 87w" /><div class="featured_image_credit">Screenshot via YouTube</div></div><div class="thb-post-share-container"><div class="thb-fixed-container"><div class="thb-fixed-top"><div class="thb-article-author"><div class="author-content"> <a href="https://socialitelife.com/author/miu/" rel="author">Miu von Furstenberg</a><p></p></div></div><div class="thb-fixed-shares-container"><div class="thb-fixed sticky-post-shares"><div class="thb-social-top style1 sharing-counts-off"><div class="thb-social-top-buttons"><div class="social-button-holder"> <a href="https://twitter.com/intent/tweet?text=The%20Great%20British%20Baking%20Show —%20Biscuit%20Week (TV%20Talk)&#038;via=socialitelife&#038;url=https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/" rel="noreferrer" class="social social-twitter"
 > <span class="thb-social-icon"> <i class="thb-icon-twitter"></i> </span> </a></div><div class="social-button-holder"> <a href="https://www.facebook.com/sharer.php?u=https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/" rel="noreferrer" class="social social-facebook"
 > <span class="thb-social-icon"> <i class="thb-icon-facebook"></i> </span> </a></div><div class="social-button-holder"> <a href="https://pinterest.com/pin/create/bookmarklet/?url=https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/&#038;media=https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/Bake-Off-4085-Large.jpeg?fit=1280%2C705&#038;ssl=1" rel="noreferrer" class="social social-pinterest"
 > <span class="thb-social-icon"> <i class="thb-icon-pinterest"></i> </span> </a></div><div class="social-button-holder"> <a href="https://reddit.com/submit?url=https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/" rel="noreferrer" class="social social-reddit"
 > <span class="thb-social-icon"> <i class="thb-icon-reddit"></i> </span> </a></div><div class="social-button-holder"> <a href="https://share.flipboard.com/bookmarklet/popout?v=2&#038;title=The%20Great%20British%20Baking%20Show —%20Biscuit%20Week (TV%20Talk)&#038;url=https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/" rel="noreferrer" class="social social-flipboard"
 > <span class="thb-social-icon"> <i class="thb-icon-flipboard"></i> </span> </a></div><div class="social-button-holder"> <a href="https://www.linkedin.com/cws/share?url=https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/" rel="noreferrer" class="social social-linkedin"
 > <span class="thb-social-icon"> <i class="thb-icon-linkedin"></i> </span> </a></div><div class="social-button-holder"> <a href="https://wa.me/?text=The%20Great%20British%20Baking%20Show —%20Biscuit%20Week (TV%20Talk)%20https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/" rel="noreferrer" class="social social-whatsapp"
 data-action="share/whatsapp/share"> <span class="thb-social-icon"> <i class="thb-icon-whatsapp"></i> </span> </a></div><div class="social-button-holder"> <a href="/cdn-cgi/l/email-protection#dce3afa9beb6b9bfa8e188b4b9f9eeec9baeb9bda8f9eeec9eaeb5a8b5afb4f9eeec9ebdb7b5b2bbf9eeec8fb4b3ab1e7c3e5c48f9eeec9eb5afbfa9b5a8f9eeec8bb9b9b71e7cf4888af9eeec88bdb0b7f5faffecefe4e7beb3b8a5e188b4b9f9eeec9baeb9bda8f9eeec9eaeb5a8b5afb4f9eeec9ebdb7b5b2bbf9eeec8fb4b3ab1e7c3e5c48f9eeec9eb5afbfa9b5a8f9eeec8bb9b9b71e7cf4888af9eeec88bdb0b7f5f9eeecb4a8a8acafe6f3f3afb3bfb5bdb0b5a8b9b0b5bab9f2bfb3b1f3a8b4b9f1bbaeb9bda8f1beaeb5a8b5afb4f1bebdb7b5b2bbf1afb4b3abf1beb5afbfa9b5a8f1abb9b9b7f1a8aaf1a8bdb0b7f3" rel="noreferrer" class="social social-email"> <span class="thb-social-icon"> <i class="thb-icon-mail"></i> </span> </a></div></div></div></div></div></div></div><div class="post-content-container"><div class="post-content entry-content" itemprop="articleBody"><p>Biscuits. Cookies. Whatever you call them, they’re delicious.</p><p>As a consumer of way too much television, I am sharing my thoughts on a few of my favorite TV shows. Here are a few of my miusings [sic] regarding the Biscuit Week episode from <strong><em><a href="/tag/the-great-british-baking-show">The Great British Baking Show</a></em></strong>:</p><h2>SPOILER ALERT</h2><p>Here is a run-through of the new batch of bakers and how they fared their second week in the tent.</p><p><strong>Abdul</strong> &#8211; Biscuits were hit or miss for Abdul. His macaroons had too much coffee in them, he came in last place in the technical challenge with his 12 garibaldi biscuits but redeemed himself in the Showstopper challenge with his 3-D parrot mask.</p><p><strong>Rebs</strong> &#8211; While Rebs won the technical challenge, she struggled with her macaroons and her mask was kind of boring and on the small side.</p><p><strong>Dawn</strong> &#8211; Dawn got the first handshake of the season for her macaroons. Sadly, her 12 garibaldi biscuits were too dark, but she redeemed herself with her macabre mask in the showstopper.</p><p><strong>Carole</strong> &#8211; Carole had the first dessert disaster of the season when here mask collapsed. This landed Carole in the bottom, but luckily her flavors saved her.</p><figure class="wp-block-image size-large"><img loading="lazy" width="1160" height="870" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://socialitelife.com/wp-content/uploads/2022/09/0_Bake-off-1160x870.jpg" alt="The Great British Baking Show — Biscuit Week" class="wp-image-74588 lazyload" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/0_Bake-off.jpg?resize=1160%2C870&amp;ssl=1 1160w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/0_Bake-off.jpg?resize=800%2C600&amp;ssl=1 800w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/0_Bake-off.jpg?resize=320%2C240&amp;ssl=1 320w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/0_Bake-off.jpg?resize=370%2C278&amp;ssl=1 370w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/0_Bake-off.jpg?resize=20%2C15&amp;ssl=1 20w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/0_Bake-off.jpg?resize=185%2C139&amp;ssl=1 185w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/0_Bake-off.jpg?resize=740%2C555&amp;ssl=1 740w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/0_Bake-off.jpg?resize=400%2C300&amp;ssl=1 400w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/0_Bake-off.jpg?resize=64%2C48&amp;ssl=1 64w" sizes="(max-width: 1160px) 100vw, 1160px" /></figure><p><strong>Kevin</strong> &#8211; Kevin’s ice cream cone macaroons had too strong of a flavor, and he didn’t fair that great in the other challenges either.</p><p><strong>Maisam</strong> &#8211; The youngest baker at 18 had a very rough week and ended up being the baker who was sent home. Too strong flavors and simple designs are what ended up doing Maisam in.</p><p><strong>Maxy</strong> &#8211; Maxy was the recipient of the second Paul Hollywood handshake of the season for her delightful daisy macaroons. Maxy kept the momentum going throughout the bakes (that mask was quite impressive) and was able to win Star Baker.</p><p><strong>James</strong> &#8211; James had a pretty decent week. A big improvement for his first go round. His horror creature mask was a sight to behold.</p><div class="post thumbnail-seealso post-74416 type-post status-publish format-standard has-post-thumbnail hentry category-tv tag-the-great-british-baking-show tag-tv-talk mv-content-wrapper thb-post-share-style1"> <span class="thb-seealso-text">See Also</span><figure class="post-gallery"> <a href="https://socialitelife.com/the-great-british-baking-show-cake-week-tv-talk/"><img width="180" height="180" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/74086_S6_The-Great-British-Bake-Off-S6-89-1.jpg?resize=20%2C20&amp;ssl=1" class="attachment-theissue-thumbnail-x2 size-theissue-thumbnail-x2 thb-lazyload lazyload wp-post-image" alt="The Great British Bake Off S6" loading="lazy" sizes="(max-width: 180px) 100vw, 180px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/74086_S6_The-Great-British-Bake-Off-S6-89-1.jpg?resize=180%2C180&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/74086_S6_The-Great-British-Bake-Off-S6-89-1.jpg?resize=180%2C180&amp;ssl=1 180w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/74086_S6_The-Great-British-Bake-Off-S6-89-1.jpg?resize=90%2C90&amp;ssl=1 90w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/74086_S6_The-Great-British-Bake-Off-S6-89-1.jpg?resize=20%2C19&amp;ssl=1 20w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/74086_S6_The-Great-British-Bake-Off-S6-89-1.jpg?zoom=2&amp;resize=180%2C180&amp;ssl=1 360w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/74086_S6_The-Great-British-Bake-Off-S6-89-1.jpg?zoom=3&amp;resize=180%2C180&amp;ssl=1 540w" /></a></figure><div class="thumbnail-seealso-inner"><aside class="post-category "> <a href="https://socialitelife.com/category/entertainment/tv/" rel="category tag">TV</a></aside><div class="post-title"><h6><a href="https://socialitelife.com/the-great-british-baking-show-cake-week-tv-talk/" title="The Great British Baking Show — Cake Week (TV Talk)"><span>The Great British Baking Show — Cake Week (TV Talk)</span></a></h6></div></div></div></p><p><strong>Syabira</strong> &#8211; Syabira brought the comic relief in the technical challenge when she confused feathering the chocolate on the side of her biscuit with white chocolate meant to make a white-chocolate feather to put on top of them. She’s adorable.</p><p><strong>Sandro</strong> &#8211; We got a glimpse of Sandro working out so that was a treat. As for the baking, his macaroon burgers turned out pretty well, and he was in the top three for the technical challenge, and his carnival mask which was inspired by fighting gender stereotypes was very pretty and deemed delicious.</p><figure class="wp-block-image size-full"><img loading="lazy" width="854" height="1280" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://socialitelife.com/wp-content/uploads/2022/09/bake-off-week-two-dog-rough-garibaldis-and-mild-sa-bake-off-week-two-dog-rough-garibaldis-and-mild-sa-1572357219961769984-Large.jpeg" alt="The Great British Baking Show — Biscuit Week" class="wp-image-74586 lazyload" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/bake-off-week-two-dog-rough-garibaldis-and-mild-sa-bake-off-week-two-dog-rough-garibaldis-and-mild-sa-1572357219961769984-Large.jpeg?w=854&amp;ssl=1 854w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/bake-off-week-two-dog-rough-garibaldis-and-mild-sa-bake-off-week-two-dog-rough-garibaldis-and-mild-sa-1572357219961769984-Large.jpeg?resize=800%2C1199&amp;ssl=1 800w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/bake-off-week-two-dog-rough-garibaldis-and-mild-sa-bake-off-week-two-dog-rough-garibaldis-and-mild-sa-1572357219961769984-Large.jpeg?resize=370%2C555&amp;ssl=1 370w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/bake-off-week-two-dog-rough-garibaldis-and-mild-sa-bake-off-week-two-dog-rough-garibaldis-and-mild-sa-1572357219961769984-Large.jpeg?resize=185%2C277&amp;ssl=1 185w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/bake-off-week-two-dog-rough-garibaldis-and-mild-sa-bake-off-week-two-dog-rough-garibaldis-and-mild-sa-1572357219961769984-Large.jpeg?resize=740%2C1109&amp;ssl=1 740w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/bake-off-week-two-dog-rough-garibaldis-and-mild-sa-bake-off-week-two-dog-rough-garibaldis-and-mild-sa-1572357219961769984-Large.jpeg?resize=20%2C30&amp;ssl=1 20w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/bake-off-week-two-dog-rough-garibaldis-and-mild-sa-bake-off-week-two-dog-rough-garibaldis-and-mild-sa-1572357219961769984-Large.jpeg?resize=400%2C600&amp;ssl=1 400w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/bake-off-week-two-dog-rough-garibaldis-and-mild-sa-bake-off-week-two-dog-rough-garibaldis-and-mild-sa-1572357219961769984-Large.jpeg?resize=32%2C48&amp;ssl=1 32w" sizes="(max-width: 854px) 100vw, 854px" /></figure><p><strong>Janusz </strong>&#8211; Last week’s Star Baker fared pretty well again this week. His mask was a mashup of LGBTQ colors and cubism, and he was praised for his flavors.</p><figure class="wp-block-image size-large"><img loading="lazy" width="1160" height="653" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" data-src="https://socialitelife.com/wp-content/uploads/2022/09/Screenshotter-TheGreatBritishBakingShowE2BiscuitWeek-6052-1160x653.jpg" alt="The Great British Baking Show — Biscuit Week" class="wp-image-74587 lazyload" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/Screenshotter-TheGreatBritishBakingShowE2BiscuitWeek-6052.jpg?resize=1160%2C653&amp;ssl=1 1160w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/Screenshotter-TheGreatBritishBakingShowE2BiscuitWeek-6052.jpg?resize=800%2C450&amp;ssl=1 800w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/Screenshotter-TheGreatBritishBakingShowE2BiscuitWeek-6052.jpg?resize=370%2C208&amp;ssl=1 370w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/Screenshotter-TheGreatBritishBakingShowE2BiscuitWeek-6052.jpg?resize=20%2C11&amp;ssl=1 20w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/Screenshotter-TheGreatBritishBakingShowE2BiscuitWeek-6052.jpg?resize=185%2C104&amp;ssl=1 185w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/Screenshotter-TheGreatBritishBakingShowE2BiscuitWeek-6052.jpg?resize=740%2C416&amp;ssl=1 740w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/Screenshotter-TheGreatBritishBakingShowE2BiscuitWeek-6052.jpg?resize=400%2C225&amp;ssl=1 400w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/Screenshotter-TheGreatBritishBakingShowE2BiscuitWeek-6052.jpg?resize=85%2C48&amp;ssl=1 85w" sizes="(max-width: 1160px) 100vw, 1160px" /></figure><p>My very early picks for the final three are Sandro, Janusz, and Dawn, with Abdul and Maxy close behind.</p><div style="height:100px" aria-hidden="true" class="wp-block-spacer"></div><hr class="wp-block-separator"/><h3 class="has-text-align-center">THE LATEST ON SL</h3><div class="wp-container-1 wp-block-group"><div class="wp-block-group__inner-container"><div data-elink="https://elink.io/embed/9c6c8ac"><a href="https://elink.io" target="_blank" rel="noopener">elink.io</a> | <a href="https://elink.io/p/socialite-links-9c6c8ac" target="_blank" rel="noopener">See Original</a></div><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async="" src="https://d1sf3a4rercrry.cloudfront.net/embed.js" charset="utf-8"></script> </div></div><div style="height:25px" aria-hidden="true" class="wp-block-spacer"></div><div class="wp-container-3 wp-block-group"><div class="wp-block-group__inner-container"><h2 class="has-text-align-center"><strong>FROM OUR PARTNERS</strong></h2><div class="wp-container-2 wp-block-group"><div class="wp-block-group__inner-container"><div data-elink="https://elink.io/embed/9c819b3"><a href="https://elink.io" target="_blank" rel="noopener">elink.io</a> | <a href="https://elink.io/p/9c819b3" target="_blank" rel="noopener">See Original</a></div><script async src="https://d1sf3a4rercrry.cloudfront.net/embed.js" charset="utf-8"></script> </div></div></div></div><p></p><div class="pubexchange_module" id="pubexchange_below_content" data-pubexchange-module-id="2065"></div></div><div class="thb-article-tags"> <span>Tags</span><div> <a href="https://socialitelife.com/tag/the-great-british-baking-show/" title="">The Great British Baking Show</a> <a href="https://socialitelife.com/tag/tv-talk/" title="">TV Talk</a></div></div><div class="thb-social-fixed sharing-counts-off"><div class="social-button-holder"> <a href="https://www.facebook.com/sharer.php?u=https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/" class="social social-facebook"
 > <span class="thb-social-icon"> <i class="thb-icon-facebook"></i> </span> </a></div><div class="social-button-holder"> <a href="https://twitter.com/intent/tweet?text=The%20Great%20British%20Baking%20Show —%20Biscuit%20Week (TV%20Talk)&#038;via=socialitelife&#038;url=https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/" class="social social-twitter"
 > <span class="thb-social-icon"> <i class="thb-icon-twitter"></i> </span> </a></div><div class="social-button-holder"> <a href="https://pinterest.com/pin/create/bookmarklet/?url=https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/&#038;media=https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/Bake-Off-4085-Large.jpeg?fit=1280%2C705&#038;ssl=1" class="social social-pinterest"
 > <span class="thb-social-icon"> <i class="thb-icon-pinterest"></i> </span> </a></div><div class="social-button-holder"> <a href="https://reddit.com/submit?url=https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/" class="social social-reddit"
 > <span class="thb-social-icon"> <i class="thb-icon-reddit"></i> </span> </a></div><div class="social-button-holder"> <a href="https://share.flipboard.com/bookmarklet/popout?v=2&#038;title=The%20Great%20British%20Baking%20Show —%20Biscuit%20Week (TV%20Talk)&#038;url=https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/" class="social social-flipboard"
 > <span class="thb-social-icon"> <i class="thb-icon-flipboard"></i> </span> </a></div><div class="social-button-holder"> <a href="https://www.linkedin.com/cws/share?url=https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/" class="social social-linkedin"
 > <span class="thb-social-icon"> <i class="thb-icon-linkedin"></i> </span> </a></div><div class="social-button-holder"> <a href="/cdn-cgi/l/email-protection#27185452454d4244531a734f42021517605542465302151765554e534e544f02151765464c4e4940021517744f4850e587c5a7b3021517654e5444524e530215177042424ce5870f737102151773464b4c0e010417141f1c4548435e1a734f42021517605542465302151765554e534e544f02151765464c4e4940021517744f4850e587c5a7b3021517654e5444524e530215177042424ce5870f737102151773464b4c0e0215174f535357541d08085448444e464b4e53424b4e41420944484a08534f420a40554246530a45554e534e544f0a45464c4e49400a544f48500a454e5444524e530a5042424c0a53510a53464b4c08" class="social social-email"> <span class="thb-social-icon"> <i class="thb-icon-mail"></i> </span> </a></div></div><aside class="post-bottom-meta hide"><meta itemprop="mainEntityOfPage" content="https://socialitelife.com/the-great-british-baking-show-biscuit-week-tv-talk/"> <span class="vcard author" itemprop="author" content="Miu von Furstenberg"> <span class="fn">Miu von Furstenberg</span> </span> <time class="time publised entry-date" datetime="2022-09-27T18:37:02-05:00" itemprop="datePublished" content="2022-09-27T18:37:02-05:00">September 27, 2022</time><meta itemprop="dateModified" class="updated" content="2022-09-27T18:37:04-05:00"> <span itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="Socialite Life"> <span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://socialitelife.com/wp-content/uploads/2020/04/SL-Wig-banner-600.jpg"> </span> </span> <span itemprop="image" itemscope itemtype="http://schema.org/ImageObject"><meta itemprop="url" content="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/Bake-Off-4085-Large.jpeg?fit=1280%2C705&amp;ssl=1"><meta itemprop="width" content="1280" /><meta itemprop="height" content="705" /> </span></aside></div></div></div><aside class="sidebar"><div id="thb_posts_widget-18" class="widget style1 thb_widget_posts"><div class="thb-widget-title"><span>POPULAR</div></span><div class="post thumbnail-style4  post-74437 type-post status-publish format-standard has-post-thumbnail hentry category-eye-candy category-fashion tag-jake-hobbs tag-male-model-spotlight tag-models tag-photos tag-video mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <a href="https://socialitelife.com/jake-hobbs-male-model-spotlight/"> <img width="180" height="180" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/jake-hobbs-photos-09212022-1.jpg?resize=20%2C20&amp;ssl=1" class="attachment-theissue-thumbnail-x2 size-theissue-thumbnail-x2 thb-lazyload lazyload wp-post-image" alt="Jake Hobbs" loading="lazy" sizes="(max-width: 180px) 100vw, 180px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/jake-hobbs-photos-09212022-1.jpg?resize=180%2C180&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/jake-hobbs-photos-09212022-1.jpg?resize=180%2C180&amp;ssl=1 180w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/jake-hobbs-photos-09212022-1.jpg?resize=90%2C90&amp;ssl=1 90w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/jake-hobbs-photos-09212022-1.jpg?resize=20%2C19&amp;ssl=1 20w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/jake-hobbs-photos-09212022-1.jpg?zoom=2&amp;resize=180%2C180&amp;ssl=1 360w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/jake-hobbs-photos-09212022-1.jpg?zoom=3&amp;resize=180%2C180&amp;ssl=1 540w" /> </a></figure><div class="thumbnail-style4-inner"><div class="post-title"><h6><a href="https://socialitelife.com/jake-hobbs-male-model-spotlight/" title="Jake Hobbs: Male Model Spotlight"><span>Jake Hobbs: Male Model Spotlight</span></a></h6></div><aside class="thb-post-bottom"><ul><li class="post-date">September 23, 2022</li><li class="post-read">1 min Read</li></ul></aside></div></div><div class="post thumbnail-style4  post-74426 type-post status-publish format-standard has-post-thumbnail hentry category-celebrity category-featured category-video tag-howard-stern tag-jon-hamm tag-video mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <a href="https://socialitelife.com/jon-hamm-keeps-his-sausage-rolled/"> <img width="180" height="180" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/jon-hamm-anna-osceola-46.jpeg?resize=20%2C20&amp;ssl=1" class="attachment-theissue-thumbnail-x2 size-theissue-thumbnail-x2 thb-lazyload lazyload wp-post-image" alt="Jon Hamm Howard Stern" loading="lazy" sizes="(max-width: 180px) 100vw, 180px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/jon-hamm-anna-osceola-46.jpeg?resize=180%2C180&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/jon-hamm-anna-osceola-46.jpeg?resize=180%2C180&amp;ssl=1 180w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/jon-hamm-anna-osceola-46.jpeg?resize=90%2C90&amp;ssl=1 90w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/jon-hamm-anna-osceola-46.jpeg?resize=20%2C19&amp;ssl=1 20w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/jon-hamm-anna-osceola-46.jpeg?zoom=2&amp;resize=180%2C180&amp;ssl=1 360w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/jon-hamm-anna-osceola-46.jpeg?zoom=3&amp;resize=180%2C180&amp;ssl=1 540w" /> </a></figure><div class="thumbnail-style4-inner"><div class="post-title"><h6><a href="https://socialitelife.com/jon-hamm-keeps-his-sausage-rolled/" title="Jon Hamm keeps his sausage rolled"><span>Jon Hamm keeps his sausage rolled</span></a></h6></div><aside class="thb-post-bottom"><ul><li class="post-date">September 21, 2022</li><li class="post-read">2 mins Read</li></ul></aside></div></div><div class="post thumbnail-style4  post-74299 type-post status-publish format-standard has-post-thumbnail hentry category-eye-candy category-featured tag-carlos-plaza-belda tag-instahottie tag-photos mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <a href="https://socialitelife.com/meet-instagram-hottie-carlos-plaza-belda/"> <img width="180" height="180" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/carlos-plaza-belda-photos-09162022-1.jpg?resize=20%2C20&amp;ssl=1" class="attachment-theissue-thumbnail-x2 size-theissue-thumbnail-x2 thb-lazyload lazyload wp-post-image" alt="Carlos Plaza Belda" loading="lazy" sizes="(max-width: 180px) 100vw, 180px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/carlos-plaza-belda-photos-09162022-1.jpg?resize=180%2C180&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/carlos-plaza-belda-photos-09162022-1.jpg?resize=180%2C180&amp;ssl=1 180w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/carlos-plaza-belda-photos-09162022-1.jpg?resize=90%2C90&amp;ssl=1 90w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/carlos-plaza-belda-photos-09162022-1.jpg?resize=20%2C19&amp;ssl=1 20w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/carlos-plaza-belda-photos-09162022-1.jpg?zoom=2&amp;resize=180%2C180&amp;ssl=1 360w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/carlos-plaza-belda-photos-09162022-1.jpg?zoom=3&amp;resize=180%2C180&amp;ssl=1 540w" /> </a></figure><div class="thumbnail-style4-inner"><div class="post-title"><h6><a href="https://socialitelife.com/meet-instagram-hottie-carlos-plaza-belda/" title="Meet Instagram hottie Carlos Plaza Belda"><span>Meet Instagram hottie Carlos Plaza Belda</span></a></h6></div><aside class="thb-post-bottom"><ul><li class="post-date">September 17, 2022</li><li class="post-read">1 min Read</li></ul></aside></div></div></div></aside></div></article><div class="thb-article-nav previous"><div class="post post-nav featured-style center-contents post-74570 type-post status-publish format-standard has-post-thumbnail hentry category-celebrity tag-legal-matters tag-shakira mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <img width="370" height="355" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/shakira-09272022.jpg?resize=20%2C19&amp;ssl=1" class="attachment-theissue-square size-theissue-square thb-lazyload lazyload wp-post-image" alt="Shakira" loading="lazy" sizes="(max-width: 370px) 100vw, 370px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/shakira-09272022.jpg?resize=370%2C355&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/shakira-09272022.jpg?resize=370%2C355&amp;ssl=1 370w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/shakira-09272022.jpg?resize=20%2C19&amp;ssl=1 20w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/shakira-09272022.jpg?zoom=2&amp;resize=370%2C355&amp;ssl=1 740w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/shakira-09272022.jpg?zoom=3&amp;resize=370%2C355&amp;ssl=1 1110w" /></figure><div class="post-inner-content"><aside class="post-category "> <a href="https://socialitelife.com/category/entertainment/celebrity/" rel="category tag">Celebrity</a></aside><div class="post-title"><h6><a href="https://socialitelife.com/spanish-court-orders-shakira-to-stand-trial-in-tax-fraud-case/" title="Spanish court orders Shakira to stand trial in tax fraud case"><span>Spanish court orders Shakira to stand trial in tax fraud case</span></a></h6></div></div></div> <span class="thb-article-nav-text">Previous Article</span></div><div class="row hide-on-print"><aside class="small-12 columns related-posts related-posts-style2"><h6 class="related-posts-title">Related Posts</h6><div class="row
 "><div class="small-6 medium-6 large-3 columns"><div class="post style2 post-74549 type-post status-publish format-standard has-post-thumbnail hentry category-tv tag-house-of-the-dragon tag-tv-talk mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <a href="https://socialitelife.com/house-of-the-dragon-the-princess-and-the-queen-tv-talk/"><img width="740" height="675" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/house-of-dragon-main-09262022.jpg?resize=20%2C19&amp;ssl=1" class="attachment-theissue-square-x2 size-theissue-square-x2 thb-lazyload lazyload wp-post-image" alt="House of the Dragon — The Princess and the Queen" loading="lazy" sizes="(max-width: 740px) 100vw, 740px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/house-of-dragon-main-09262022.jpg?resize=740%2C675&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/house-of-dragon-main-09262022.jpg?resize=740%2C675&amp;ssl=1 740w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/house-of-dragon-main-09262022.jpg?resize=20%2C19&amp;ssl=1 20w" /></a></figure><aside class="post-category "> <a href="https://socialitelife.com/category/entertainment/tv/" rel="category tag">TV</a></aside><div class="post-title"><h6><a href="https://socialitelife.com/house-of-the-dragon-the-princess-and-the-queen-tv-talk/" title="House of the Dragon — &#8216;The Princess and the Queen&#8217; (TV Talk)"><span>House of the Dragon — &#8216;The Princess and the Queen&#8217; (TV Talk)</span></a></h6></div></div></div><div class="small-6 medium-6 large-3 columns"><div class="post style2 post-74416 type-post status-publish format-standard has-post-thumbnail hentry category-tv tag-the-great-british-baking-show tag-tv-talk mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <a href="https://socialitelife.com/the-great-british-baking-show-cake-week-tv-talk/"><img width="740" height="675" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/74086_S6_The-Great-British-Bake-Off-S6-89-1.jpg?resize=20%2C19&amp;ssl=1" class="attachment-theissue-square-x2 size-theissue-square-x2 thb-lazyload lazyload wp-post-image" alt="The Great British Bake Off S6" loading="lazy" sizes="(max-width: 740px) 100vw, 740px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/74086_S6_The-Great-British-Bake-Off-S6-89-1.jpg?resize=740%2C675&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/74086_S6_The-Great-British-Bake-Off-S6-89-1.jpg?resize=740%2C675&amp;ssl=1 740w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/74086_S6_The-Great-British-Bake-Off-S6-89-1.jpg?resize=20%2C19&amp;ssl=1 20w" /></a></figure><aside class="post-category "> <a href="https://socialitelife.com/category/entertainment/tv/" rel="category tag">TV</a></aside><div class="post-title"><h6><a href="https://socialitelife.com/the-great-british-baking-show-cake-week-tv-talk/" title="The Great British Baking Show — Cake Week (TV Talk)"><span>The Great British Baking Show — Cake Week (TV Talk)</span></a></h6></div></div></div><div class="small-6 medium-6 large-3 columns"><div class="post style2 post-74366 type-post status-publish format-standard has-post-thumbnail hentry category-tv tag-house-of-the-dragon tag-tv-talk mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <a href="https://socialitelife.com/house-of-the-dragon-we-light-the-way-tv-talk/"><img width="740" height="675" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/house-of-the-dragon-main-09192022.jpg?resize=20%2C19&amp;ssl=1" class="attachment-theissue-square-x2 size-theissue-square-x2 thb-lazyload lazyload wp-post-image" alt="House of the Dragon — &#039;We Light the Way&#039;" loading="lazy" sizes="(max-width: 740px) 100vw, 740px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/house-of-the-dragon-main-09192022.jpg?resize=740%2C675&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/house-of-the-dragon-main-09192022.jpg?resize=740%2C675&amp;ssl=1 740w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/09/house-of-the-dragon-main-09192022.jpg?resize=20%2C19&amp;ssl=1 20w" /></a></figure><aside class="post-category "> <a href="https://socialitelife.com/category/entertainment/tv/" rel="category tag">TV</a></aside><div class="post-title"><h6><a href="https://socialitelife.com/house-of-the-dragon-we-light-the-way-tv-talk/" title="House of the Dragon — ‘We Light the Way’ (TV Talk)"><span>House of the Dragon — ‘We Light the Way’ (TV Talk)</span></a></h6></div></div></div><div class="small-6 medium-6 large-3 columns"><div class="post style2 post-63476 type-post status-publish format-standard has-post-thumbnail hentry category-tv tag-netflix tag-the-great-british-baking-show mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <a href="https://socialitelife.com/the-great-british-baking-show-returns-with-new-episodes-on-netflix-this-month/"><img width="740" height="675" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2021/09/great-british-baking-show-09092021.jpg?resize=20%2C19&amp;ssl=1" class="attachment-theissue-square-x2 size-theissue-square-x2 thb-lazyload lazyload wp-post-image" alt="The Great British Baking Show" loading="lazy" sizes="(max-width: 740px) 100vw, 740px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2021/09/great-british-baking-show-09092021.jpg?resize=740%2C675&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2021/09/great-british-baking-show-09092021.jpg?resize=740%2C675&amp;ssl=1 740w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2021/09/great-british-baking-show-09092021.jpg?resize=20%2C19&amp;ssl=1 20w" /></a></figure><aside class="post-category "> <a href="https://socialitelife.com/category/entertainment/tv/" rel="category tag">TV</a></aside><div class="post-title"><h6><a href="https://socialitelife.com/the-great-british-baking-show-returns-with-new-episodes-on-netflix-this-month/" title="The Great British Baking Show returns with new episodes on Netflix this month"><span>The Great British Baking Show returns with new episodes on Netflix this month</span></a></h6></div></div></div><div class="small-6 medium-6 large-3 columns"><div class="post style2 post-50974 type-post status-publish format-standard has-post-thumbnail hentry category-drag-queens category-featured tag-bob-the-drag-queen tag-derry-girls tag-divina-de-campo tag-jaymes-mansfield tag-jonathan-van-ness tag-katya tag-monet-x-change tag-nina-west tag-noel-fielding tag-paul-hollywood tag-rupauls-drag-race tag-rupauls-drag-race-uk tag-sum-ting-wong tag-the-great-british-baking-show tag-the-week-in-drag tag-trixie-mattel tag-willam tag-yuhua-hamasaki tag-yvie-oddly mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <a href="https://socialitelife.com/week-in-drag-season-13-queens-2/"><img width="740" height="675" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2021/01/rupuals-drag-races-season-13-cast.jpg?resize=20%2C19&amp;ssl=1" class="attachment-theissue-square-x2 size-theissue-square-x2 thb-lazyload lazyload wp-post-image" alt="RuPauls Drag Race Season 13 cast" loading="lazy" sizes="(max-width: 740px) 100vw, 740px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2021/01/rupuals-drag-races-season-13-cast.jpg?resize=740%2C675&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2021/01/rupuals-drag-races-season-13-cast.jpg?resize=740%2C675&amp;ssl=1 740w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2021/01/rupuals-drag-races-season-13-cast.jpg?resize=20%2C19&amp;ssl=1 20w" /></a></figure><aside class="post-category "> <a href="https://socialitelife.com/category/drag-queens/" rel="category tag">Drag Queens</a></aside><div class="post-title"><h6><a href="https://socialitelife.com/week-in-drag-season-13-queens-2/" title="The Week in Drag – The season 13 queens make the rounds, Trixie Mattel builds a dream house, Nina West sings in the new year, and more"><span>The Week in Drag – The season 13 queens make the rounds, Trixie Mattel builds a dream house, Nina West sings in the new year, and more</span></a></h6></div></div></div><div class="small-6 medium-6 large-3 columns"><div class="post style2 post-48307 type-post status-publish format-standard has-post-thumbnail hentry category-quickies tag-adele tag-alex-trebek tag-chris-hemsworth tag-chris-pratt tag-james-bond tag-john-boyega tag-katy-perry tag-meryl-streep tag-michael-j-fox tag-robert-englund tag-schitts-creek tag-sia tag-stranger-things tag-supernatural tag-the-great-british-baking-show tag-the-prom tag-thor mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <a href="https://socialitelife.com/alex-trebek-pancreatic-cancer-video/"><img width="740" height="675" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2020/11/1844254.0.jpg?resize=20%2C19&amp;ssl=1" class="attachment-theissue-square-x2 size-theissue-square-x2 thb-lazyload lazyload wp-post-image" alt="Alex Trebek" loading="lazy" sizes="(max-width: 740px) 100vw, 740px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2020/11/1844254.0.jpg?resize=740%2C675&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2020/11/1844254.0.jpg?resize=740%2C675&amp;ssl=1 740w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2020/11/1844254.0.jpg?resize=20%2C19&amp;ssl=1 20w" /></a></figure><aside class="post-category "> <a href="https://socialitelife.com/category/quickies/" rel="category tag">Quickies</a></aside><div class="post-title"><h6><a href="https://socialitelife.com/alex-trebek-pancreatic-cancer-video/" title="Alex Trebek raises awareness of ‘terrible’ pancreatic cancer in pre-recorded ‘Jeopardy!’ video and"><span>Alex Trebek raises awareness of ‘terrible’ pancreatic cancer in pre-recorded ‘Jeopardy!’ video and</span></a></h6></div></div></div><div class="small-6 medium-6 large-3 columns"><div class="post style2 post-46110 type-post status-publish format-standard has-post-thumbnail hentry category-quickies tag-ant-anstead tag-cardi-b tag-christina-el-moussa tag-kamala-harris tag-kanye-west tag-kim-kardashian tag-lizzo tag-offset tag-peacock tag-ruth-bader-ginsberg tag-selena-gomez tag-taylor-swift tag-the-great-british-baking-show mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <a href="https://socialitelife.com/tom-hardy-james-bond-quickies/"><img width="740" height="675" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2020/09/tom-hardy-bond.jpg?resize=20%2C19&amp;ssl=1" class="attachment-theissue-square-x2 size-theissue-square-x2 thb-lazyload lazyload wp-post-image" alt="Tom Hardy James Bond" loading="lazy" sizes="(max-width: 740px) 100vw, 740px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2020/09/tom-hardy-bond.jpg?resize=740%2C675&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2020/09/tom-hardy-bond.jpg?resize=740%2C675&amp;ssl=1 740w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2020/09/tom-hardy-bond.jpg?resize=20%2C19&amp;ssl=1 20w" /></a></figure><aside class="post-category "> <a href="https://socialitelife.com/category/quickies/" rel="category tag">Quickies</a></aside><div class="post-title"><h6><a href="https://socialitelife.com/tom-hardy-james-bond-quickies/" title="Is Tom Hardy the Next James Bond, How to stream Ruth Bader Ginsberg, Cardi B Talks Offset, Peacock coming to Roku, and More"><span>Is Tom Hardy the Next James Bond, How to stream Ruth Bader Ginsberg, Cardi B Talks Offset, Peacock coming to Roku, and More</span></a></h6></div></div></div><div class="small-6 medium-6 large-3 columns"><div class="post style2 post-45812 type-post status-publish format-standard has-post-thumbnail hentry category-quickies tag-cardi-b tag-chadwick-boseman tag-chris-evans tag-genevieve-padalecki tag-jude-law tag-kanye-west tag-kendall-jenner tag-kim-kardashian tag-kristen-bell tag-lady-gaga tag-offset tag-prince-harry tag-qanon tag-taylor-hanson tag-the-great-british-baking-show tag-walker mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <a href="https://socialitelife.com/the-great-british-baking-show-returns-jude-law-becomes-a-dad-again-kendall-jenner-is-a-stoner-chadwick-boseman-chris-evans-and-more/"><img width="740" height="675" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2020/09/great-british-baking-show.jpg?resize=20%2C19&amp;ssl=1" class="attachment-theissue-square-x2 size-theissue-square-x2 thb-lazyload lazyload wp-post-image" alt="The Great British Baking Show" loading="lazy" sizes="(max-width: 740px) 100vw, 740px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2020/09/great-british-baking-show.jpg?resize=740%2C675&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2020/09/great-british-baking-show.jpg?resize=740%2C675&amp;ssl=1 740w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2020/09/great-british-baking-show.jpg?resize=20%2C19&amp;ssl=1 20w" /></a></figure><aside class="post-category "> <a href="https://socialitelife.com/category/quickies/" rel="category tag">Quickies</a></aside><div class="post-title"><h6><a href="https://socialitelife.com/the-great-british-baking-show-returns-jude-law-becomes-a-dad-again-kendall-jenner-is-a-stoner-chadwick-boseman-chris-evans-and-more/" title="The Great British Baking Show Returns, Jude Law Becomes a Dad Again, Kendall Jenner Is a Stoner, Chadwick Boseman, Chris Evans and More"><span>The Great British Baking Show Returns, Jude Law Becomes a Dad Again, Kendall Jenner Is a Stoner, Chadwick Boseman, Chris Evans and More</span></a></h6></div></div></div></div></aside></div></div></div></div></div></div><footer id="footer" class="footer light footer-full-width-off"><div class="row footer-row"><div class="small-12 medium-6 large-4 columns"><div id="text-2" class="widget style1 widget_text"><div class="thb-widget-title"><span>About Socialite Life</div></span><div class="textwidget"><p><strong>Socialite Life</strong> brings you a daily dose of divas, drag queens, hot male celebrities and models, along with a healthy dollop of celebrity and pop culture news.</p></div></div><div id="text-7" class="widget style1 widget_text"><div class="thb-widget-title"><span>Disclaimer</div></span><div class="textwidget"><p><em>Socialite Life has affiliate partnerships, so we may receive a share of the revenue from your purchase.</em></p></div></div></div><div class="small-12 medium-6 large-4 columns"><div id="text-6" class="widget style1 widget_text"><div class="thb-widget-title"><span>Visit Our Partners</div></span><div class="textwidget"><ul><li><strong><a href="http://pubx.co/NrTBtu" target="_blank" rel="noopener" data-schema-attribute="">!!omgblog!!</a></strong></li><li><strong><a href="https://www.boyculture.com/" target="_blank" rel="noopener" data-schema-attribute="">Boy Culture</a></strong></li><li><strong><a href="http://www.evilbeetgossip.com/" target="_blank" rel="noopener" data-schema-attribute="">Evil Beet Gossip</a></strong></li><li><strong><a href="http://pubx.co/cN8EaE" target="_blank" rel="noopener" data-schema-attribute="">Go Fug Yourself</a></strong></li><li><strong><a href="http://www.kennethinthe212.com/" target="_blank" rel="noopener" data-schema-attribute="">Kenneth in the 212</a></strong></li></ul></div></div></div><div class="small-12 large-4 columns"><div id="thb_subscribe_widget-2" class="widget style1 thb_widget_subscribe"><aside class="thb-newsletter-form"><h4>Subscribe to our newsletter!</h4><p>A weekly recap of pop culture delivered straight to your inbox every Friday evening.</p><form class="newsletter-form" action="#" method="post" data-security="06513d6bf9"> <input placeholder="Your E-Mail" type="text" name="widget_subscribe" class="widget_subscribe"> <button type="submit" name="submit" class="btn black">SIGN UP</button><div class="thb-preloader"> <svg class="material-spinner" width="50px" height="50px" viewBox="0 0 66 66" xmlns="http://www.w3.org/2000/svg"> <circle class="material-path" fill="none" stroke-width="6" stroke-linecap="round" cx="33" cy="33" r="30"></circle> </svg></div></form><div class="thb-custom-checkbox"> <input type="checkbox" id="thb-newsletter-privacy-908" name="thb-newsletter-privacy" class="thb-newsletter-privacy"  checked='checked' > <label for="thb-newsletter-privacy-908"> I would like to receive news and special offers. </label></div></aside></div></div></div></footer><div class="subfooter style4 light subfooter-full-width-off"><div class="row align-middle subfooter-row"><div class="small-12 medium-4 columns text-center medium-text-left"><div class="menu-footer-menu-container"><ul id="menu-footer-menu-1" class="thb-full-menu thb-standard"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2856"><a href="https://socialitelife.com/about-socialite-life/">About</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-397"><a href="https://socialitelife.com/contact/">Contact</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-398"><a href="https://socialitelife.com/terms/">Terms</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-399"><a href="https://socialitelife.com/privacy-policy-2/">Privacy</a></li></ul></div></div><div class="small-12 medium-4 columns text-center"><div class="footer-logo-holder"> <a href="https://socialitelife.com/" class="footer-logolink" title="Socialite Life"> <img src="https://socialitelife.com/wp-content/uploads/2020/04/SL-Wig-banner-600.jpg" class="logoimg" loading="lazy" alt="Socialite Life"/> </a></div></div><div class="small-12 medium-4 columns text-center medium-text-right"><div class="thb-social-links-container thb-social-horizontal mono-icons"><div class="thb-social-link-wrap"> <a href="https://facebook.com/socialitelife" target="_blank" class="thb-social-link social-link-facebook" rel="noreferrer"><div class="thb-social-label-container"><div class="thb-social-icon-container"><i class="thb-icon-facebook"></i></div><div class="thb-social-label">Facebook</div></div> </a></div><div class="thb-social-link-wrap"> <a href="https://twitter.com/socialitelife" target="_blank" class="thb-social-link social-link-twitter" rel="noreferrer"><div class="thb-social-label-container"><div class="thb-social-icon-container"><i class="thb-icon-twitter"></i></div><div class="thb-social-label">Twitter</div></div> </a></div><div class="thb-social-link-wrap"> <a href="https://instagram.com/socialitelife" target="_blank" class="thb-social-link social-link-instagram" rel="noreferrer"><div class="thb-social-label-container"><div class="thb-social-icon-container"><i class="thb-icon-instagram"></i></div><div class="thb-social-label">Instagram</div></div> </a></div><div class="thb-social-link-wrap"> <a href="https://pinterest.com/socialitelife" target="_blank" class="thb-social-link social-link-pinterest" rel="noreferrer"><div class="thb-social-label-container"><div class="thb-social-icon-container"><i class="thb-icon-pinterest"></i></div><div class="thb-social-label">Pinterest</div></div> </a></div><div class="thb-social-link-wrap"> <a href="https://youtube.com/channel/UC7ew27fEz_OXF4kkxczb3Eg" target="_blank" class="thb-social-link social-link-youtube" rel="noreferrer"><div class="thb-social-label-container"><div class="thb-social-icon-container"><i class="thb-icon-youtube"></i></div><div class="thb-social-label">Youtube</div></div> </a></div></div></div></div><div class="row align-middle align-center"><div class="small-12 medium-6 large-4 columns text-center"><p>Support <strong>Socialite Life</strong> when you shop on Amazon <a href="https://amzn.to/2n3VQt5" target="_blank" rel="noopener">using this link</a> or when you click any of our affiliate links. You won’t have to go to the store, and we’ll receive a little commission.</p><p>Copyright ©2021, MJP Content Labs, LLC. All Rights Reserved.</p></div></div></div> <a id="scroll_to_top" class="style1"> <span>Scroll To Top</span> </a><div class="click-capture"></div><nav id="mobile-menu" class="style1 side-panel light dark-scroll" data-behaviour="thb-submenu"> <a class="thb-mobile-close"><div><span></span><span></span></div></a><div class="logo-holder mobilemenu-logo-holder"> <a href="https://socialitelife.com/" class="logolink" title="Socialite Life"> <img src="https://socialitelife.com/wp-content/uploads/2020/04/SL-Wig-banner-150.jpg" class="logoimg logo-dark" alt="Socialite Life" data-logo-alt="https://socialitelife.com/wp-content/uploads/2020/04/SL-Wig-banner-600.jpg" /> </a></div><div class="custom_scroll side-panel-inner" id="menu-scroll"><div class="mobile-menu-top"><ul id="menu-site-wide-menu-1" class="thb-mobile-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-1743"><a href="https://socialitelife.com/category/entertainment/">Entertainment<div class="thb-arrow"><i class="thb-icon-down-open-mini"></i></div></a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16713"><a href="https://socialitelife.com/category/entertainment/celebrity/">Celebrity</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16125"><a href="https://socialitelife.com/category/entertainment/movies/">Movies</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-16124"><a href="https://socialitelife.com/category/entertainment/tv/">TV</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16123"><a href="https://socialitelife.com/category/entertainment/music/">Music</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16126"><a href="https://socialitelife.com/category/fashion/">Fashion</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20600"><a href="https://socialitelife.com/tag/podcasts/">Podcasts</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23688"><a href="https://socialitelife.com/category/real-housewives/">Real Housewives</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-528"><a href="https://socialitelife.com/category/sl-flashback/">SL Flashback</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-16712"><a href="https://socialitelife.com/category/drag-queens/">Drag Queens<div class="thb-arrow"><i class="thb-icon-down-open-mini"></i></div></a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14251"><a href="https://socialitelife.com/tag/the-week-in-drag/">The Week in Drag</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10323"><a href="https://socialitelife.com/tag/rupauls-drag-race/">RuPaul&#8217;s Drag Race</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41509"><a href="https://socialitelife.com/tag/rupauls-drag-race-all-stars/">RuPaul&#8217;s Drag Race All Stars</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23598"><a href="https://socialitelife.com/tag/rupauls-drag-race-uk/">RuPaul&#8217;s Drag Race UK</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-326"><a href="https://socialitelife.com/category/eye-candy/">Eye Candy<div class="thb-arrow"><i class="thb-icon-down-open-mini"></i></div></a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1762"><a href="https://socialitelife.com/tag/man-candy">Insta Snaps</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1760"><a href="https://socialitelife.com/tag/instahottie">Instahottie</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1761"><a href="https://socialitelife.com/tag/male-model-monday">Male Model Monday</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-73349"><a href="https://socialitelife.com/tag/male-model-spotlight/">Male Model Spotlight</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-7032"><a href="https://socialitelife.com/category/interviews/">Interviews<div class="thb-arrow"><i class="thb-icon-down-open-mini"></i></div></a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-25651"><a href="https://socialitelife.com/tag/socialite-seven/">Socialite Seven</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1765"><a href="https://socialitelife.com/tag/photos">Photos</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-51007"><a href="#">Videos<div class="thb-arrow"><i class="thb-icon-down-open-mini"></i></div></a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51008"><a href="https://socialitelife.com/category/viral-video/">Viral Video</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35309"><a href="https://socialitelife.com/celebrity-news/">Celebrity News</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35314"><a href="https://socialitelife.com/movie-trailer-park/">Movie Trailer Park</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35311"><a href="https://socialitelife.com/tv-highlights-and-trailers/">TV Highlights and Trailers</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35308"><a href="https://socialitelife.com/netflix-and-chill/">Netflix and Chill</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35310"><a href="https://socialitelife.com/sls-pop-music-playlist/">SL’s Pop Music Playlist</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38919"><a href="https://socialitelife.com/in-real-life/">In Real Life</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35312"><a href="https://socialitelife.com/male-models/">Fashion</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35313"><a href="https://socialitelife.com/drag-queen-fabulosity/">Drag Queen Fabulosity</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14069"><a href="https://amzn.to/2RI8nUF">SL Shop</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49221"><a href="https://socialitelife.com/partners/">Partners</a></li></ul><ul id="menu-footer-menu-2" class="thb-secondary-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2856"><a href="https://socialitelife.com/about-socialite-life/">About</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-397"><a href="https://socialitelife.com/contact/">Contact</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-398"><a href="https://socialitelife.com/terms/">Terms</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-399"><a href="https://socialitelife.com/privacy-policy-2/">Privacy</a></li></ul></div><div class="mobile-menu-bottom"><div class="thb-social-links-container thb-social-horizontal mono-icons"><div class="thb-social-link-wrap"> <a href="https://facebook.com/socialitelife" target="_blank" class="thb-social-link social-link-facebook" rel="noreferrer"><div class="thb-social-label-container"><div class="thb-social-icon-container"><i class="thb-icon-facebook"></i></div><div class="thb-social-label">Facebook</div></div> </a></div><div class="thb-social-link-wrap"> <a href="https://twitter.com/socialitelife" target="_blank" class="thb-social-link social-link-twitter" rel="noreferrer"><div class="thb-social-label-container"><div class="thb-social-icon-container"><i class="thb-icon-twitter"></i></div><div class="thb-social-label">Twitter</div></div> </a></div><div class="thb-social-link-wrap"> <a href="https://instagram.com/socialitelife" target="_blank" class="thb-social-link social-link-instagram" rel="noreferrer"><div class="thb-social-label-container"><div class="thb-social-icon-container"><i class="thb-icon-instagram"></i></div><div class="thb-social-label">Instagram</div></div> </a></div><div class="thb-social-link-wrap"> <a href="https://pinterest.com/socialitelife" target="_blank" class="thb-social-link social-link-pinterest" rel="noreferrer"><div class="thb-social-label-container"><div class="thb-social-icon-container"><i class="thb-icon-pinterest"></i></div><div class="thb-social-label">Pinterest</div></div> </a></div><div class="thb-social-link-wrap"> <a href="https://youtube.com/channel/UC7ew27fEz_OXF4kkxczb3Eg" target="_blank" class="thb-social-link social-link-youtube" rel="noreferrer"><div class="thb-social-label-container"><div class="thb-social-icon-container"><i class="thb-icon-youtube"></i></div><div class="thb-social-label">Youtube</div></div> </a></div></div></div></div></nav>  <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">(function(w, d, s, id) {
  w.PUBX=w.PUBX || {pub: "socialite_life", discover: true, lazy: true};
  var js, pjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id; js.async = true;
  js.src = "//main.pubexchange.com/loader.min.js";
  pjs.parentNode.insertBefore(js, pjs);
}(window, document, "script", "pubexchange-jssdk"));</script> <script type="text/javascript">var sbiajaxurl = "https://socialitelife.com/wp-admin/admin-ajax.php";</script> <aside id="newsletter-popup" class="mfp-hide theme-popup newsletter-popup light"><figure class="newsletter-image"><img width="500" height="500" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2018/09/SL-500-square.jpg?resize=20%2C19&amp;ssl=1" class="attachment-theissue-square-x2 size-theissue-square-x2 thb-lazyload lazyload" alt="" loading="lazy" sizes="(max-width: 500px) 100vw, 500px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2018/09/SL-500-square.jpg?resize=500%2C500&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2018/09/SL-500-square.jpg?w=500&amp;ssl=1 500w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2018/09/SL-500-square.jpg?resize=180%2C180&amp;ssl=1 180w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2018/09/SL-500-square.jpg?resize=90%2C90&amp;ssl=1 90w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2018/09/SL-500-square.jpg?resize=370%2C370&amp;ssl=1 370w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2018/09/SL-500-square.jpg?resize=20%2C20&amp;ssl=1 20w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2018/09/SL-500-square.jpg?resize=185%2C185&amp;ssl=1 185w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2018/09/SL-500-square.jpg?resize=400%2C400&amp;ssl=1 400w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2018/09/SL-500-square.jpg?resize=45%2C45&amp;ssl=1 45w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2018/09/SL-500-square.jpg?resize=300%2C300&amp;ssl=1 300w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2018/09/SL-500-square.jpg?resize=100%2C100&amp;ssl=1 100w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2018/09/SL-500-square.jpg?resize=48%2C48&amp;ssl=1 48w" /></figure><div class="newsletter-content"><aside class="thb-article-subscribe thb-newsletter-form"><div class="thb-subscribe-icon-container"><svg version="1.1" class="thb-subscribe-icon" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
 viewBox="0 0 90 68" style="enable-background:new 0 0 90 68;" xml:space="preserve"> <path d="M89.9,7.9c0-4.3-3.6-7.9-7.9-7.9L7.8,0.1C3.5,0.1,0,3.8,0,8.1l0.1,52c0,4.3,3.6,7.9,7.9,7.9l74.2-0.1c4.3,0,7.8-3.6,7.8-8
 L89.9,7.9z M7.8,4.4l74.2-0.1c0.4,0,0.8,0.1,1.2,0.2L48.9,39.4c-1,1.1-2.4,1.6-3.9,1.6c-1.5,0-2.8-0.5-3.9-1.6L6.7,4.6
 C7,4.5,7.4,4.4,7.8,4.4z M82.2,63.6L7.9,63.8c-2,0-3.7-1.7-3.7-3.7l-0.1-52l34,34.4c1.8,1.8,4.3,2.9,6.8,2.9c2.5,0,5-1.1,6.8-2.9
 L85.7,7.9l0.1,52C85.8,61.9,84.2,63.6,82.2,63.6z M80.5,55.7L62.9,40c-0.8-0.7-2.2-0.7-2.9,0.2c-0.7,0.8-0.7,2.2,0.2,3l17.6,15.7
 c0.4,0.3,0.9,0.5,1.4,0.5c0.6,0,1.1-0.2,1.6-0.7C81.4,57.8,81.4,56.4,80.5,55.7z M26.9,40.3L9.5,55.8c-0.8,0.7-0.9,2.1-0.2,3
 c0.5,0.5,1,0.7,1.7,0.7c0.5,0,0.9-0.2,1.4-0.5l17.3-15.5c0.8-0.7,0.9-2.1,0.2-3C29.1,39.6,27.8,39.5,26.9,40.3z"/> </svg></div><h4> Subscribe to our newsletter!</h4><p> A weekly recap of pop culture delivered straight to your inbox every Friday evening.</p><form class="newsletter-form" action="#" method="post" data-security="06513d6bf9"> <input placeholder="Your E-Mail" type="text" name="widget_subscribe" class="widget_subscribe large"> <button type="submit" name="submit" class="btn large">SIGN UP</button><div class="thb-preloader"> <svg class="material-spinner" width="50px" height="50px" viewBox="0 0 66 66" xmlns="http://www.w3.org/2000/svg"> <circle class="material-path" fill="none" stroke-width="6" stroke-linecap="round" cx="33" cy="33" r="30"></circle> </svg></div></form><div class="thb-custom-checkbox"> <input type="checkbox" id="thb-newsletter-privacy-810" name="thb-newsletter-privacy" class="thb-newsletter-privacy"  checked='checked' > <label for="thb-newsletter-privacy-810"> I would like to receive news and special offers. </label></div></aside></div></aside><style>.wp-container-1 > .alignleft { float: left; margin-inline-start: 0; margin-inline-end: 2em; }.wp-container-1 > .alignright { float: right; margin-inline-start: 2em; margin-inline-end: 0; }.wp-container-1 > .aligncenter { margin-left: auto !important; margin-right: auto !important; }</style><style>.wp-container-2 > .alignleft { float: left; margin-inline-start: 0; margin-inline-end: 2em; }.wp-container-2 > .alignright { float: right; margin-inline-start: 2em; margin-inline-end: 0; }.wp-container-2 > .aligncenter { margin-left: auto !important; margin-right: auto !important; }</style><style>.wp-container-3 > .alignleft { float: left; margin-inline-start: 0; margin-inline-end: 2em; }.wp-container-3 > .alignright { float: right; margin-inline-start: 2em; margin-inline-end: 0; }.wp-container-3 > .aligncenter { margin-left: auto !important; margin-right: auto !important; }</style> <script type='text/javascript' src='https://socialitelife.com/wp-content/themes/theissue/assets/js/vendor/lazysizes.min.js?ver=1.6.7' id='lazysizes-js'></script> <script type='text/javascript' src='https://cdn.plyr.io/3.6.2/plyr.polyfilled.js?ver=1.6.7' id='plyr-js'></script> <script type='text/javascript' id='thb-app-js-extra'>var themeajax = {"url":"https:\/\/socialitelife.com\/wp-admin\/admin-ajax.php","l10n":{"of":"%curr% of %total%","just_of":"of","loading":"Loading","lightbox_loading":"Loading...","nomore":"No More Posts","nomore_products":"All Products Loaded","loadmore":"Load More","added":"Added To Cart","no_results":"No Results Found","results_found":"Results Found","results_all":"View All Results","copied":"Copied","prev":"Prev","next":"Next","pinit":"PIN IT","adding_to_cart":"Adding to Cart"},"svg":{"prev_arrow":"<svg version=\"1.1\" xmlns=\"http:\/\/www.w3.org\/2000\/svg\" xmlns:xlink=\"http:\/\/www.w3.org\/1999\/xlink\" x=\"0px\" y=\"0px\"\r\n\t width=\"30px\" height=\"30px\" viewBox=\"0 0 30 30\" enable-background=\"new 0 0 30 30\" xml:space=\"preserve\">\r\n<path class=\"thb-arrow-first\" d=\"M12.757,14.997l3.585,3.243c0.201,0.174,0.201,0.459,0,0.635c-0.203,0.175-0.532,0.175-0.734,0l-3.948-3.557\r\n\tc-0.203-0.175-0.203-0.459,0-0.635l3.948-3.557c0.202-0.175,0.531-0.175,0.734,0c0.201,0.175,0.201,0.459,0,0.635L12.757,14.997z\"\/>\r\n<path class=\"thb-arrow-second\" d=\"M12.757,14.997l3.585,3.243c0.201,0.174,0.201,0.459,0,0.635c-0.203,0.175-0.533,0.175-0.734,0l-3.948-3.557\r\n\tc-0.203-0.175-0.203-0.459,0-0.635l3.948-3.557c0.201-0.175,0.531-0.175,0.734,0c0.201,0.175,0.201,0.459,0,0.635L12.757,14.997z\"\/>\r\n<\/svg>\r\n","next_arrow":"<svg version=\"1.1\" xmlns=\"http:\/\/www.w3.org\/2000\/svg\" xmlns:xlink=\"http:\/\/www.w3.org\/1999\/xlink\" x=\"0px\" y=\"0px\"\r\n\t width=\"30px\" height=\"30px\" viewBox=\"0 0 30 30\" enable-background=\"new 0 0 30 30\" xml:space=\"preserve\">\r\n<path class=\"thb-arrow-first\" d=\"M13.659,11.76c-0.201-0.175-0.201-0.459,0-0.635c0.203-0.175,0.532-0.175,0.734,0l3.947,3.557\r\n\tc0.203,0.176,0.203,0.46,0,0.635l-3.947,3.557c-0.202,0.175-0.531,0.175-0.734,0c-0.201-0.176-0.201-0.461,0-0.635l3.585-3.243\r\n\tL13.659,11.76z\"\/>\r\n<path class=\"thb-arrow-second\" d=\"M13.659,11.76c-0.201-0.175-0.201-0.459,0-0.635c0.203-0.175,0.533-0.175,0.734,0l3.948,3.557\r\n\tc0.203,0.176,0.203,0.46,0,0.635l-3.948,3.557c-0.201,0.175-0.531,0.175-0.734,0c-0.201-0.176-0.201-0.461,0-0.635l3.585-3.243\r\n\tL13.659,11.76z\"\/>\r\n<\/svg>\r\n","added_arrow":"","close_arrow":"<svg xmlns=\"http:\/\/www.w3.org\/2000\/svg\" viewBox=\"0 0 64 64\" enable-background=\"new 0 0 64 64\"><g fill=\"none\" stroke=\"#000\" stroke-width=\"2\" stroke-miterlimit=\"10\"><path d=\"m18.947 17.15l26.1 25.903\"\/><path d=\"m19.05 43.15l25.902-26.1\"\/><\/g><\/svg>","pagination":"<svg version=\"1.1\" xmlns=\"http:\/\/www.w3.org\/2000\/svg\" class=\"thb-pagination-svg\" width=\"14px\" height=\"14px\" viewBox=\"0 0 16 16\" preserveAspectRatio=\"none\"><circle cx=\"8\" cy=\"8\" r=\"5.5\"><\/circle><\/svg>","preloader":"<svg class=\"material-spinner\" width=\"50px\" height=\"50px\" viewBox=\"0 0 66 66\" xmlns=\"http:\/\/www.w3.org\/2000\/svg\">\n   <circle class=\"material-path\" fill=\"none\" stroke-width=\"6\" stroke-linecap=\"round\" cx=\"33\" cy=\"33\" r=\"30\"><\/circle>\n<\/svg>"},"settings":{"infinite_count":"5","site_url":"https:\/\/socialitelife.com","current_url":"https:\/\/socialitelife.com\/the-great-british-baking-show-biscuit-week-tv-talk\/","fixed_header_scroll":"off","fixed_header_padding":"","general_search_ajax":"off","newsletter":"on","newsletter_length":"2","newsletter_delay":"10","newsletter_mailchimp":true,"page_transition":"on","page_transition_style":"thb-fade","page_transition_in_speed":"500","page_transition_out_speed":"250","shop_product_listing_pagination":"style1","right_click":"off","cart_url":false,"is_cart":false,"is_checkout":false,"touch_threshold":5,"mobile_menu_animation_speed":"0.3","thb_custom_video_player":"on","viai_publisher_id":""}};</script> <aside class="thb-search-popup" data-security="f7d3bf9412"> <a class="thb-mobile-close"><div><span></span><span></span></div></a><div class="thb-close-text">PRESS ESC TO CLOSE</div><div class="row align-center align-middle search-main-row"><div class="small-12 medium-8 columns"><form method="get" class="searchform" action="https://socialitelife.com/"> <input type="text" name="s" class="search-field" placeholder="Type Here to Search" /></form><div class="thb-autocomplete-wrapper"><div class="thb-preloader"> <svg class="material-spinner" width="50px" height="50px" viewBox="0 0 66 66" xmlns="http://www.w3.org/2000/svg"> <circle class="material-path" fill="none" stroke-width="6" stroke-linecap="round" cx="33" cy="33" r="30"></circle> </svg></div></div></div></div></aside> <script src='https://stats.wp.com/e-202239.js' defer></script> <script>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:11.3.2',blog:'21367542',post:'74581',tz:'-5',srv:'socialitelife.com'} ]);
	_stq.push([ 'clickTrackerInit', '21367542', '74581' ]);</script> </div>  <script defer src="https://socialitelife.com/wp-content/cache/autoptimize/js/autoptimize_e9598c372c50275e873094f074ff958a.js"></script></body></html>