<!doctype html><html lang="en-US"><head><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, viewport-fit=cover"><link rel="profile" href="https://gmpg.org/xfn/11"><link rel="pingback" href="https://socialitelife.com/xmlrpc.php"><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /><link media="all" href="https://socialitelife.com/wp-content/cache/autoptimize/css/autoptimize_433f9d9c75f887393725dec8f3279a37.css" rel="stylesheet" /><title>The Week in Drag – We swear it’s not all Trixie Mattel content! Say G’Day to the Down Under queens, Nina West hits Comic Con, All Stars fashion and more &ndash; Socialite Life</title><meta name="description" content="Hello, hello, hello! We’re back with a post-holiday edition of updates and news from your favorite queens in The Week in Drag." /><link rel="canonical" href="https://socialitelife.com/the-week-in-drag-we-swear-its-not-all-trixie-mattel-content-say-gday-to-the-down-under-queens-nina-west-hits-comic-con-all-stars-fashion-and-more/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="The Week in Drag – We swear it’s not all Trixie Mattel content! Say G’Day to the Down Under queens, Nina West hits Comic Con, All Stars fashion and more" /><meta property="og:description" content="Hello, hello, hello! We’re back with a post-holiday edition of updates and news from your favorite queens in The Week in Drag." /><meta property="og:url" content="https://socialitelife.com/the-week-in-drag-we-swear-its-not-all-trixie-mattel-content-say-gday-to-the-down-under-queens-nina-west-hits-comic-con-all-stars-fashion-and-more/" /><meta property="og:site_name" content="Socialite Life" /><meta property="article:publisher" content="https://www.facebook.com/SocialiteLife" /><meta property="article:published_time" content="2022-07-10T14:05:11+00:00" /><meta property="article:modified_time" content="2022-07-10T14:05:18+00:00" /><meta property="og:image" content="https://socialitelife.com/wp-content/uploads/2022/07/rpdr-down-under-season-2.jpg" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="675" /><meta property="og:image:type" content="image/jpeg" /><meta name="author" content="Christine Fitzgerald" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:title" content="The Week in Drag – We swear it’s not all Trixie Mattel content! Say G’Day to the Down Under queens, Nina West hits Comic Con, All Stars fashion and more" /><meta name="twitter:creator" content="@socialitelife" /><meta name="twitter:site" content="@socialitelife" /><meta name="twitter:label1" content="Written by" /><meta name="twitter:data1" content="Christine Fitzgerald" /><meta name="twitter:label2" content="Est. reading time" /><meta name="twitter:data2" content="7 minutes" /> <script type="application/ld+json" class="yoast-schema-graph">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</script> <link rel='dns-prefetch' href='//scripts.mediavine.com' /><link rel='dns-prefetch' href='//cdn.plyr.io' /><link rel='dns-prefetch' href='//use.typekit.net' /><link rel='dns-prefetch' href='//s.w.org' /><link rel='dns-prefetch' href='//i0.wp.com' /><link rel='dns-prefetch' href='//c0.wp.com' /><link rel="alternate" type="application/rss+xml" title="Socialite Life &raquo; Feed" href="https://socialitelife.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Socialite Life &raquo; Comments Feed" href="https://socialitelife.com/comments/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/socialitelife.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);</script> <link rel='stylesheet' id='thb-typekit-css'  href='https://use.typekit.net/crc4abh.css?ver=1.6.7' type='text/css' media='' /> <script type='text/javascript' async="async" data-noptimize="1" data-cfasync="false" src='https://scripts.mediavine.com/tags/socialite-life.js?ver=6.0' id='mv-script-wrapper-js'></script> <script type='text/javascript' src='https://socialitelife.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script> <link rel="https://api.w.org/" href="https://socialitelife.com/wp-json/" /><link rel="alternate" type="application/json" href="https://socialitelife.com/wp-json/wp/v2/posts/72174" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://socialitelife.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://socialitelife.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 6.0" /><link rel='shortlink' href='https://socialitelife.com/?p=72174' /><link rel="alternate" type="application/json+oembed" href="https://socialitelife.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsocialitelife.com%2Fthe-week-in-drag-we-swear-its-not-all-trixie-mattel-content-say-gday-to-the-down-under-queens-nina-west-hits-comic-con-all-stars-fashion-and-more%2F" /><link rel="alternate" type="text/xml+oembed" href="https://socialitelife.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsocialitelife.com%2Fthe-week-in-drag-we-swear-its-not-all-trixie-mattel-content-say-gday-to-the-down-under-queens-nina-west-hits-comic-con-all-stars-fashion-and-more%2F&#038;format=xml" /><link rel="preconnect" href="https://fonts.googleapis.com"><link rel="preconnect" href="https://fonts.gstatic.com">  <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-78592632-1', 'auto');
			ga('send', 'pageview');</script> <meta name="pubexchange:image" content="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/rpdr-down-under-season-2.jpg?fit=800%2C450&ssl=1"><meta name="pubexchange:title" content="The Week in Drag – We swear it’s not all Trixie Mattel content! Say G’Day to the Down Under queens, Nina West hits Comic Con, All Stars fashion and more"><link rel="icon" href="https://i0.wp.com/socialitelife.com/wp-content/uploads/2020/04/cropped-SL-square-favicon.jpg?fit=32%2C32&#038;ssl=1" sizes="32x32" /><link rel="icon" href="https://i0.wp.com/socialitelife.com/wp-content/uploads/2020/04/cropped-SL-square-favicon.jpg?fit=192%2C192&#038;ssl=1" sizes="192x192" /><link rel="apple-touch-icon" href="https://i0.wp.com/socialitelife.com/wp-content/uploads/2020/04/cropped-SL-square-favicon.jpg?fit=180%2C180&#038;ssl=1" /><meta name="msapplication-TileImage" content="https://i0.wp.com/socialitelife.com/wp-content/uploads/2020/04/cropped-SL-square-favicon.jpg?fit=270%2C270&#038;ssl=1" /> <noscript><style>.wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head><body class="post-template-default single single-post postid-72174 single-format-standard aawp-custom thb-dropcap-off fixed-header-on fixed-header-scroll-off thb-dropdown-color-light right-click-off thb-borders-off thb-pinit-off thb-boxed-off thb-dark-mode-off thb-capitalize-off thb-parallax-off thb-single-product-ajax-on thb-article-sidebar-mobile-on wpb-js-composer js-comp-ver-6.6.0 vc_responsive"> <svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><div id="wrapper" class="thb-page-transition-on"><header class="header fixed fixed-article header-full-width fixed-header-full-width-on light-header thb-fixed-shadow-style1"><div class="row full-width-row"><div class="small-12 columns"><div class="thb-navbar"><div class="fixed-logo-holder"><div class="mobile-toggle-holder"><div class="mobile-toggle"> <span></span><span></span><span></span></div></div><div class="logo-holder fixed-logo-holder"> <a href="https://socialitelife.com/" class="logolink" title="Socialite Life"> <img src="https://socialitelife.com/wp-content/uploads/2020/04/SL-Wig-banner-600.jpg" class="logoimg logo-dark" alt="Socialite Life" data-logo-alt="https://socialitelife.com/wp-content/uploads/2020/04/SL-Wig-banner-600.jpg" /> </a></div></div><div class="fixed-title-holder"> <span>Now Reading</span><div class="fixed-article-title"><h6 id="page-title">The Week in Drag – We swear it’s not all Trixie Mattel content! Say G’Day to the Down Under queens, Nina West hits Comic Con, All Stars fashion and more</h6></div></div><div class="fixed-article-shares"><div class="thb-social-fixed sharing-counts-off"><div class="social-button-holder"> <a href="https://www.facebook.com/sharer.php?u=https://socialitelife.com/the-week-in-drag-we-swear-its-not-all-trixie-mattel-content-say-gday-to-the-down-under-queens-nina-west-hits-comic-con-all-stars-fashion-and-more/" class="social social-facebook"
 > <span class="thb-social-icon"> <i class="thb-icon-facebook"></i> </span> </a></div><div class="social-button-holder"> <a href="https://twitter.com/intent/tweet?text=The%20Week%20in%20Drag%20–%20We%20swear%20it’s%20not%20all%20Trixie%20Mattel%20content!%20Say%20G’Day%20to%20the%20Down%20Under%20queens,%20Nina%20West%20hits%20Comic%20Con,%20All%20Stars%20fashion%20and%20more&#038;via=socialitelife&#038;url=https://socialitelife.com/the-week-in-drag-we-swear-its-not-all-trixie-mattel-content-say-gday-to-the-down-under-queens-nina-west-hits-comic-con-all-stars-fashion-and-more/" class="social social-twitter"
 > <span class="thb-social-icon"> <i class="thb-icon-twitter"></i> </span> </a></div><div class="social-button-holder"> <a href="https://pinterest.com/pin/create/bookmarklet/?url=https://socialitelife.com/the-week-in-drag-we-swear-its-not-all-trixie-mattel-content-say-gday-to-the-down-under-queens-nina-west-hits-comic-con-all-stars-fashion-and-more/&#038;media=https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/rpdr-down-under-season-2.jpg?fit=1200%2C675&#038;ssl=1" class="social social-pinterest"
 > <span class="thb-social-icon"> <i class="thb-icon-pinterest"></i> </span> </a></div><div class="social-button-holder"> <a href="https://reddit.com/submit?url=https://socialitelife.com/the-week-in-drag-we-swear-its-not-all-trixie-mattel-content-say-gday-to-the-down-under-queens-nina-west-hits-comic-con-all-stars-fashion-and-more/" class="social social-reddit"
 > <span class="thb-social-icon"> <i class="thb-icon-reddit"></i> </span> </a></div><div class="social-button-holder"> <a href="https://share.flipboard.com/bookmarklet/popout?v=2&#038;title=The%20Week%20in%20Drag%20–%20We%20swear%20it’s%20not%20all%20Trixie%20Mattel%20content!%20Say%20G’Day%20to%20the%20Down%20Under%20queens,%20Nina%20West%20hits%20Comic%20Con,%20All%20Stars%20fashion%20and%20more&#038;url=https://socialitelife.com/the-week-in-drag-we-swear-its-not-all-trixie-mattel-content-say-gday-to-the-down-under-queens-nina-west-hits-comic-con-all-stars-fashion-and-more/" class="social social-flipboard"
 > <span class="thb-social-icon"> <i class="thb-icon-flipboard"></i> </span> </a></div><div class="social-button-holder"> <a href="https://www.linkedin.com/cws/share?url=https://socialitelife.com/the-week-in-drag-we-swear-its-not-all-trixie-mattel-content-say-gday-to-the-down-under-queens-nina-west-hits-comic-con-all-stars-fashion-and-more/" class="social social-linkedin"
 > <span class="thb-social-icon"> <i class="thb-icon-linkedin"></i> </span> </a></div><div class="social-button-holder"> <a href="/cdn-cgi/l/email-protection#a699d5d3c4ccc3c5d29bf2cec3839496f1c3c3cd839496cfc8839496e2d4c7c1839496442635839496f1c3839496d5d1c3c7d4839496cfd244263fd5839496c8c9d2839496c7caca839496f2d4cfdecfc3839496ebc7d2d2c3ca839496c5c9c8d2c3c8d287839496f5c7df839496e144263fe2c7df839496d2c9839496d2cec3839496e2c9d1c8839496f3c8c2c3d4839496d7d3c3c3c8d58a839496e8cfc8c7839496f1c3d5d2839496cecfd2d5839496e5c9cbcfc5839496e5c9c88a839496e7caca839496f5d2c7d4d5839496c0c7d5cecfc9c8839496c7c8c2839496cbc9d4c3808596959e9dc4c9c2df9bf2cec3839496f1c3c3cd839496cfc8839496e2d4c7c1839496442635839496f1c3839496d5d1c3c7d4839496cfd244263fd5839496c8c9d2839496c7caca839496f2d4cfdecfc3839496ebc7d2d2c3ca839496c5c9c8d2c3c8d287839496f5c7df839496e144263fe2c7df839496d2c9839496d2cec3839496e2c9d1c8839496f3c8c2c3d4839496d7d3c3c3c8d58a839496e8cfc8c7839496f1c3d5d2839496cecfd2d5839496e5c9cbcfc5839496e5c9c88a839496e7caca839496f5d2c7d4d5839496c0c7d5cecfc9c8839496c7c8c2839496cbc9d4c3839496ced2d2d6d59c8989d5c9c5cfc7cacfd2c3cacfc0c388c5c9cb89d2cec38bd1c3c3cd8bcfc88bc2d4c7c18bd1c38bd5d1c3c7d48bcfd2d58bc8c9d28bc7caca8bd2d4cfdecfc38bcbc7d2d2c3ca8bc5c9c8d2c3c8d28bd5c7df8bc1c2c7df8bd2c98bd2cec38bc2c9d1c88bd3c8c2c3d48bd7d3c3c3c8d58bc8cfc8c78bd1c3d5d28bcecfd2d58bc5c9cbcfc58bc5c9c88bc7caca8bd5d2c7d4d58bc0c7d5cecfc9c88bc7c8c28bcbc9d4c389" class="social social-email"> <span class="thb-social-icon"> <i class="thb-icon-mail"></i> </span> </a></div></div></div></div></div></div></header><div class="subheader style1 light subheader-mobile-off subheader-full-width-on"><div class="row subheader-row"><div class="small-12 medium-6 columns subheader-leftside"><ul id="menu-footer-menu" class="thb-full-menu"><li id="menu-item-2856" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2856"><a href="https://socialitelife.com/about-socialite-life/">About</a></li><li id="menu-item-397" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-397"><a href="https://socialitelife.com/contact/">Contact</a></li><li id="menu-item-398" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-398"><a href="https://socialitelife.com/terms/">Terms</a></li><li id="menu-item-399" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-399"><a href="https://socialitelife.com/privacy-policy-2/">Privacy</a></li></ul></div><div class="small-12 medium-6 columns subheader-rightside"></div></div></div><div class="mobile-header-holder"><header class="header header-mobile header-mobile-style1 light-header"><div class="row"><div class="small-3 columns"><div class="mobile-toggle-holder"><div class="mobile-toggle"> <span></span><span></span><span></span></div></div></div><div class="small-6 columns"><div class="logo-holder mobile-logo-holder"> <a href="https://socialitelife.com/" class="logolink" title="Socialite Life"> <img src="https://socialitelife.com/wp-content/uploads/2020/04/SL-Wig-banner-300.jpg" class="logoimg logo-dark" alt="Socialite Life" data-logo-alt="https://socialitelife.com/wp-content/uploads/2020/04/SL-Wig-banner-300.jpg" /> </a></div></div><div class="small-3 columns"><div class="secondary-area"><div class="thb-search-holder"> <svg version="1.1" class="thb-search-icon" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" viewBox="0 0 14 14" enable-background="new 0 0 14 14" xml:space="preserve" width="14" height="14"> <path d="M13.8,12.7l-3-3c0.8-1,1.3-2.3,1.3-3.8c0-3.3-2.7-6-6.1-6C2.7,0,0,2.7,0,6c0,3.3,2.7,6,6.1,6c1.4,0,2.6-0.5,3.6-1.2l3,3
 c0.1,0.1,0.3,0.2,0.5,0.2c0.2,0,0.4-0.1,0.5-0.2C14.1,13.5,14.1,13,13.8,12.7z M1.5,6c0-2.5,2-4.5,4.5-4.5c2.5,0,4.5,2,4.5,4.5
 c0,2.5-2,4.5-4.5,4.5C3.5,10.5,1.5,8.5,1.5,6z"/> </svg></div></div></div></div></header></div><header class="header style2 thb-main-header light-header"><div class="row"><div class="small-4 columns"><div class="mobile-toggle-holder"><div class="mobile-toggle"> <span></span><span></span><span></span></div></div></div><div class="small-4 columns"><div class="logo-holder"> <a href="https://socialitelife.com/" class="logolink" title="Socialite Life"> <img src="https://socialitelife.com/wp-content/uploads/2020/04/SL-Wig-banner-600.jpg" class="logoimg logo-dark" alt="Socialite Life" data-logo-alt="https://socialitelife.com/wp-content/uploads/2020/04/SL-Wig-banner-600.jpg" /> </a></div></div><div class="small-4 columns"><div class="secondary-area"><div class="thb-follow-holder"><ul class="thb-full-menu thb-standard"><li class="menu-item-has-children"> <a><span>Follow</span></a><ul class="sub-menu"><li><div class="thb-social-links-container thb-social-vertical mono-icons"><div class="thb-social-link-wrap"> <a href="https://facebook.com/socialitelife" target="_blank" class="thb-social-link social-link-facebook" rel="noreferrer"><div class="thb-social-label-container"><div class="thb-social-icon-container"><i class="thb-icon-facebook"></i></div><div class="thb-social-label">Facebook</div></div> </a></div><div class="thb-social-link-wrap"> <a href="https://twitter.com/socialitelife" target="_blank" class="thb-social-link social-link-twitter" rel="noreferrer"><div class="thb-social-label-container"><div class="thb-social-icon-container"><i class="thb-icon-twitter"></i></div><div class="thb-social-label">Twitter</div></div> </a></div><div class="thb-social-link-wrap"> <a href="https://instagram.com/socialitelife" target="_blank" class="thb-social-link social-link-instagram" rel="noreferrer"><div class="thb-social-label-container"><div class="thb-social-icon-container"><i class="thb-icon-instagram"></i></div><div class="thb-social-label">Instagram</div></div> </a></div><div class="thb-social-link-wrap"> <a href="https://pinterest.com/socialitelife" target="_blank" class="thb-social-link social-link-pinterest" rel="noreferrer"><div class="thb-social-label-container"><div class="thb-social-icon-container"><i class="thb-icon-pinterest"></i></div><div class="thb-social-label">Pinterest</div></div> </a></div><div class="thb-social-link-wrap"> <a href="https://youtube.com/channel/UC7ew27fEz_OXF4kkxczb3Eg" target="_blank" class="thb-social-link social-link-youtube" rel="noreferrer"><div class="thb-social-label-container"><div class="thb-social-icon-container"><i class="thb-icon-youtube"></i></div><div class="thb-social-label">Youtube</div></div> </a></div></div></li><li class="subscribe_part"><aside class="thb-article-subscribe thb-newsletter-form"><div class="thb-subscribe-icon-container"><svg version="1.1" class="thb-subscribe-icon" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
 viewBox="0 0 90 68" style="enable-background:new 0 0 90 68;" xml:space="preserve"> <path d="M89.9,7.9c0-4.3-3.6-7.9-7.9-7.9L7.8,0.1C3.5,0.1,0,3.8,0,8.1l0.1,52c0,4.3,3.6,7.9,7.9,7.9l74.2-0.1c4.3,0,7.8-3.6,7.8-8
 L89.9,7.9z M7.8,4.4l74.2-0.1c0.4,0,0.8,0.1,1.2,0.2L48.9,39.4c-1,1.1-2.4,1.6-3.9,1.6c-1.5,0-2.8-0.5-3.9-1.6L6.7,4.6
 C7,4.5,7.4,4.4,7.8,4.4z M82.2,63.6L7.9,63.8c-2,0-3.7-1.7-3.7-3.7l-0.1-52l34,34.4c1.8,1.8,4.3,2.9,6.8,2.9c2.5,0,5-1.1,6.8-2.9
 L85.7,7.9l0.1,52C85.8,61.9,84.2,63.6,82.2,63.6z M80.5,55.7L62.9,40c-0.8-0.7-2.2-0.7-2.9,0.2c-0.7,0.8-0.7,2.2,0.2,3l17.6,15.7
 c0.4,0.3,0.9,0.5,1.4,0.5c0.6,0,1.1-0.2,1.6-0.7C81.4,57.8,81.4,56.4,80.5,55.7z M26.9,40.3L9.5,55.8c-0.8,0.7-0.9,2.1-0.2,3
 c0.5,0.5,1,0.7,1.7,0.7c0.5,0,0.9-0.2,1.4-0.5l17.3-15.5c0.8-0.7,0.9-2.1,0.2-3C29.1,39.6,27.8,39.5,26.9,40.3z"/> </svg></div><h4> Subscribe to our newsletter!</h4><p> A weekly recap of pop culture delivered straight to your inbox every Friday evening.</p><form class="newsletter-form" action="#" method="post" data-security="b9b42d2ba9"> <input placeholder="Your E-Mail" type="text" name="widget_subscribe" class="widget_subscribe large"> <button type="submit" name="submit" class="btn large">SIGN UP</button><div class="thb-preloader"> <svg class="material-spinner" width="50px" height="50px" viewBox="0 0 66 66" xmlns="http://www.w3.org/2000/svg"> <circle class="material-path" fill="none" stroke-width="6" stroke-linecap="round" cx="33" cy="33" r="30"></circle> </svg></div></form><div class="thb-custom-checkbox"> <input type="checkbox" id="thb-newsletter-privacy-370" name="thb-newsletter-privacy" class="thb-newsletter-privacy"  checked='checked' > <label for="thb-newsletter-privacy-370"> I would like to receive news and special offers. </label></div></aside></li></ul></li></ul></div><div class="thb-trending-holder"><ul class="thb-full-menu"><li class="menu-item-has-children"> <a><span><svg version="1.1" class="thb-trending-icon thb-trending-icon-style3" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
 viewBox="0 0 20 28" xml:space="preserve"><path d="M6.9,28C2.9,26.7,0,23,0,18.7C0,10.6,8,9.6,7.7,0c8.5,4.7,7.4,12.7,7.4,12.7S17,11.7,17,9.4c2.1,3.3,3,6.6,3,9.3
 c0,4.3-2.9,8-6.9,9.3c1.7-1,2.8-2.8,2.8-4.8c0-4.8-4.5-5.4-4.6-10.9c-4.6,3.5-3.3,9.4-3.3,9.4s-2.3-0.7-2-3.9
 c-1.3,2-1.8,3.8-1.8,5.4C4.1,25.2,5.2,27,6.9,28z"/></svg></span></a><div class="sub-menu"><div class="thb-trending
 " data-security="d86bfb822c"><div class="thb-trending-tabs"> <a data-time="2" class="active">Now</a> <a data-time="7">Week</a> <a data-time="30">Month</a></div><div class="thb-trending-content"><div class="thb-trending-content-inner"><div class="post thumbnail-style3 post-72147 type-post status-publish format-standard has-post-thumbnail hentry category-celebrity category-eye-candy tag-adam-roberts tag-brad-goreski tag-bruno-alcantara tag-frederik-eklund tag-george-shelley tag-insta-snaps tag-joseph-baena tag-maluma tag-man-candy tag-manu-rios tag-mehcad-brooks tag-neil-patrick-harris tag-photos tag-skeet-ulrich tag-tian-richards tag-tyler-oakley mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <a href="https://socialitelife.com/bruno-alcantara-tian-richards-neil-patrick-harris-and-more-insta-snaps/"> <img width="90" height="90" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/brunocalcantara_1657256904.jpg?resize=20%2C20&amp;ssl=1" class="attachment-theissue-thumbnail size-theissue-thumbnail thb-lazyload lazyload wp-post-image" alt="Bruno Alcantara" loading="lazy" sizes="(max-width: 90px) 100vw, 90px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/brunocalcantara_1657256904.jpg?resize=90%2C90&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/brunocalcantara_1657256904.jpg?resize=90%2C90&amp;ssl=1 90w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/brunocalcantara_1657256904.jpg?resize=20%2C19&amp;ssl=1 20w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/brunocalcantara_1657256904.jpg?zoom=2&amp;resize=90%2C90&amp;ssl=1 180w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/brunocalcantara_1657256904.jpg?zoom=3&amp;resize=90%2C90&amp;ssl=1 270w" /> </a></figure><div class="thumbnail-style2-inner"><div class="post-title"><h5><a href="https://socialitelife.com/bruno-alcantara-tian-richards-neil-patrick-harris-and-more-insta-snaps/" title="Bruno Alcantara, Tian Richards, Neil Patrick Harris, and more Insta Snaps"><span>Bruno Alcantara, Tian Richards, Neil Patrick Harris, and more Insta Snaps</span></a></h5></div></div></div><div class="post thumbnail-style3 post-72123 type-post status-publish format-standard has-post-thumbnail hentry category-eye-candy tag-instahottie tag-jason-moattar tag-photos mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <a href="https://socialitelife.com/meet-instagram-hottie-jason-moattar/"> <img width="90" height="90" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/jason-moattar-photos-07072022-2.jpg?resize=20%2C20&amp;ssl=1" class="attachment-theissue-thumbnail size-theissue-thumbnail thb-lazyload lazyload wp-post-image" alt="Jason Moattar" loading="lazy" sizes="(max-width: 90px) 100vw, 90px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/jason-moattar-photos-07072022-2.jpg?resize=90%2C90&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/jason-moattar-photos-07072022-2.jpg?resize=90%2C90&amp;ssl=1 90w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/jason-moattar-photos-07072022-2.jpg?resize=20%2C19&amp;ssl=1 20w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/jason-moattar-photos-07072022-2.jpg?zoom=2&amp;resize=90%2C90&amp;ssl=1 180w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/jason-moattar-photos-07072022-2.jpg?zoom=3&amp;resize=90%2C90&amp;ssl=1 270w" /> </a></figure><div class="thumbnail-style2-inner"><div class="post-title"><h5><a href="https://socialitelife.com/meet-instagram-hottie-jason-moattar/" title="Meet Instagram hottie Jason Moattar"><span>Meet Instagram hottie Jason Moattar</span></a></h5></div></div></div><div class="post thumbnail-style3 post-72067 type-post status-publish format-standard has-post-thumbnail hentry category-eye-candy category-fashion category-featured tag-levi-conely tag-male-model-spotlight tag-models tag-photos mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <a href="https://socialitelife.com/levi-conely-male-model-spotlight/"> <img width="90" height="90" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/levi-conely-photos-07062022-3.jpg?resize=20%2C20&amp;ssl=1" class="attachment-theissue-thumbnail size-theissue-thumbnail thb-lazyload lazyload wp-post-image" alt="Levi Conely" loading="lazy" sizes="(max-width: 90px) 100vw, 90px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/levi-conely-photos-07062022-3.jpg?resize=90%2C90&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/levi-conely-photos-07062022-3.jpg?resize=90%2C90&amp;ssl=1 90w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/levi-conely-photos-07062022-3.jpg?resize=20%2C19&amp;ssl=1 20w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/levi-conely-photos-07062022-3.jpg?zoom=2&amp;resize=90%2C90&amp;ssl=1 180w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/levi-conely-photos-07062022-3.jpg?zoom=3&amp;resize=90%2C90&amp;ssl=1 270w" /> </a></figure><div class="thumbnail-style2-inner"><div class="post-title"><h5><a href="https://socialitelife.com/levi-conely-male-model-spotlight/" title="Levi Conely: Male Model Spotlight"><span>Levi Conely: Male Model Spotlight</span></a></h5></div></div></div><div class="post thumbnail-style3 post-71902 type-post status-publish format-standard has-post-thumbnail hentry category-eye-candy tag-instahottie tag-jony-evans tag-models tag-photos mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <a href="https://socialitelife.com/meet-instagram-hottie-jony-evans/"> <img width="90" height="90" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/jony-evans-photos-06302022-3.jpg?resize=20%2C20&amp;ssl=1" class="attachment-theissue-thumbnail size-theissue-thumbnail thb-lazyload lazyload wp-post-image" alt="Jony Evans" loading="lazy" sizes="(max-width: 90px) 100vw, 90px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/jony-evans-photos-06302022-3.jpg?resize=90%2C90&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/jony-evans-photos-06302022-3.jpg?resize=90%2C90&amp;ssl=1 90w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/jony-evans-photos-06302022-3.jpg?resize=20%2C19&amp;ssl=1 20w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/jony-evans-photos-06302022-3.jpg?zoom=2&amp;resize=90%2C90&amp;ssl=1 180w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/jony-evans-photos-06302022-3.jpg?zoom=3&amp;resize=90%2C90&amp;ssl=1 270w" /> </a></figure><div class="thumbnail-style2-inner"><div class="post-title"><h5><a href="https://socialitelife.com/meet-instagram-hottie-jony-evans/" title="Meet Instagram Hottie Jony Evans"><span>Meet Instagram Hottie Jony Evans</span></a></h5></div></div></div><div class="post thumbnail-style3 post-18921 type-post status-publish format-standard has-post-thumbnail hentry category-sl-flashback tag-chris-hemsworth tag-vacation mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <a href="https://socialitelife.com/chris-hemsworth-needed-an-extra-large-prosthetic-penis-to-make-that-scene-work-for-vacation-sl-flashback/"> <img width="90" height="90" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2019/07/chris-hemsworth-vacation-main-07272019.jpg?resize=20%2C20&amp;ssl=1" class="attachment-theissue-thumbnail size-theissue-thumbnail thb-lazyload lazyload wp-post-image" alt="Chris Hemsworth Vacation" loading="lazy" sizes="(max-width: 90px) 100vw, 90px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2019/07/chris-hemsworth-vacation-main-07272019.jpg?resize=90%2C90&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2019/07/chris-hemsworth-vacation-main-07272019.jpg?resize=90%2C90&amp;ssl=1 90w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2019/07/chris-hemsworth-vacation-main-07272019.jpg?resize=20%2C19&amp;ssl=1 20w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2019/07/chris-hemsworth-vacation-main-07272019.jpg?resize=45%2C45&amp;ssl=1 45w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2019/07/chris-hemsworth-vacation-main-07272019.jpg?zoom=2&amp;resize=90%2C90&amp;ssl=1 180w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2019/07/chris-hemsworth-vacation-main-07272019.jpg?zoom=3&amp;resize=90%2C90&amp;ssl=1 270w" /> </a></figure><div class="thumbnail-style2-inner"><div class="post-title"><h5><a href="https://socialitelife.com/chris-hemsworth-needed-an-extra-large-prosthetic-penis-to-make-that-scene-work-for-vacation-sl-flashback/" title="Chris Hemsworth Needed An Extra Large Prosthetic Penis To Make That Scene Work For ‘Vacation’ — SL FLASHBACK"><span>Chris Hemsworth Needed An Extra Large Prosthetic Penis To Make That Scene Work For ‘Vacation’ — SL FLASHBACK</span></a></h5></div></div></div></div><div class="thb-preloader"> <svg class="material-spinner" width="50px" height="50px" viewBox="0 0 66 66" xmlns="http://www.w3.org/2000/svg"> <circle class="material-path" fill="none" stroke-width="6" stroke-linecap="round" cx="33" cy="33" r="30"></circle> </svg></div></div></div></div></li></ul></div><div class="thb-search-holder"> <svg version="1.1" class="thb-search-icon" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" viewBox="0 0 14 14" enable-background="new 0 0 14 14" xml:space="preserve" width="14" height="14"> <path d="M13.8,12.7l-3-3c0.8-1,1.3-2.3,1.3-3.8c0-3.3-2.7-6-6.1-6C2.7,0,0,2.7,0,6c0,3.3,2.7,6,6.1,6c1.4,0,2.6-0.5,3.6-1.2l3,3
 c0.1,0.1,0.3,0.2,0.5,0.2c0.2,0,0.4-0.1,0.5-0.2C14.1,13.5,14.1,13,13.8,12.7z M1.5,6c0-2.5,2-4.5,4.5-4.5c2.5,0,4.5,2,4.5,4.5
 c0,2.5-2,4.5-4.5,4.5C3.5,10.5,1.5,8.5,1.5,6z"/> </svg></div></div></div></div><div class="row"><div class="small-12 columns"><div class="thb-navbar"><nav class="full-menu"><ul id="menu-site-wide-menu" class="thb-full-menu thb-standard"><li id="menu-item-1743" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1743"><a href="https://socialitelife.com/category/entertainment/"><span>Entertainment</span></a><ul class="sub-menu "><li id="menu-item-16713" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16713"><a href="https://socialitelife.com/category/entertainment/celebrity/"><span>Celebrity</span></a></li><li id="menu-item-16125" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16125"><a href="https://socialitelife.com/category/entertainment/movies/"><span>Movies</span></a></li><li id="menu-item-16124" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16124"><a href="https://socialitelife.com/category/entertainment/tv/"><span>TV</span></a></li><li id="menu-item-16123" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16123"><a href="https://socialitelife.com/category/entertainment/music/"><span>Music</span></a></li><li id="menu-item-16126" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16126"><a href="https://socialitelife.com/category/fashion/"><span>Fashion</span></a></li><li id="menu-item-20600" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20600"><a href="https://socialitelife.com/tag/podcasts/"><span>Podcasts</span></a></li><li id="menu-item-23688" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23688"><a href="https://socialitelife.com/category/real-housewives/"><span>Real Housewives</span></a></li><li id="menu-item-528" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-528"><a href="https://socialitelife.com/category/sl-flashback/"><span>SL Flashback</span></a></li></ul></li><li id="menu-item-16712" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-16712"><a href="https://socialitelife.com/category/drag-queens/"><span>Drag Queens</span></a><ul class="sub-menu "><li id="menu-item-14251" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14251"><a href="https://socialitelife.com/tag/the-week-in-drag/"><span>The Week in Drag</span></a></li><li id="menu-item-10323" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10323"><a href="https://socialitelife.com/tag/rupauls-drag-race/"><span>RuPaul&#8217;s Drag Race</span></a></li><li id="menu-item-41509" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41509"><a href="https://socialitelife.com/tag/rupauls-drag-race-all-stars/"><span>RuPaul&#8217;s Drag Race All Stars</span></a></li><li id="menu-item-23598" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23598"><a href="https://socialitelife.com/tag/rupauls-drag-race-uk/"><span>RuPaul&#8217;s Drag Race UK</span></a></li></ul></li><li id="menu-item-326" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-326"><a href="https://socialitelife.com/category/eye-candy/"><span>Eye Candy</span></a><ul class="sub-menu "><li id="menu-item-1762" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1762"><a href="https://socialitelife.com/tag/man-candy"><span>Insta Snaps</span></a></li><li id="menu-item-1760" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1760"><a href="https://socialitelife.com/tag/instahottie"><span>Instahottie</span></a></li><li id="menu-item-1761" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1761"><a href="https://socialitelife.com/tag/male-model-monday"><span>Male Model Monday</span></a></li></ul></li><li id="menu-item-7032" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-7032"><a href="https://socialitelife.com/category/interviews/"><span>Interviews</span></a><ul class="sub-menu "><li id="menu-item-25651" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-25651"><a href="https://socialitelife.com/tag/socialite-seven/"><span>Socialite Seven</span></a></li></ul></li><li id="menu-item-1765" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1765"><a href="https://socialitelife.com/tag/photos"><span>Photos</span></a></li><li id="menu-item-51007" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-51007"><a href="#"><span>Videos</span></a><ul class="sub-menu "><li id="menu-item-51008" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51008"><a href="https://socialitelife.com/category/viral-video/"><span>Viral Video</span></a></li><li id="menu-item-35309" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35309"><a href="https://socialitelife.com/celebrity-news/"><span>Celebrity News</span></a></li><li id="menu-item-35314" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35314"><a href="https://socialitelife.com/movie-trailer-park/"><span>Movie Trailer Park</span></a></li><li id="menu-item-35311" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35311"><a href="https://socialitelife.com/tv-highlights-and-trailers/"><span>TV Highlights and Trailers</span></a></li><li id="menu-item-35308" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35308"><a href="https://socialitelife.com/netflix-and-chill/"><span>Netflix and Chill</span></a></li><li id="menu-item-35310" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35310"><a href="https://socialitelife.com/sls-pop-music-playlist/"><span>SL’s Pop Music Playlist</span></a></li><li id="menu-item-38919" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38919"><a href="https://socialitelife.com/in-real-life/"><span>In Real Life</span></a></li><li id="menu-item-35312" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35312"><a href="https://socialitelife.com/male-models/"><span>Fashion</span></a></li><li id="menu-item-35313" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35313"><a href="https://socialitelife.com/drag-queen-fabulosity/"><span>Drag Queen Fabulosity</span></a></li></ul></li><li id="menu-item-14069" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14069"><a href="https://amzn.to/2RI8nUF"><span>SL Shop</span></a></li><li id="menu-item-49221" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49221"><a href="https://socialitelife.com/partners/"><span>Partners</span></a></li></ul></nav></div></div></div></header><div role="main"><div id="infinite-article" data-infinite="off" data-security="56714dbd71"><div class="post-detail-row has-article-padding"><div class="row"><div class="small-12 columns"><article itemscope itemtype="http://schema.org/Article" class="post post-detail post-detail-style4 post-72174 type-post status-publish format-standard has-post-thumbnail hentry category-drag-queens category-featured tag-alaska tag-aubrey-haive tag-batty-davis tag-bendelacreme tag-bob-the-drag-queen tag-canadas-drag-race tag-daya-betty tag-designing-women tag-drag-race-france tag-gottmik tag-jaida-essence-hall tag-jaymes-mansfield tag-jinkx-monsoon tag-joseph-shepherd tag-kara-mel-dville tag-katya tag-laganja-estranja tag-leslie-jordan tag-max-malanaphy tag-michelle-visage tag-monet-x-change tag-peppermint tag-raja tag-rhys-nicholson tag-rupaul tag-rupauls-drag-race-all-stars tag-rupauls-drag-race-down-under tag-rupauls-drag-race tag-scarlet-envy tag-sharon-needles tag-shea-coulee tag-the-vivienne tag-the-week-in-drag tag-trinity-the-tuck tag-trixie-mattel tag-video tag-violet-chachki tag-willam tag-willow-pill tag-yuhua-hamasaki tag-yvie-oddly mv-content-wrapper thb-post-share-style1" id="post-72174" data-id="72174" data-url="https://socialitelife.com/the-week-in-drag-we-swear-its-not-all-trixie-mattel-content-say-gday-to-the-down-under-queens-nina-west-hits-comic-con-all-stars-fashion-and-more/"><div class="post-title-container"><aside class="post-category post-detail-category"> <a href="https://socialitelife.com/category/drag-queens/" rel="category tag">Drag Queens</a></aside><header class="post-title entry-header"><h1 class="entry-title" itemprop="headline"> The Week in Drag – We swear it’s not all Trixie Mattel content! Say G’Day to the Down Under queens, Nina West hits Comic Con, All Stars fashion and more</h1></header><div class="thb-post-title-bottom thb-post-share-style1"><div class="thb-post-title-inline-author"><div class="author-and-date"><div class="post-author thb-post-author-269"> <em>by</em> <a href="https://socialitelife.com/author/christinef/" title="Posts by Christine Fitzgerald" rel="author">Christine Fitzgerald</a></div><div class="thb-post-date"> July 10, 2022</div></div></div></div></div><div class="article-container"><div class="post-content-wrapper"><div class="thb-article-featured-image "
 data-override="off"> <img width="1200" height="675" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/rpdr-down-under-season-2.jpg?fit=20%2C11&amp;ssl=1" class="attachment-theissue-full-x2 size-theissue-full-x2 thb-lazyload lazyload wp-post-image" alt="RuPaul’s Drag Race Down Under Season 2" sizes="(max-width: 1200px) 100vw, 1200px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/rpdr-down-under-season-2.jpg?fit=1200%2C675&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/rpdr-down-under-season-2.jpg?w=1200&amp;ssl=1 1200w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/rpdr-down-under-season-2.jpg?resize=800%2C450&amp;ssl=1 800w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/rpdr-down-under-season-2.jpg?resize=1160%2C653&amp;ssl=1 1160w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/rpdr-down-under-season-2.jpg?resize=370%2C208&amp;ssl=1 370w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/rpdr-down-under-season-2.jpg?resize=20%2C11&amp;ssl=1 20w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/rpdr-down-under-season-2.jpg?resize=185%2C104&amp;ssl=1 185w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/rpdr-down-under-season-2.jpg?resize=740%2C416&amp;ssl=1 740w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/rpdr-down-under-season-2.jpg?resize=400%2C225&amp;ssl=1 400w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/rpdr-down-under-season-2.jpg?resize=85%2C48&amp;ssl=1 85w" /></div><div class="thb-post-share-container"><div class="thb-fixed-container"><div class="thb-fixed-top"><div class="thb-article-author"><div class="author-content"> <a href="https://socialitelife.com/author/christinef/" rel="author">Christine Fitzgerald</a><p></p></div></div><div class="thb-fixed-shares-container"><div class="thb-fixed sticky-post-shares"><div class="thb-social-top style1 sharing-counts-off"><div class="thb-social-top-buttons"><div class="social-button-holder"> <a href="https://twitter.com/intent/tweet?text=The%20Week%20in%20Drag%20–%20We%20swear%20it’s%20not%20all%20Trixie%20Mattel%20content!%20Say%20G’Day%20to%20the%20Down%20Under%20queens,%20Nina%20West%20hits%20Comic%20Con,%20All%20Stars%20fashion%20and%20more&#038;via=socialitelife&#038;url=https://socialitelife.com/the-week-in-drag-we-swear-its-not-all-trixie-mattel-content-say-gday-to-the-down-under-queens-nina-west-hits-comic-con-all-stars-fashion-and-more/" rel="noreferrer" class="social social-twitter"
 > <span class="thb-social-icon"> <i class="thb-icon-twitter"></i> </span> </a></div><div class="social-button-holder"> <a href="https://www.facebook.com/sharer.php?u=https://socialitelife.com/the-week-in-drag-we-swear-its-not-all-trixie-mattel-content-say-gday-to-the-down-under-queens-nina-west-hits-comic-con-all-stars-fashion-and-more/" rel="noreferrer" class="social social-facebook"
 > <span class="thb-social-icon"> <i class="thb-icon-facebook"></i> </span> </a></div><div class="social-button-holder"> <a href="https://pinterest.com/pin/create/bookmarklet/?url=https://socialitelife.com/the-week-in-drag-we-swear-its-not-all-trixie-mattel-content-say-gday-to-the-down-under-queens-nina-west-hits-comic-con-all-stars-fashion-and-more/&#038;media=https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/rpdr-down-under-season-2.jpg?fit=1200%2C675&#038;ssl=1" rel="noreferrer" class="social social-pinterest"
 > <span class="thb-social-icon"> <i class="thb-icon-pinterest"></i> </span> </a></div><div class="social-button-holder"> <a href="https://reddit.com/submit?url=https://socialitelife.com/the-week-in-drag-we-swear-its-not-all-trixie-mattel-content-say-gday-to-the-down-under-queens-nina-west-hits-comic-con-all-stars-fashion-and-more/" rel="noreferrer" class="social social-reddit"
 > <span class="thb-social-icon"> <i class="thb-icon-reddit"></i> </span> </a></div><div class="social-button-holder"> <a href="https://share.flipboard.com/bookmarklet/popout?v=2&#038;title=The%20Week%20in%20Drag%20–%20We%20swear%20it’s%20not%20all%20Trixie%20Mattel%20content!%20Say%20G’Day%20to%20the%20Down%20Under%20queens,%20Nina%20West%20hits%20Comic%20Con,%20All%20Stars%20fashion%20and%20more&#038;url=https://socialitelife.com/the-week-in-drag-we-swear-its-not-all-trixie-mattel-content-say-gday-to-the-down-under-queens-nina-west-hits-comic-con-all-stars-fashion-and-more/" rel="noreferrer" class="social social-flipboard"
 > <span class="thb-social-icon"> <i class="thb-icon-flipboard"></i> </span> </a></div><div class="social-button-holder"> <a href="https://www.linkedin.com/cws/share?url=https://socialitelife.com/the-week-in-drag-we-swear-its-not-all-trixie-mattel-content-say-gday-to-the-down-under-queens-nina-west-hits-comic-con-all-stars-fashion-and-more/" rel="noreferrer" class="social social-linkedin"
 > <span class="thb-social-icon"> <i class="thb-icon-linkedin"></i> </span> </a></div><div class="social-button-holder"> <a href="https://wa.me/?text=The%20Week%20in%20Drag%20–%20We%20swear%20it’s%20not%20all%20Trixie%20Mattel%20content!%20Say%20G’Day%20to%20the%20Down%20Under%20queens,%20Nina%20West%20hits%20Comic%20Con,%20All%20Stars%20fashion%20and%20more%20https://socialitelife.com/the-week-in-drag-we-swear-its-not-all-trixie-mattel-content-say-gday-to-the-down-under-queens-nina-west-hits-comic-con-all-stars-fashion-and-more/" rel="noreferrer" class="social social-whatsapp"
 data-action="share/whatsapp/share"> <span class="thb-social-icon"> <i class="thb-icon-whatsapp"></i> </span> </a></div><div class="social-button-holder"> <a href="/cdn-cgi/l/email-protection#bd82cec8dfd7d8dec980e9d5d8988f8dead8d8d6988f8dd4d3988f8df9cfdcda988f8d5f3d2e988f8dead8988f8dcecad8dccf988f8dd4c95f3d24ce988f8dd3d2c9988f8ddcd1d1988f8de9cfd4c5d4d8988f8df0dcc9c9d8d1988f8dded2d3c9d8d3c99c988f8deedcc4988f8dfa5f3d24f9dcc4988f8dc9d2988f8dc9d5d8988f8df9d2cad3988f8de8d3d9d8cf988f8dccc8d8d8d3ce91988f8df3d4d3dc988f8dead8cec9988f8dd5d4c9ce988f8dfed2d0d4de988f8dfed2d391988f8dfcd1d1988f8deec9dccfce988f8ddbdcced5d4d2d3988f8ddcd3d9988f8dd0d2cfd89b9e8d8e8586dfd2d9c480e9d5d8988f8dead8d8d6988f8dd4d3988f8df9cfdcda988f8d5f3d2e988f8dead8988f8dcecad8dccf988f8dd4c95f3d24ce988f8dd3d2c9988f8ddcd1d1988f8de9cfd4c5d4d8988f8df0dcc9c9d8d1988f8dded2d3c9d8d3c99c988f8deedcc4988f8dfa5f3d24f9dcc4988f8dc9d2988f8dc9d5d8988f8df9d2cad3988f8de8d3d9d8cf988f8dccc8d8d8d3ce91988f8df3d4d3dc988f8dead8cec9988f8dd5d4c9ce988f8dfed2d0d4de988f8dfed2d391988f8dfcd1d1988f8deec9dccfce988f8ddbdcced5d4d2d3988f8ddcd3d9988f8dd0d2cfd8988f8dd5c9c9cdce879292ced2ded4dcd1d4c9d8d1d4dbd893ded2d092c9d5d890cad8d8d690d4d390d9cfdcda90cad890cecad8dccf90d4c9ce90d3d2c990dcd1d190c9cfd4c5d4d890d0dcc9c9d8d190ded2d3c9d8d3c990cedcc490dad9dcc490c9d290c9d5d890d9d2cad390c8d3d9d8cf90ccc8d8d8d3ce90d3d4d3dc90cad8cec990d5d4c9ce90ded2d0d4de90ded2d390dcd1d190cec9dccfce90dbdcced5d4d2d390dcd3d990d0d2cfd892" rel="noreferrer" class="social social-email"> <span class="thb-social-icon"> <i class="thb-icon-mail"></i> </span> </a></div></div></div></div></div></div></div><div class="post-content-container"><div class="post-content entry-content" itemprop="articleBody"><p>Hello, hello, hello! We’re back with a post-holiday edition of updates and news from your favorite queens in <strong><a href="/tag/the-week-in-drag">The Week in Drag</a></strong>.</p><p>This week, the legendary <em>All Stars</em> created their own soon-to-be viral dances and revealed their style on the runway. Last week, the dolls nailed a holiday-themed acting challenge and showcased some knotty fashions on the runway.</p><p>We’ve got reviews and opinions about last week’s episode as well as lots (and lots…and lots) of videos from the insanely busy Trixie Mattel, another unboxing from Willam, an interview where season 7 queen Max gets exposed, an update from the congenial Nina West and so much more. There’s a lot to take in, so let’s bring it to the runway!</p><p>This week on <em>RuPaul’s Drag Race All Stars</em>, the queens had to take to TikTok and create a viral dance craze and reveal their fashion best on the runway. As the episode opens, <strong>Monét</strong> and <strong>Shea</strong> commiserate as the last remaining 1-star queens and <strong>Jaida</strong> plays up how despondent she was to get the block. Ru describes the challenge as a “master class in branding” (first lesson: all of the queens have to choreograph their dance to a Mama Ru song), so who became a social media sensation?</p><figure class="wp-block-embed is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper"><div class="flex-video widescreen youtube" data-plyr-embed-id="ifOUD3neDf4" data-plyr-provider="youtube"><iframe loading="lazy" title="All Stars 7 Episode 9 Sneak Peek 📱🎶 RuPaul’s Drag Race All Stars" width="1170" height="658" src="https://www.youtube.com/embed/ifOUD3neDf4?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div></div></figure><p>The videos, as with every challenge this season, produced some immensely entertaining results. Shea gave us a literal performance of Ru’s “Cha Cha Biitch”, Jaida incorporated her “Look over there!” into her routine, <strong>The Vivienne</strong> played up her lack of dance skills and Monét transformed “Freaky Money” into a new payday anthem.&nbsp; And <strong>Jinkx</strong>, oh, how I love you, made a dance out of making a sandwich and there’s no other song for that than the classic “Peanut Butter.”</p><p>On the runway, the theme was “What Lies Beneath” and the queens brought the most beautiful looks that impressed the judges (including guest judge <strong>Ben Platt</strong>.) Shea was a vision in blue, serving up 30s starlet in feathers, tulle, and a backless gown, Jaida took us through the four seasons like a quick-change artist (you know, if this drag thing doesn’t work out, Jaida, you could always go on <em>America&#8217;s Got Talent</em>.) Jinkx gave us a stunning art history class, <strong>Raja</strong> glammed resort wear to the max and Monét delivered a powerful statement.&nbsp;</p><figure class="wp-block-embed is-type-rich is-provider-twitter wp-block-embed-twitter"><div class="wp-block-embed__wrapper"><blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">Category Is: What Lies Beneath 👀<br><br>Lewk after lewk, our legends turned it out on the runway! 😍 <a href="https://twitter.com/hashtag/AllStars7?src=hash&amp;ref_src=twsrc%5Etfw">#AllStars7</a> Episode 9 is NOW STREAMING on <a href="https://twitter.com/paramountplus?ref_src=twsrc%5Etfw">@paramountplus</a> ✨ <a href="https://t.co/Ht5qiry8xr">pic.twitter.com/Ht5qiry8xr</a></p>&mdash; RuPaul&#39;s Drag Race (@RuPaulsDragRace) <a href="https://twitter.com/RuPaulsDragRace/status/1545467761383579653?ref_src=twsrc%5Etfw">July 8, 2022</a></blockquote><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script> </div></figure><p>Ru declared Jinkx and Monét as the week’s top two and, for the first time in <em>Drag Race</em> her-story, the duo face off in a spoken word lip sync, to <strong>Dixie Carter</strong>’s iconic <a href="https://www.youtube.com/watch?v=Latj4SAu0Ps">“Night the Lights Went Out in Georgia”</a> monologue from <em><strong>Designing Women</strong>.</em> Both queens did Julia Sugarbaker justice, but only one can win and Monét joins the 2-star club. When it comes to the recipient of the platinum plunger, Monét seemingly fulfilled Raja’s quest to know the secrets of the plunger.&nbsp; Next week, the queens test their comedy chops with the traditional roast challenge (for the Kennedy Davenport Center Honors.) Who will deliver a job well-done? Tune in next week to find out.</p><figure class="wp-block-embed is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper"><div class="flex-video widescreen youtube" data-plyr-embed-id="QHWUsdwVqBo" data-plyr-provider="youtube"><iframe loading="lazy" title="All Stars 7 Episode 9 Lip Sync 🎭 RuPaul’s Drag Race All Stars 7" width="1170" height="658" src="https://www.youtube.com/embed/QHWUsdwVqBo?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div></div></figure><p>Last week, the queens of <em>RuPaul’s Drag Race All Stars</em> took us on a spooky visit to Santa’s School for Girls (in one of the best acting challenges in a long time) and gave us amazing “warm fuzzies, but make it fashion” looks on the runway. <strong>Bob</strong> and <strong>Peppermint</strong> school us on last week’s episode on “The Pit Stop.”</p><figure class="wp-block-embed is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper"><div class="flex-video widescreen youtube" data-plyr-embed-id="oB2de1hFeig" data-plyr-provider="youtube"><iframe loading="lazy" title="The Pit Stop AS7 E08 | Bob The Drag Queen &amp; Peppermint! | RuPaul’s Drag Race All Stars" width="1170" height="658" src="https://www.youtube.com/embed/oB2de1hFeig?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div></div></figure><p><strong>Laganja</strong> <strong>Etrangja</strong> and <strong>Joseph</strong> <strong>Shepherd</strong> discuss the challenge&#8217;s performances, the looks and more on the latest episode of “Queening Out.”</p><figure class="wp-block-embed is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper"><div class="flex-video widescreen youtube" data-plyr-embed-id="ICe-MlKftIA" data-plyr-provider="youtube"><iframe loading="lazy" title="Laganja Estranja &amp; Joseph Shepherd Recap Drag Race AS7 E8 Santa&#039;s School for Girls | Queening Out" width="1170" height="658" src="https://www.youtube.com/embed/ICe-MlKftIA?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div></div></figure><p>Laganja keeps the fashion commentary coming as she and <strong>Yuhua Hamasaki</strong> share some laughs and their “Bootleg Opinions.”</p><figure class="wp-block-embed is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper"><div class="flex-video widescreen youtube" data-plyr-embed-id="YiC7XpJFSnU" data-plyr-provider="youtube"><iframe loading="lazy" title="All Stars 7 x Bootleg Opinions: Episode 8: &quot;Knitty-Knitty, Bang-Bang!&quot; with Laganja Estranja" width="1170" height="658" src="https://www.youtube.com/embed/YiC7XpJFSnU?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen title="All Stars 7 x Bootleg Opinions: Episode 8: "Knitty-Knitty, Bang-Bang!" with Laganja Estranja"></iframe></div></div></figure><p><strong>Willow Pill</strong>, <strong>Yvie Oddly</strong> and <strong>Daya Betty</strong> take a seat on the rattan couches and join <strong>Batty Davis</strong> and <strong>Kara Mel D’Ville</strong> for the weekly Roscoe’s Viewing Party that I will one day attend.</p><figure class="wp-block-embed is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper"><div class="flex-video widescreen youtube" data-plyr-embed-id="8pUkePH0DeI" data-plyr-provider="youtube"><iframe loading="lazy" title="Willow Pill, Yvie Oddly &amp; Daya Betty: Roscoe&#039;s RPDR All Stars 7 Viewing Party with Batty &amp; Kara" width="1170" height="658" src="https://www.youtube.com/embed/8pUkePH0DeI?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div></div></figure><p>The season seven <em>All Stars</em> rate some of their fellow queens’ iconic looks as they play “Drip or Drop” with Cosmopolitan. Who wore feathers better? Whose headpiece was a stun? Who rocked the best-spiked look? Watch and find out.</p><figure class="wp-block-embed is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper"><div class="flex-video widescreen youtube" data-plyr-embed-id="tSnlRp-SBaA" data-plyr-provider="youtube"><iframe loading="lazy" title="Ru Paul&#039;s Drag Race All Stars Rating Looks From Other Queens *ICONIC* | Drip Or Drop? | Cosmopolitan" width="1170" height="658" src="https://www.youtube.com/embed/tSnlRp-SBaA?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div></div></figure><p>In another video, this time from <em>Allure</em>, the <em>All Stars</em> try something they haven’t before, like creating dog drag names, recording a laugh track (Yvie was made for this) going through guided meditation, and drawing pictures with foundation and blush. Also, Yvie makes a DIY pageant sash, the queens attempt to identify celebrity perfume and give us their best Ru impersonations.</p><figure class="wp-block-embed is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper"><div class="flex-video widescreen youtube" data-plyr-embed-id="b3-Fpa1Bwoo" data-plyr-provider="youtube"><iframe loading="lazy" title="RuPaul&#039;s Drag Race All Stars Try 9 Things They&#039;ve Never Done Before | Allure" width="1170" height="658" src="https://www.youtube.com/embed/b3-Fpa1Bwoo?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div></div></figure><p>More drag? Yes, please. The second season of <em>RuPaul’s Drag Race Down Under</em> is almost here! The series will debut July 30th, exclusively on WOW Presents Plus. RuPaul will return as host with <strong>Michelle Visage</strong> and comedian <strong>Rhys Nicholson</strong> serving as judges. 10 more fierce drag entertainers from Australia and New Zealand who will be competing in a variety of challenges and using their charisma, uniqueness, nerve, and talent to win the title of “Down Under’s Next Drag Superstar.” Check out the trailer and meet the queens (and let’s all agree that <strong>Aubrey Haive</strong> is an amazing drag name.)</p><figure class="wp-block-embed is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper"><div class="flex-video widescreen youtube" data-plyr-embed-id="P_OU9hTSOdM" data-plyr-provider="youtube"><iframe loading="lazy" title="Meet The Queens of RuPaul&#039;s Drag Race Down Under Season 2 🇦🇺🇳🇿 Premieres July 30" width="1170" height="658" src="https://www.youtube.com/embed/P_OU9hTSOdM?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div></div></figure><figure class="wp-block-embed is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper"><div class="flex-video widescreen youtube" data-plyr-embed-id="6Va6sHeWbVg" data-plyr-provider="youtube"><iframe loading="lazy" title="Meet The Queens (FULL COMPILATION) 🇦🇺🇳🇿 RuPaul&#039;s Drag Race Down Under Season 2" width="1170" height="658" src="https://www.youtube.com/embed/6Va6sHeWbVg?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div></div></figure><p>It’s never too early to treat yourself to some holiday cheer, so why not celebrate the season with Jinkx Monsoon and <strong>BenDeLaCreme</strong>? The hilarious duo is taking the Jinkx &amp; Dela Holiday Show on the road for a 22-city national tour, kicking off in Buffalo on November 23. <a href="https://socialitelife.com/christmas-july-jinkx-monsoon-bendelacreme-holiday-tour/">Read more about it</a> and visit <a href="http://www.jinkxanddela.com/" target="_blank" rel="noreferrer noopener">jinkxanddela.com</a> for tickets and info.</p><figure class="wp-block-embed is-type-rich is-provider-instagram wp-block-embed-instagram"><div class="wp-block-embed__wrapper"><div class="sbi-embed-wrap"><blockquote class="instagram-media sbi-embed" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/CfuAikTrOs7/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="14" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:658px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);"><div style="padding:16px;"> <a href="https://www.instagram.com/p/CfuAikTrOs7/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"><div style=" display: flex; flex-direction: row; align-items: center;"><div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div><div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div><div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div><div style="padding-top: 8px;"><div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;">View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div><div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div><div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"><div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div><div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div></div><div style="margin-left: auto;"><div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div><div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div><div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div><div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center; margin-bottom: 24px;"><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 224px;"></div><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 144px;"></div></div></a><p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;"><a href="https://www.instagram.com/p/CfuAikTrOs7/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none;" target="_blank">A post shared by BenDeLaCreme ✨🎄 (@bendelacreme)</a></p></div></blockquote><script async src="//platform.instagram.com/en_US/embeds.js"></script></div></div></figure><p>The delightful <strong>Nina West</strong> is bringing her brand of kindness to San Diego Comic Con with a very special, first-of-its-kind panel previewing her first-ever children’s book <em>The You Kind of Kind</em>. Nina will be one of the first-ever drag queens to host a panel at SDCC about their own project. I am so excited to make my San Diego Comic Con debut to talk about my new book&nbsp;<em>The You Kind of Kind!</em>” said Nina.</p><p>“SDCC is a place where thousands of like-minded people come together to celebrate their fandoms, and, as a member of this community, I am thrilled to share my new project with this incredible community of fans! And it doesn’t get any better, because I get to share in this experience with my friend Ashley Eckstein, and the illustrator of <em>The You Kind of Kind</em>, Hayden Evans! I can’t wait to meet you all and share the kindness and love!” <em>The You Kind of Kind</em> hits shelves on October 25. For pre-orders visit&nbsp;<a href="https://79smg.r.a.d.sendibm1.com/mk/cl/f/os76f6VuPEMRwm4AU-zXbAGaFzzq3jYjIYe0-HGI7kX-gsKtq7-xZOvXenpJ3y3fnwCuZ--e0yaDEwRPixeaT0-OALAxZUXSP1sPwz3Kj_EAjQ-up3ul4kGKBkspWC7wiBoKykdWmiQt-e2I6Z7U-V23t70Qoxhz21h-3s-Ir2lgA5KiPwRcCd5578UIwa1sqD8RuLxrX92ZxZuhS0szyfIw6NzLwDGeQfKzQ4K-zBisqQRftcxSdyNWEmwAITSJSwMBWi2KU1gHLoQavU7i4im1VUBog54KWVUiI14OXzQx9ocxcC0u" target="_blank" rel="noreferrer noopener">www.ninawest.com&nbsp;</a>.</p><figure class="wp-block-embed is-type-rich is-provider-instagram wp-block-embed-instagram"><div class="wp-block-embed__wrapper"><div class="sbi-embed-wrap"><blockquote class="instagram-media sbi-embed" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/reel/CfsLMhBjvVu/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="14" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:658px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);"><div style="padding:16px;"> <a href="https://www.instagram.com/reel/CfsLMhBjvVu/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"><div style=" display: flex; flex-direction: row; align-items: center;"><div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div><div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div><div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div><div style="padding-top: 8px;"><div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;">View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div><div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div><div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div><div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"><div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div><div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div></div><div style="margin-left: auto;"><div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div><div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div><div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div><div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center; margin-bottom: 24px;"><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 224px;"></div><div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 144px;"></div></div></a><p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;"><a href="https://www.instagram.com/reel/CfsLMhBjvVu/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none;" target="_blank">A post shared by Nina West (@ninawest)</a></p></div></blockquote><script async src="//platform.instagram.com/en_US/embeds.js"></script></div></div></figure><p>It’s probably not a surprise but the queens of <em>Drag Race France</em> are killing it on the runway. After last week’s spectacular Gautier-inspired looks, this week they blossomed again with floral ensembles. <strong>Adriana</strong> and <strong>Scarlet Envy</strong> toot and boot the looks on “Fashion Photo Ruview.”</p><figure class="wp-block-embed is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper"><div class="flex-video widescreen youtube" data-plyr-embed-id="8DaWBMwHhmU" data-plyr-provider="youtube"><iframe loading="lazy" title="FASHION PHOTO RUVIEW: Drag Race France Season 1 - Say it with Flowers" width="1170" height="658" src="https://www.youtube.com/embed/8DaWBMwHhmU?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div></div></figure><p>And now let’s catch up with the unstoppable <strong>Trixie Mattel</strong>. Here, she treats us to her latest PR haul, including makeup from Sugar Pill, Colourpop (with its latest <em>Star Wars</em> line), and Resy. Also, I can’t stop thinking about the Hipdot x Cup O’ Noodles collection.</p><div class="post thumbnail-seealso post-71656 type-post status-publish format-standard has-post-thumbnail hentry category-celebrity category-featured category-music tag-beyonce tag-video mv-content-wrapper thb-post-share-style1"> <span class="thb-seealso-text">See Also</span><figure class="post-gallery"> <a href="https://socialitelife.com/beyonce-drops-new-dance-track-break-my-soul-listen/"><img width="180" height="180" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2019/07/beyonce-coachella-07252019.jpg?resize=20%2C20&amp;ssl=1" class="attachment-theissue-thumbnail-x2 size-theissue-thumbnail-x2 thb-lazyload lazyload wp-post-image" alt="2018 Coachella Valley Music And Arts Festival - Weekend 1 - Day 2" loading="lazy" sizes="(max-width: 180px) 100vw, 180px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2019/07/beyonce-coachella-07252019.jpg?resize=180%2C180&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2019/07/beyonce-coachella-07252019.jpg?resize=100%2C100&amp;ssl=1 100w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2019/07/beyonce-coachella-07252019.jpg?resize=180%2C180&amp;ssl=1 180w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2019/07/beyonce-coachella-07252019.jpg?resize=90%2C90&amp;ssl=1 90w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2019/07/beyonce-coachella-07252019.jpg?resize=20%2C19&amp;ssl=1 20w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2019/07/beyonce-coachella-07252019.jpg?resize=45%2C45&amp;ssl=1 45w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2019/07/beyonce-coachella-07252019.jpg?zoom=2&amp;resize=180%2C180&amp;ssl=1 360w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2019/07/beyonce-coachella-07252019.jpg?zoom=3&amp;resize=180%2C180&amp;ssl=1 540w" /></a></figure><div class="thumbnail-seealso-inner"><aside class="post-category "> <a href="https://socialitelife.com/category/entertainment/music/" rel="category tag">Music</a></aside><div class="post-title"><h6><a href="https://socialitelife.com/beyonce-drops-new-dance-track-break-my-soul-listen/" title="Beyoncé drops new dance track ‘Break My Soul’ &#8211; Listen"><span>Beyoncé drops new dance track ‘Break My Soul’ &#8211; Listen</span></a></h6></div></div></div></p><figure class="wp-block-embed is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper"><div class="flex-video widescreen youtube" data-plyr-embed-id="YJASGoQdqDE" data-plyr-provider="youtube"><iframe loading="lazy" title="Blind Reacting to MORE PR | What Does PR Even Stand For Anyway?" width="1170" height="658" src="https://www.youtube.com/embed/YJASGoQdqDE?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div></div></figure><p>Here’s your weekly check-in at the <em>Trixie Motel</em>. In this clip, she conducts lifeguard tryouts with a little help from the charming and adorable <strong>Leslie Jordan</strong>.</p><figure class="wp-block-embed is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper"><div class="flex-video widescreen youtube" data-plyr-embed-id="UNa7Y8FaYcI" data-plyr-provider="youtube"><iframe loading="lazy" title="Lifeguard Tryouts with Leslie Jordan | Trixie Motel | discovery+" width="1170" height="658" src="https://www.youtube.com/embed/UNa7Y8FaYcI?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div></div></figure><p>It’s time to talk about…time. In the latest episode of “UNHhhh”, Trixie is 30 minutes late which prompts a conversation about alarm clocks, being late and all things time.</p><figure class="wp-block-embed is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper"><div class="flex-video widescreen youtube" data-plyr-embed-id="QaPpsaFSG1s" data-plyr-provider="youtube"><iframe loading="lazy" title="UNHhhh ep 181 - Time... Again" width="1170" height="658" src="https://www.youtube.com/embed/QaPpsaFSG1s?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div></div></figure><p>Trixie takes a lie detector test for <em>Vanity Fair</em>.</p><figure class="wp-block-embed is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper"><div class="flex-video widescreen youtube" data-plyr-embed-id="sFfy1nM_ob0" data-plyr-provider="youtube"><iframe loading="lazy" title="Trixie Mattel Takes a Lie Detector Test | Vanity Fair" width="1170" height="658" src="https://www.youtube.com/embed/sFfy1nM_ob0?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div></div></figure><p>I always like watching <strong>Willam</strong> rip through boxes and packages with abandon, so I very much enjoyed this Pride unboxing.</p><figure class="wp-block-embed is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper"><div class="flex-video widescreen youtube" data-plyr-embed-id="nCqpeplFPrc" data-plyr-provider="youtube"><iframe loading="lazy" title="Pride Unboxing w/ WILLAM" width="1170" height="658" src="https://www.youtube.com/embed/nCqpeplFPrc?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div></div></figure><p><strong>Gottmik </strong>(congrats on the name change) and <strong>Violet Chachki</strong> update us on what they’ve been up to (like their recent Pride tour) talk about DragCon, the “Fashion Photo Ruview” controversy, &nbsp;Kim K’s Met Gala look, and more on “No Gorge.”:</p><figure class="wp-block-embed is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper"><div class="flex-video widescreen youtube" data-plyr-embed-id="0JZyGxXXWg8" data-plyr-provider="youtube"><iframe loading="lazy" title="fashion photo review drama+marylin vs kim" width="1170" height="658" src="https://www.youtube.com/embed/0JZyGxXXWg8?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div></div></figure><p>I love Japanese culture and the latest video from <strong>Rock M Sakura</strong> is making me want to go to Los Angeles immediately. Rock takes us to a Maid Café that, if you didn’t know better, would be found in the heart of Tokyo. &nbsp;</p><figure class="wp-block-embed is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper"><div class="flex-video widescreen youtube" data-plyr-embed-id="4j3e7C2_Qlo" data-plyr-provider="youtube"><iframe loading="lazy" title="Visiting a Maid Cafe in LA! Dreamland Maid Cafe!" width="1170" height="658" src="https://www.youtube.com/embed/4j3e7C2_Qlo?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div></div></figure><p>If you’ve asked yourself, “I wonder whatever happened to <em>Drag Race</em> season 7’s <strong>Max</strong>?” Joseph Shepherd is here with the answers in another of his fabulous “Exposed” interviews.</p><figure class="wp-block-embed is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper"><div class="flex-video widescreen youtube" data-plyr-embed-id="5fmPBmqgS80" data-plyr-provider="youtube"><iframe loading="lazy" title="Exposed: An Interview with Max Malanaphy" width="1170" height="658" src="https://www.youtube.com/embed/5fmPBmqgS80?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div></div></figure><p>In Laganja’s latest vlog, she takes us behind the scenes of the “Werk the World” tour.</p><figure class="wp-block-embed is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper"><div class="flex-video widescreen youtube" data-plyr-embed-id="pjZ9w-xPh5M" data-plyr-provider="youtube"><iframe loading="lazy" title="LAGANJA ESTRANJA | Werq The World Vlog! | Part One" width="1170" height="658" src="https://www.youtube.com/embed/pjZ9w-xPh5M?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div></div></figure><p><strong>Sharon Needles</strong> has released the second single and video from her forthcoming album,&nbsp;Absolute Zero (which is <a href="https://ffm.to/absolutezerosn">available for pre-order</a>.) The new song is called <a href="https://ffm.to/flaminhot">“Flamin’ Hot”&nbsp;</a>and Sharon says of the tune, “Some say disco is dead.&nbsp;Researching disco, I have found that some of my favorite rock ‘n’ roll bands had a hand in this disturbing funeral of my favorite soul, funk, disco, and R&amp;B bands. “Flamin’ Hot”&nbsp;was written because I was hung over, and I saw my musicians eating flaming hot Cheetos.&nbsp;I hate food but I love music.&nbsp;I’m famously known for saying unsavory things, but I want to be more famous for making disco songs about savory snacks.&nbsp;Though many people may find a resemblance to Madonna’s Hung Up, it’s really based off of trans French icon Amanda Lear. She likes Blood and Honey, I like Blood/Honey.”</p><figure class="wp-block-embed is-type-video is-provider-youtube wp-block-embed-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper"><div class="flex-video widescreen youtube" data-plyr-embed-id="N0nVeeYrFcE" data-plyr-provider="youtube"><iframe loading="lazy" title="Sharon Needles - Flamin&#039; Hot (Official Music Video)" width="1170" height="658" src="https://www.youtube.com/embed/N0nVeeYrFcE?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></div></div></figure><p>And with that, another week of drag fabulousness comes to an end. But don’t worry, we’ll be back next week with more from the queens. Until then, stay safe, stay healthy and say LOVE!</p><div style="height:100px" aria-hidden="true" class="wp-block-spacer"></div><hr class="wp-block-separator"/><h3 class="has-text-align-center">THE LATEST ON SL</h3><div class="wp-container-1 wp-block-group"><div class="wp-block-group__inner-container"><div data-elink="https://elink.io/embed/9c6c8ac"><a href="https://elink.io" target="_blank" rel="noopener">elink.io</a> | <a href="https://elink.io/p/socialite-links-9c6c8ac" target="_blank" rel="noopener">See Original</a></div><script async="" src="https://d1sf3a4rercrry.cloudfront.net/embed.js" charset="utf-8"></script> </div></div><div style="height:25px" aria-hidden="true" class="wp-block-spacer"></div><div class="wp-container-3 wp-block-group"><div class="wp-block-group__inner-container"><h2 class="has-text-align-center"><strong>FROM OUR PARTNERS</strong></h2><div class="wp-container-2 wp-block-group"><div class="wp-block-group__inner-container"><div data-elink="https://elink.io/embed/9c819b3"><a href="https://elink.io" target="_blank" rel="noopener">elink.io</a> | <a href="https://elink.io/p/9c819b3" target="_blank" rel="noopener">See Original</a></div><script async src="https://d1sf3a4rercrry.cloudfront.net/embed.js" charset="utf-8"></script> </div></div></div></div><p></p><div class="pubexchange_module" id="pubexchange_below_content" data-pubexchange-module-id="2065"></div></div><div class="thb-article-tags"> <span>Tags</span><div> <a href="https://socialitelife.com/tag/alaska/" title="">Alaska</a> <a href="https://socialitelife.com/tag/aubrey-haive/" title="">Aubrey Haive</a> <a href="https://socialitelife.com/tag/batty-davis/" title="">Batty Davis</a> <a href="https://socialitelife.com/tag/bendelacreme/" title="">BenDeLaCreme</a> <a href="https://socialitelife.com/tag/bob-the-drag-queen/" title="">Bob the Drag Queen</a> <a href="https://socialitelife.com/tag/canadas-drag-race/" title="">Canadas Drag Race</a> <a href="https://socialitelife.com/tag/daya-betty/" title="">Daya Betty</a> <a href="https://socialitelife.com/tag/designing-women/" title="">Designing Women</a> <a href="https://socialitelife.com/tag/drag-race-france/" title="">Drag Race France</a> <a href="https://socialitelife.com/tag/gottmik/" title="">Gottmik</a> <a href="https://socialitelife.com/tag/jaida-essence-hall/" title="">Jaida Essence Hall</a> <a href="https://socialitelife.com/tag/jaymes-mansfield/" title="">Jaymes Mansfield</a> <a href="https://socialitelife.com/tag/jinkx-monsoon/" title="">Jinkx Monsoon</a> <a href="https://socialitelife.com/tag/joseph-shepherd/" title="">Joseph Shepherd</a> <a href="https://socialitelife.com/tag/kara-mel-dville/" title="">Kara Mel DVille</a> <a href="https://socialitelife.com/tag/katya/" title="">Katya</a> <a href="https://socialitelife.com/tag/laganja-estranja/" title="">Laganja Estranja</a> <a href="https://socialitelife.com/tag/leslie-jordan/" title="">Leslie Jordan</a> <a href="https://socialitelife.com/tag/max-malanaphy/" title="">Max Malanaphy</a> <a href="https://socialitelife.com/tag/michelle-visage/" title="">Michelle Visage</a> <a href="https://socialitelife.com/tag/monet-x-change/" title="">Monet X Change</a> <a href="https://socialitelife.com/tag/peppermint/" title="">Peppermint</a> <a href="https://socialitelife.com/tag/raja/" title="">Raja</a> <a href="https://socialitelife.com/tag/rhys-nicholson/" title="">Rhys Nicholson</a> <a href="https://socialitelife.com/tag/rupaul/" title="">RuPaul</a> <a href="https://socialitelife.com/tag/rupauls-drag-race-all-stars/" title="">RuPaul&#039;s Drag Race All-Stars</a> <a href="https://socialitelife.com/tag/rupauls-drag-race-down-under/" title="">RuPaul’s Drag Race Down Under</a> <a href="https://socialitelife.com/tag/rupauls-drag-race/" title="">RuPauls Drag Race</a> <a href="https://socialitelife.com/tag/scarlet-envy/" title="">Scarlet Envy</a> <a href="https://socialitelife.com/tag/sharon-needles/" title="">Sharon Needles</a> <a href="https://socialitelife.com/tag/shea-coulee/" title="">Shea Coulee</a> <a href="https://socialitelife.com/tag/the-vivienne/" title="">The Vivienne</a> <a href="https://socialitelife.com/tag/the-week-in-drag/" title="">The Week in Drag</a> <a href="https://socialitelife.com/tag/trinity-the-tuck/" title="">Trinity the Tuck</a> <a href="https://socialitelife.com/tag/trixie-mattel/" title="">Trixie Mattel</a> <a href="https://socialitelife.com/tag/video/" title="">Video</a> <a href="https://socialitelife.com/tag/violet-chachki/" title="">Violet Chachki</a> <a href="https://socialitelife.com/tag/willam/" title="">Willam</a> <a href="https://socialitelife.com/tag/willow-pill/" title="">Willow Pill</a> <a href="https://socialitelife.com/tag/yuhua-hamasaki/" title="">Yuhua Hamasaki</a> <a href="https://socialitelife.com/tag/yvie-oddly/" title="">Yvie Oddly</a></div></div><div class="thb-social-fixed sharing-counts-off"><div class="social-button-holder"> <a href="https://www.facebook.com/sharer.php?u=https://socialitelife.com/the-week-in-drag-we-swear-its-not-all-trixie-mattel-content-say-gday-to-the-down-under-queens-nina-west-hits-comic-con-all-stars-fashion-and-more/" class="social social-facebook"
 > <span class="thb-social-icon"> <i class="thb-icon-facebook"></i> </span> </a></div><div class="social-button-holder"> <a href="https://twitter.com/intent/tweet?text=The%20Week%20in%20Drag%20–%20We%20swear%20it’s%20not%20all%20Trixie%20Mattel%20content!%20Say%20G’Day%20to%20the%20Down%20Under%20queens,%20Nina%20West%20hits%20Comic%20Con,%20All%20Stars%20fashion%20and%20more&#038;via=socialitelife&#038;url=https://socialitelife.com/the-week-in-drag-we-swear-its-not-all-trixie-mattel-content-say-gday-to-the-down-under-queens-nina-west-hits-comic-con-all-stars-fashion-and-more/" class="social social-twitter"
 > <span class="thb-social-icon"> <i class="thb-icon-twitter"></i> </span> </a></div><div class="social-button-holder"> <a href="https://pinterest.com/pin/create/bookmarklet/?url=https://socialitelife.com/the-week-in-drag-we-swear-its-not-all-trixie-mattel-content-say-gday-to-the-down-under-queens-nina-west-hits-comic-con-all-stars-fashion-and-more/&#038;media=https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/rpdr-down-under-season-2.jpg?fit=1200%2C675&#038;ssl=1" class="social social-pinterest"
 > <span class="thb-social-icon"> <i class="thb-icon-pinterest"></i> </span> </a></div><div class="social-button-holder"> <a href="https://reddit.com/submit?url=https://socialitelife.com/the-week-in-drag-we-swear-its-not-all-trixie-mattel-content-say-gday-to-the-down-under-queens-nina-west-hits-comic-con-all-stars-fashion-and-more/" class="social social-reddit"
 > <span class="thb-social-icon"> <i class="thb-icon-reddit"></i> </span> </a></div><div class="social-button-holder"> <a href="https://share.flipboard.com/bookmarklet/popout?v=2&#038;title=The%20Week%20in%20Drag%20–%20We%20swear%20it’s%20not%20all%20Trixie%20Mattel%20content!%20Say%20G’Day%20to%20the%20Down%20Under%20queens,%20Nina%20West%20hits%20Comic%20Con,%20All%20Stars%20fashion%20and%20more&#038;url=https://socialitelife.com/the-week-in-drag-we-swear-its-not-all-trixie-mattel-content-say-gday-to-the-down-under-queens-nina-west-hits-comic-con-all-stars-fashion-and-more/" class="social social-flipboard"
 > <span class="thb-social-icon"> <i class="thb-icon-flipboard"></i> </span> </a></div><div class="social-button-holder"> <a href="https://www.linkedin.com/cws/share?url=https://socialitelife.com/the-week-in-drag-we-swear-its-not-all-trixie-mattel-content-say-gday-to-the-down-under-queens-nina-west-hits-comic-con-all-stars-fashion-and-more/" class="social social-linkedin"
 > <span class="thb-social-icon"> <i class="thb-icon-linkedin"></i> </span> </a></div><div class="social-button-holder"> <a href="/cdn-cgi/l/email-protection#516e2224333b3432256c0539347463610634343a746361383f74636115233036746361b3d1c2746361063474636122263430237463613825b3d1c8227463613f3e25746361303d3d7463610523382938347463611c302525343d746361323e3f25343f257074636102302874636116b3d1c8153028746361253e746361253934746361153e263f746361043f353423746361202434343f227d7463611f383f307463610634222574636139382522746361123e3c3832746361123e3f7d746361103d3d746361022530232274636137302239383e3f746361303f357463613c3e233477726162696a333e35286c0539347463610634343a746361383f74636115233036746361b3d1c2746361063474636122263430237463613825b3d1c8227463613f3e25746361303d3d7463610523382938347463611c302525343d746361323e3f25343f257074636102302874636116b3d1c8153028746361253e746361253934746361153e263f746361043f353423746361202434343f227d7463611f383f307463610634222574636139382522746361123e3c3832746361123e3f7d746361103d3d746361022530232274636137302239383e3f746361303f357463613c3e233474636139252521226b7e7e223e3238303d3825343d3837347f323e3c7e2539347c2634343a7c383f7c352330367c26347c22263430237c3825227c3f3e257c303d3d7c2523382938347c3c302525343d7c323e3f25343f257c2230287c363530287c253e7c2539347c353e263f7c243f3534237c202434343f227c3f383f307c263422257c393825227c323e3c38327c323e3f7c303d3d7c22253023227c37302239383e3f7c303f357c3c3e23347e" class="social social-email"> <span class="thb-social-icon"> <i class="thb-icon-mail"></i> </span> </a></div></div><aside class="post-bottom-meta hide"><meta itemprop="mainEntityOfPage" content="https://socialitelife.com/the-week-in-drag-we-swear-its-not-all-trixie-mattel-content-say-gday-to-the-down-under-queens-nina-west-hits-comic-con-all-stars-fashion-and-more/"> <span class="vcard author" itemprop="author" content="Christine Fitzgerald"> <span class="fn">Christine Fitzgerald</span> </span> <time class="time publised entry-date" datetime="2022-07-10T09:05:11-05:00" itemprop="datePublished" content="2022-07-10T09:05:11-05:00">July 10, 2022</time><meta itemprop="dateModified" class="updated" content="2022-07-10T09:05:18-05:00"> <span itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="Socialite Life"> <span itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://socialitelife.com/wp-content/uploads/2020/04/SL-Wig-banner-600.jpg"> </span> </span> <span itemprop="image" itemscope itemtype="http://schema.org/ImageObject"><meta itemprop="url" content="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/rpdr-down-under-season-2.jpg?fit=1200%2C675&amp;ssl=1"><meta itemprop="width" content="1200" /><meta itemprop="height" content="675" /> </span></aside></div></div></div><aside class="sidebar"><div id="thb_posts_widget-18" class="widget style1 thb_widget_posts"><div class="thb-widget-title"><span>POPULAR</div></span><div class="post thumbnail-style4  post-72067 type-post status-publish format-standard has-post-thumbnail hentry category-eye-candy category-fashion category-featured tag-levi-conely tag-male-model-spotlight tag-models tag-photos mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <a href="https://socialitelife.com/levi-conely-male-model-spotlight/"> <img width="180" height="180" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/levi-conely-photos-07062022-3.jpg?resize=20%2C20&amp;ssl=1" class="attachment-theissue-thumbnail-x2 size-theissue-thumbnail-x2 thb-lazyload lazyload wp-post-image" alt="Levi Conely" loading="lazy" sizes="(max-width: 180px) 100vw, 180px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/levi-conely-photos-07062022-3.jpg?resize=180%2C180&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/levi-conely-photos-07062022-3.jpg?resize=180%2C180&amp;ssl=1 180w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/levi-conely-photos-07062022-3.jpg?resize=90%2C90&amp;ssl=1 90w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/levi-conely-photos-07062022-3.jpg?resize=20%2C19&amp;ssl=1 20w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/levi-conely-photos-07062022-3.jpg?zoom=2&amp;resize=180%2C180&amp;ssl=1 360w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/levi-conely-photos-07062022-3.jpg?zoom=3&amp;resize=180%2C180&amp;ssl=1 540w" /> </a></figure><div class="thumbnail-style4-inner"><div class="post-title"><h6><a href="https://socialitelife.com/levi-conely-male-model-spotlight/" title="Levi Conely: Male Model Spotlight"><span>Levi Conely: Male Model Spotlight</span></a></h6></div><aside class="thb-post-bottom"><ul><li class="post-date">July 7, 2022</li><li class="post-read">1 min Read</li></ul></aside></div></div><div class="post thumbnail-style4  post-71972 type-post status-publish format-standard has-post-thumbnail hentry category-eye-candy tag-augusta-alexander tag-daniel-lenhardt tag-david-gandy tag-glenn-baeck tag-julian-schneyder tag-kyle-skopec tag-male-model-monday tag-models tag-nigel-hart tag-photos tag-ricardo-baldin tag-stefano-tomadini tag-victor-pinheiro mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <a href="https://socialitelife.com/male-model-monday-nigel-hart-victor-pinheiro-augusta-alexander-and-more/"> <img width="180" height="180" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/nigeel.haart_1656352216.jpg?resize=20%2C20&amp;ssl=1" class="attachment-theissue-thumbnail-x2 size-theissue-thumbnail-x2 thb-lazyload lazyload wp-post-image" alt="Nigel Hart" loading="lazy" sizes="(max-width: 180px) 100vw, 180px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/nigeel.haart_1656352216.jpg?resize=180%2C180&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/nigeel.haart_1656352216.jpg?resize=180%2C180&amp;ssl=1 180w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/nigeel.haart_1656352216.jpg?resize=90%2C90&amp;ssl=1 90w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/nigeel.haart_1656352216.jpg?resize=20%2C19&amp;ssl=1 20w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/nigeel.haart_1656352216.jpg?zoom=2&amp;resize=180%2C180&amp;ssl=1 360w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/nigeel.haart_1656352216.jpg?zoom=3&amp;resize=180%2C180&amp;ssl=1 540w" /> </a></figure><div class="thumbnail-style4-inner"><div class="post-title"><h6><a href="https://socialitelife.com/male-model-monday-nigel-hart-victor-pinheiro-augusta-alexander-and-more/" title="Male Model Monday: Nigel Hart, Victor Pinheiro, Augusta Alexander, and more"><span>Male Model Monday: Nigel Hart, Victor Pinheiro, Augusta Alexander, and more</span></a></h6></div><aside class="thb-post-bottom"><ul><li class="post-date">July 4, 2022</li><li class="post-read">1 min Read</li></ul></aside></div></div><div class="post thumbnail-style4  post-71902 type-post status-publish format-standard has-post-thumbnail hentry category-eye-candy tag-instahottie tag-jony-evans tag-models tag-photos mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <a href="https://socialitelife.com/meet-instagram-hottie-jony-evans/"> <img width="180" height="180" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/jony-evans-photos-06302022-3.jpg?resize=20%2C20&amp;ssl=1" class="attachment-theissue-thumbnail-x2 size-theissue-thumbnail-x2 thb-lazyload lazyload wp-post-image" alt="Jony Evans" loading="lazy" sizes="(max-width: 180px) 100vw, 180px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/jony-evans-photos-06302022-3.jpg?resize=180%2C180&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/jony-evans-photos-06302022-3.jpg?resize=180%2C180&amp;ssl=1 180w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/jony-evans-photos-06302022-3.jpg?resize=90%2C90&amp;ssl=1 90w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/jony-evans-photos-06302022-3.jpg?resize=20%2C19&amp;ssl=1 20w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/jony-evans-photos-06302022-3.jpg?zoom=2&amp;resize=180%2C180&amp;ssl=1 360w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/jony-evans-photos-06302022-3.jpg?zoom=3&amp;resize=180%2C180&amp;ssl=1 540w" /> </a></figure><div class="thumbnail-style4-inner"><div class="post-title"><h6><a href="https://socialitelife.com/meet-instagram-hottie-jony-evans/" title="Meet Instagram Hottie Jony Evans"><span>Meet Instagram Hottie Jony Evans</span></a></h6></div><aside class="thb-post-bottom"><ul><li class="post-date">July 2, 2022</li><li class="post-read">1 min Read</li></ul></aside></div></div></div></aside></div></article><div class="thb-article-nav previous"><div class="post post-nav featured-style center-contents post-72194 type-post status-publish format-standard has-post-thumbnail hentry category-celebrity tag-armie-hammer mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <img width="370" height="355" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/72194-origin_1.jpg?resize=20%2C19&amp;ssl=1" class="attachment-theissue-square size-theissue-square thb-lazyload lazyload wp-post-image" alt="" loading="lazy" sizes="(max-width: 370px) 100vw, 370px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/72194-origin_1.jpg?resize=370%2C355&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/72194-origin_1.jpg?resize=370%2C355&amp;ssl=1 370w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/72194-origin_1.jpg?resize=20%2C19&amp;ssl=1 20w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/72194-origin_1.jpg?zoom=2&amp;resize=370%2C355&amp;ssl=1 740w" /></figure><div class="post-inner-content"><aside class="post-category "> <a href="https://socialitelife.com/category/entertainment/celebrity/" rel="category tag">Celebrity</a></aside><div class="post-title"><h6><a href="https://socialitelife.com/armie-hammer-working-as-a-timeshare-salesman-following-sex-scandal-report/" title="Armie Hammer Working As A Timeshare Salesman Following Sex Scandal: Report"><span>Armie Hammer Working As A Timeshare Salesman Following Sex Scandal: Report</span></a></h6></div></div></div> <span class="thb-article-nav-text">Previous Article</span></div><div class="row hide-on-print"><aside class="small-12 columns related-posts related-posts-style2"><h6 class="related-posts-title">Related Posts</h6><div class="row
 "><div class="small-6 medium-6 large-3 columns"><div class="post style2 post-72141 type-post status-publish format-standard has-post-thumbnail hentry category-drag-queens tag-bendelacreme tag-jinkx-dela-holiday-show tag-jinkx-monsoon mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <a href="https://socialitelife.com/christmas-july-jinkx-monsoon-bendelacreme-holiday-tour/"><img width="740" height="675" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/jinkx-dela-07082022.jpg?resize=20%2C19&amp;ssl=1" class="attachment-theissue-square-x2 size-theissue-square-x2 thb-lazyload lazyload wp-post-image" alt="Jinkx Monsoon and BenDeLaCreme" loading="lazy" sizes="(max-width: 740px) 100vw, 740px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/jinkx-dela-07082022.jpg?resize=740%2C675&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/jinkx-dela-07082022.jpg?resize=740%2C675&amp;ssl=1 740w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/jinkx-dela-07082022.jpg?resize=20%2C19&amp;ssl=1 20w" /></a></figure><aside class="post-category "> <a href="https://socialitelife.com/category/drag-queens/" rel="category tag">Drag Queens</a></aside><div class="post-title"><h6><a href="https://socialitelife.com/christmas-july-jinkx-monsoon-bendelacreme-holiday-tour/" title="It’s Christmas in July as Jinkx Monsoon and BenDeLaCreme announce their 2022 holiday tour"><span>It’s Christmas in July as Jinkx Monsoon and BenDeLaCreme announce their 2022 holiday tour</span></a></h6></div></div></div><div class="small-6 medium-6 large-3 columns"><div class="post style2 post-71971 type-post status-publish format-standard has-post-thumbnail hentry category-drag-queens tag-adriana tag-alaska tag-bob-the-drag-queen tag-bosco tag-brad-goreski tag-brooke-lynn-hytes tag-canadas-drag-race tag-deja-skye tag-gottmik tag-grace-gaustad tag-jackie-cox tag-jaida-essence-hall tag-jasmine-kennedie tag-jaymes-mansfield tag-jimbo tag-jinkx-monsoon tag-joseph-shepherd tag-katya tag-kerri-colby tag-kornbread tag-lady-camden tag-laganja-estranja tag-larry-edwards tag-mayhem-miller tag-miss-vanjie tag-monet-x-change tag-raja tag-rupaul tag-rupauls-drag-race-all-stars tag-rupauls-drag-race tag-scarlet-envy tag-shea-coulee tag-the-vivienne tag-the-week-in-drag tag-traci-melchor tag-trinity-the-tuck tag-trixie-mattel tag-video tag-violet-chachki tag-willam tag-willow-pill tag-yuhua-hamasaki tag-yvie-oddly mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <a href="https://socialitelife.com/the-week-in-drag-meet-the-judges-for-canadas-drag-race-season-three/"><img width="740" height="710" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/canadas-drag-race-judges.jpeg?resize=20%2C19&amp;ssl=1" class="attachment-theissue-square-x2 size-theissue-square-x2 thb-lazyload lazyload wp-post-image" alt="Meet the judges for Canada’s Drag Race season three" loading="lazy" sizes="(max-width: 740px) 100vw, 740px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/canadas-drag-race-judges.jpeg?resize=740%2C710&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/canadas-drag-race-judges.jpeg?resize=370%2C355&amp;ssl=1 370w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/canadas-drag-race-judges.jpeg?resize=20%2C19&amp;ssl=1 20w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/07/canadas-drag-race-judges.jpeg?resize=740%2C710&amp;ssl=1 740w" /></a></figure><aside class="post-category "> <a href="https://socialitelife.com/category/drag-queens/" rel="category tag">Drag Queens</a></aside><div class="post-title"><h6><a href="https://socialitelife.com/the-week-in-drag-meet-the-judges-for-canadas-drag-race-season-three/" title="The Week in Drag – Meet the judges for Canada’s Drag Race season three, Raja’s fashion journey, a sparkly treat from Willam and more"><span>The Week in Drag – Meet the judges for Canada’s Drag Race season three, Raja’s fashion journey, a sparkly treat from Willam and more</span></a></h6></div></div></div><div class="small-6 medium-6 large-3 columns"><div class="post style2 post-71761 type-post status-publish format-standard has-post-thumbnail hentry category-drag-queens tag-alaska tag-batty-davis tag-bebe-zahara tag-betsey-johnson tag-bob-the-drag-queen tag-canadas-drag-race-2 tag-derrick-barry tag-detox tag-drag-race-france tag-gottmik tag-jaida-essence-hall tag-jasmine-kennedie tag-jaymes-mansfield tag-jinkx-monsoon tag-joseph-shepherd tag-jujubee tag-katya tag-kimora-blac tag-laganja-estranja tag-miss-vanjie tag-miz-cracker tag-monet-x-change tag-naysha-lopez tag-ongina tag-pangina-heals tag-raja tag-rupaul tag-rupauls-drag-race-all-stars tag-rupauls-drag-race-down-under tag-rupauls-drag-race tag-shangela tag-sharon-needles tag-shea-coulee tag-the-vivienne tag-the-week-in-drag tag-trinity-the-tuck tag-trixie-mattel tag-video tag-violet-chachki tag-willam tag-yuhua-hamasaki tag-yvie-oddly mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <a href="https://socialitelife.com/week-in-drag-all-stars-7-fashions-trixie-merch-shangela/"><img width="740" height="710" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/all-stars-06252022.jpeg?resize=20%2C19&amp;ssl=1" class="attachment-theissue-square-x2 size-theissue-square-x2 thb-lazyload lazyload wp-post-image" alt="All Stars 7 fashions" loading="lazy" sizes="(max-width: 740px) 100vw, 740px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/all-stars-06252022.jpeg?resize=740%2C710&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/all-stars-06252022.jpeg?resize=370%2C355&amp;ssl=1 370w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/all-stars-06252022.jpeg?resize=20%2C19&amp;ssl=1 20w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/all-stars-06252022.jpeg?resize=740%2C710&amp;ssl=1 740w" /></a></figure><aside class="post-category "> <a href="https://socialitelife.com/category/drag-queens/" rel="category tag">Drag Queens</a></aside><div class="post-title"><h6><a href="https://socialitelife.com/week-in-drag-all-stars-7-fashions-trixie-merch-shangela/" title="The Week in Drag – All Stars 7 fashions, new Trixie merch, Shangela hits the road and more"><span>The Week in Drag – All Stars 7 fashions, new Trixie merch, Shangela hits the road and more</span></a></h6></div></div></div><div class="small-6 medium-6 large-3 columns"><div class="post style2 post-71696 type-post status-publish format-standard has-post-thumbnail hentry category-eye-candy category-fashion category-featured tag-2xist tag-male-model-spotlight tag-michael-yerger tag-models tag-photos tag-video mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <a href="https://socialitelife.com/michael-yerger-for-2xist-male-model-spotlight/"><img width="740" height="675" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/michael-yerger-2xist-photos-06222022-2.jpg?resize=20%2C19&amp;ssl=1" class="attachment-theissue-square-x2 size-theissue-square-x2 thb-lazyload lazyload wp-post-image" alt="Michael Yerger for 2(x)ist" loading="lazy" sizes="(max-width: 740px) 100vw, 740px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/michael-yerger-2xist-photos-06222022-2.jpg?resize=740%2C675&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/michael-yerger-2xist-photos-06222022-2.jpg?resize=740%2C675&amp;ssl=1 740w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/michael-yerger-2xist-photos-06222022-2.jpg?resize=20%2C19&amp;ssl=1 20w" /></a></figure><aside class="post-category "> <a href="https://socialitelife.com/category/eye-candy/" rel="category tag">Eye Candy</a></aside><div class="post-title"><h6><a href="https://socialitelife.com/michael-yerger-for-2xist-male-model-spotlight/" title="Michael Yerger for 2(x)ist: Male Model Spotlight"><span>Michael Yerger for 2(x)ist: Male Model Spotlight</span></a></h6></div></div></div><div class="small-6 medium-6 large-3 columns"><div class="post style2 post-71656 type-post status-publish format-standard has-post-thumbnail hentry category-celebrity category-featured category-music tag-beyonce tag-video mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <a href="https://socialitelife.com/beyonce-drops-new-dance-track-break-my-soul-listen/"><img width="740" height="675" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2019/07/beyonce-coachella-07252019.jpg?resize=20%2C19&amp;ssl=1" class="attachment-theissue-square-x2 size-theissue-square-x2 thb-lazyload lazyload wp-post-image" alt="2018 Coachella Valley Music And Arts Festival - Weekend 1 - Day 2" loading="lazy" sizes="(max-width: 740px) 100vw, 740px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2019/07/beyonce-coachella-07252019.jpg?resize=740%2C675&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2019/07/beyonce-coachella-07252019.jpg?resize=740%2C675&amp;ssl=1 740w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2019/07/beyonce-coachella-07252019.jpg?resize=20%2C19&amp;ssl=1 20w" /></a></figure><aside class="post-category "> <a href="https://socialitelife.com/category/entertainment/music/" rel="category tag">Music</a></aside><div class="post-title"><h6><a href="https://socialitelife.com/beyonce-drops-new-dance-track-break-my-soul-listen/" title="Beyoncé drops new dance track ‘Break My Soul’ &#8211; Listen"><span>Beyoncé drops new dance track ‘Break My Soul’ &#8211; Listen</span></a></h6></div></div></div><div class="small-6 medium-6 large-3 columns"><div class="post style2 post-71589 type-post status-publish format-standard has-post-thumbnail hentry category-drag-queens tag-alaska tag-angeria-paris-vanmicheals tag-batty-davis tag-bianca-del-rio tag-bob-the-drag-queen tag-bombae tag-brittany-broski tag-canadas-drag-race tag-chelazon-leroux tag-coco-peru tag-deja-skye tag-gisele-lullaby tag-gottmik tag-halal-bae tag-irma-gerd tag-jada-shada-hudson tag-jaida-essence-hall tag-jaymes-mansfield tag-jinkx-monsoon tag-joseph-shepherd tag-kaos tag-kara-mel-dville tag-katya tag-kimmy-couture tag-lady-boom-boom tag-laganja-estranja tag-manila-luzon tag-miss-fiercalicious tag-miss-moco tag-monet-x-change tag-orville-peck tag-peppermint tag-raja tag-rupaul tag-rupauls-drag-race-all-stars tag-rupauls-drag-race tag-shea-coulee tag-tayce tag-the-vivienne tag-the-week-in-drag tag-tove-lo tag-trinity-the-tuck tag-trixie-mattel tag-video tag-violet-chachki tag-vivian-vanderpuss tag-willam tag-yvie-oddly mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <a href="https://socialitelife.com/the-week-in-drag-say-good-day-to-the-queens-of-canadas-drag-race/"><img width="740" height="675" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/canadas-drag-race.jpg?resize=20%2C19&amp;ssl=1" class="attachment-theissue-square-x2 size-theissue-square-x2 thb-lazyload lazyload wp-post-image" alt="Canada’s Drag Race Season 3" loading="lazy" sizes="(max-width: 740px) 100vw, 740px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/canadas-drag-race.jpg?resize=740%2C675&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/canadas-drag-race.jpg?resize=740%2C675&amp;ssl=1 740w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/canadas-drag-race.jpg?resize=20%2C19&amp;ssl=1 20w" /></a></figure><aside class="post-category "> <a href="https://socialitelife.com/category/drag-queens/" rel="category tag">Drag Queens</a></aside><div class="post-title"><h6><a href="https://socialitelife.com/the-week-in-drag-say-good-day-to-the-queens-of-canadas-drag-race/" title="The Week in Drag – Say “Good Day” to the queens of Canada’s Drag Race, check back in to the Trixie Motel, Coco Peru gets animated and more"><span>The Week in Drag – Say “Good Day” to the queens of Canada’s Drag Race, check back in to the Trixie Motel, Coco Peru gets animated and more</span></a></h6></div></div></div><div class="small-6 medium-6 large-3 columns"><div class="post style2 post-71584 type-post status-publish format-standard has-post-thumbnail hentry category-aww-cute-lol category-celebrity category-featured tag-buzzfeed tag-chris-evans tag-puppies tag-video mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <a href="https://socialitelife.com/chris-evans-is-as-adorable-as-the-puppies-in-his-puppy-interview/"><img width="740" height="710" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/chris-evans-puppy-interview.jpeg?resize=20%2C19&amp;ssl=1" class="attachment-theissue-square-x2 size-theissue-square-x2 thb-lazyload lazyload wp-post-image" alt="Chris Evans puppy interview" loading="lazy" sizes="(max-width: 740px) 100vw, 740px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/chris-evans-puppy-interview.jpeg?resize=740%2C710&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/chris-evans-puppy-interview.jpeg?resize=370%2C355&amp;ssl=1 370w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/chris-evans-puppy-interview.jpeg?resize=20%2C19&amp;ssl=1 20w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/chris-evans-puppy-interview.jpeg?resize=740%2C710&amp;ssl=1 740w" /></a></figure><aside class="post-category "> <a href="https://socialitelife.com/category/entertainment/celebrity/" rel="category tag">Celebrity</a></aside><div class="post-title"><h6><a href="https://socialitelife.com/chris-evans-is-as-adorable-as-the-puppies-in-his-puppy-interview/" title="Chris Evans is as adorable as the puppies in his puppy interview"><span>Chris Evans is as adorable as the puppies in his puppy interview</span></a></h6></div></div></div><div class="small-6 medium-6 large-3 columns"><div class="post style2 post-71476 type-post status-publish format-standard has-post-thumbnail hentry category-celebrity tag-questlove tag-the-new-york-times tag-video tag-wordle mv-content-wrapper thb-post-share-style1"><figure class="post-gallery"> <a href="https://socialitelife.com/questlove-on-reading-inspiration-and-wordle/"><img width="740" height="675" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/questlove-main-06132022.jpg?resize=20%2C19&amp;ssl=1" class="attachment-theissue-square-x2 size-theissue-square-x2 thb-lazyload lazyload wp-post-image" alt="Questlove" loading="lazy" sizes="(max-width: 740px) 100vw, 740px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/questlove-main-06132022.jpg?resize=740%2C675&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/questlove-main-06132022.jpg?resize=740%2C675&amp;ssl=1 740w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2022/06/questlove-main-06132022.jpg?resize=20%2C19&amp;ssl=1 20w" /></a></figure><aside class="post-category "> <a href="https://socialitelife.com/category/entertainment/celebrity/" rel="category tag">Celebrity</a></aside><div class="post-title"><h6><a href="https://socialitelife.com/questlove-on-reading-inspiration-and-wordle/" title="Questlove on reading, inspiration, and Wordle"><span>Questlove on reading, inspiration, and Wordle</span></a></h6></div></div></div></div></aside></div></div></div></div></div></div><footer id="footer" class="footer light footer-full-width-off"><div class="row footer-row"><div class="small-12 medium-6 large-4 columns"><div id="text-2" class="widget style1 widget_text"><div class="thb-widget-title"><span>About Socialite Life</div></span><div class="textwidget"><p><strong>Socialite Life</strong> brings you a daily dose of divas, drag queens, hot male celebrities and models, along with a healthy dollop of celebrity and pop culture news.</p></div></div><div id="text-7" class="widget style1 widget_text"><div class="thb-widget-title"><span>Disclaimer</div></span><div class="textwidget"><p><em>Socialite Life has affiliate partnerships, so we may receive a share of the revenue from your purchase.</em></p></div></div></div><div class="small-12 medium-6 large-4 columns"><div id="text-6" class="widget style1 widget_text"><div class="thb-widget-title"><span>Visit Our Partners</div></span><div class="textwidget"><ul><li><strong><a href="http://pubx.co/NrTBtu" target="_blank" rel="noopener" data-schema-attribute="">!!omgblog!!</a></strong></li><li><strong><a href="https://www.boyculture.com/" target="_blank" rel="noopener" data-schema-attribute="">Boy Culture</a></strong></li><li><strong><a href="http://www.evilbeetgossip.com/" target="_blank" rel="noopener" data-schema-attribute="">Evil Beet Gossip</a></strong></li><li><strong><a href="http://pubx.co/cN8EaE" target="_blank" rel="noopener" data-schema-attribute="">Go Fug Yourself</a></strong></li><li><strong><a href="http://www.kennethinthe212.com/" target="_blank" rel="noopener" data-schema-attribute="">Kenneth in the 212</a></strong></li></ul></div></div></div><div class="small-12 large-4 columns"><div id="thb_subscribe_widget-2" class="widget style1 thb_widget_subscribe"><aside class="thb-newsletter-form"><h4>Subscribe to our newsletter!</h4><p>A weekly recap of pop culture delivered straight to your inbox every Friday evening.</p><form class="newsletter-form" action="#" method="post" data-security="b9b42d2ba9"> <input placeholder="Your E-Mail" type="text" name="widget_subscribe" class="widget_subscribe"> <button type="submit" name="submit" class="btn black">SIGN UP</button><div class="thb-preloader"> <svg class="material-spinner" width="50px" height="50px" viewBox="0 0 66 66" xmlns="http://www.w3.org/2000/svg"> <circle class="material-path" fill="none" stroke-width="6" stroke-linecap="round" cx="33" cy="33" r="30"></circle> </svg></div></form><div class="thb-custom-checkbox"> <input type="checkbox" id="thb-newsletter-privacy-678" name="thb-newsletter-privacy" class="thb-newsletter-privacy"  checked='checked' > <label for="thb-newsletter-privacy-678"> I would like to receive news and special offers. </label></div></aside></div></div></div></footer><div class="subfooter style4 light subfooter-full-width-off"><div class="row align-middle subfooter-row"><div class="small-12 medium-4 columns text-center medium-text-left"><div class="menu-footer-menu-container"><ul id="menu-footer-menu-1" class="thb-full-menu thb-standard"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2856"><a href="https://socialitelife.com/about-socialite-life/">About</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-397"><a href="https://socialitelife.com/contact/">Contact</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-398"><a href="https://socialitelife.com/terms/">Terms</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-399"><a href="https://socialitelife.com/privacy-policy-2/">Privacy</a></li></ul></div></div><div class="small-12 medium-4 columns text-center"><div class="footer-logo-holder"> <a href="https://socialitelife.com/" class="footer-logolink" title="Socialite Life"> <img src="https://socialitelife.com/wp-content/uploads/2020/04/SL-Wig-banner-600.jpg" class="logoimg" loading="lazy" alt="Socialite Life"/> </a></div></div><div class="small-12 medium-4 columns text-center medium-text-right"><div class="thb-social-links-container thb-social-horizontal mono-icons"><div class="thb-social-link-wrap"> <a href="https://facebook.com/socialitelife" target="_blank" class="thb-social-link social-link-facebook" rel="noreferrer"><div class="thb-social-label-container"><div class="thb-social-icon-container"><i class="thb-icon-facebook"></i></div><div class="thb-social-label">Facebook</div></div> </a></div><div class="thb-social-link-wrap"> <a href="https://twitter.com/socialitelife" target="_blank" class="thb-social-link social-link-twitter" rel="noreferrer"><div class="thb-social-label-container"><div class="thb-social-icon-container"><i class="thb-icon-twitter"></i></div><div class="thb-social-label">Twitter</div></div> </a></div><div class="thb-social-link-wrap"> <a href="https://instagram.com/socialitelife" target="_blank" class="thb-social-link social-link-instagram" rel="noreferrer"><div class="thb-social-label-container"><div class="thb-social-icon-container"><i class="thb-icon-instagram"></i></div><div class="thb-social-label">Instagram</div></div> </a></div><div class="thb-social-link-wrap"> <a href="https://pinterest.com/socialitelife" target="_blank" class="thb-social-link social-link-pinterest" rel="noreferrer"><div class="thb-social-label-container"><div class="thb-social-icon-container"><i class="thb-icon-pinterest"></i></div><div class="thb-social-label">Pinterest</div></div> </a></div><div class="thb-social-link-wrap"> <a href="https://youtube.com/channel/UC7ew27fEz_OXF4kkxczb3Eg" target="_blank" class="thb-social-link social-link-youtube" rel="noreferrer"><div class="thb-social-label-container"><div class="thb-social-icon-container"><i class="thb-icon-youtube"></i></div><div class="thb-social-label">Youtube</div></div> </a></div></div></div></div><div class="row align-middle align-center"><div class="small-12 medium-6 large-4 columns text-center"><p>Support <strong>Socialite Life</strong> when you shop on Amazon <a href="https://amzn.to/2n3VQt5" target="_blank" rel="noopener">using this link</a> or when you click any of our affiliate links. You won’t have to go to the store, and we’ll receive a little commission.</p><p>Copyright ©2021, MJP Content Labs, LLC. All Rights Reserved.</p></div></div></div> <a id="scroll_to_top" class="style1"> <span>Scroll To Top</span> </a><div class="click-capture"></div><nav id="mobile-menu" class="style1 side-panel light dark-scroll" data-behaviour="thb-submenu"> <a class="thb-mobile-close"><div><span></span><span></span></div></a><div class="logo-holder mobilemenu-logo-holder"> <a href="https://socialitelife.com/" class="logolink" title="Socialite Life"> <img src="https://socialitelife.com/wp-content/uploads/2020/04/SL-Wig-banner-150.jpg" class="logoimg logo-dark" alt="Socialite Life" data-logo-alt="https://socialitelife.com/wp-content/uploads/2020/04/SL-Wig-banner-600.jpg" /> </a></div><div class="custom_scroll side-panel-inner" id="menu-scroll"><div class="mobile-menu-top"><ul id="menu-site-wide-menu-1" class="thb-mobile-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1743"><a href="https://socialitelife.com/category/entertainment/">Entertainment<div class="thb-arrow"><i class="thb-icon-down-open-mini"></i></div></a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16713"><a href="https://socialitelife.com/category/entertainment/celebrity/">Celebrity</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16125"><a href="https://socialitelife.com/category/entertainment/movies/">Movies</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16124"><a href="https://socialitelife.com/category/entertainment/tv/">TV</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16123"><a href="https://socialitelife.com/category/entertainment/music/">Music</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16126"><a href="https://socialitelife.com/category/fashion/">Fashion</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-20600"><a href="https://socialitelife.com/tag/podcasts/">Podcasts</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-23688"><a href="https://socialitelife.com/category/real-housewives/">Real Housewives</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-528"><a href="https://socialitelife.com/category/sl-flashback/">SL Flashback</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-16712"><a href="https://socialitelife.com/category/drag-queens/">Drag Queens<div class="thb-arrow"><i class="thb-icon-down-open-mini"></i></div></a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14251"><a href="https://socialitelife.com/tag/the-week-in-drag/">The Week in Drag</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-10323"><a href="https://socialitelife.com/tag/rupauls-drag-race/">RuPaul&#8217;s Drag Race</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-41509"><a href="https://socialitelife.com/tag/rupauls-drag-race-all-stars/">RuPaul&#8217;s Drag Race All Stars</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23598"><a href="https://socialitelife.com/tag/rupauls-drag-race-uk/">RuPaul&#8217;s Drag Race UK</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-326"><a href="https://socialitelife.com/category/eye-candy/">Eye Candy<div class="thb-arrow"><i class="thb-icon-down-open-mini"></i></div></a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1762"><a href="https://socialitelife.com/tag/man-candy">Insta Snaps</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1760"><a href="https://socialitelife.com/tag/instahottie">Instahottie</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1761"><a href="https://socialitelife.com/tag/male-model-monday">Male Model Monday</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-7032"><a href="https://socialitelife.com/category/interviews/">Interviews<div class="thb-arrow"><i class="thb-icon-down-open-mini"></i></div></a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-25651"><a href="https://socialitelife.com/tag/socialite-seven/">Socialite Seven</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1765"><a href="https://socialitelife.com/tag/photos">Photos</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-51007"><a href="#">Videos<div class="thb-arrow"><i class="thb-icon-down-open-mini"></i></div></a><ul class="sub-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51008"><a href="https://socialitelife.com/category/viral-video/">Viral Video</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35309"><a href="https://socialitelife.com/celebrity-news/">Celebrity News</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35314"><a href="https://socialitelife.com/movie-trailer-park/">Movie Trailer Park</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35311"><a href="https://socialitelife.com/tv-highlights-and-trailers/">TV Highlights and Trailers</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35308"><a href="https://socialitelife.com/netflix-and-chill/">Netflix and Chill</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35310"><a href="https://socialitelife.com/sls-pop-music-playlist/">SL’s Pop Music Playlist</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38919"><a href="https://socialitelife.com/in-real-life/">In Real Life</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35312"><a href="https://socialitelife.com/male-models/">Fashion</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-35313"><a href="https://socialitelife.com/drag-queen-fabulosity/">Drag Queen Fabulosity</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-14069"><a href="https://amzn.to/2RI8nUF">SL Shop</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49221"><a href="https://socialitelife.com/partners/">Partners</a></li></ul><ul id="menu-footer-menu-2" class="thb-secondary-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2856"><a href="https://socialitelife.com/about-socialite-life/">About</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-397"><a href="https://socialitelife.com/contact/">Contact</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-398"><a href="https://socialitelife.com/terms/">Terms</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-399"><a href="https://socialitelife.com/privacy-policy-2/">Privacy</a></li></ul></div><div class="mobile-menu-bottom"><div class="thb-social-links-container thb-social-horizontal mono-icons"><div class="thb-social-link-wrap"> <a href="https://facebook.com/socialitelife" target="_blank" class="thb-social-link social-link-facebook" rel="noreferrer"><div class="thb-social-label-container"><div class="thb-social-icon-container"><i class="thb-icon-facebook"></i></div><div class="thb-social-label">Facebook</div></div> </a></div><div class="thb-social-link-wrap"> <a href="https://twitter.com/socialitelife" target="_blank" class="thb-social-link social-link-twitter" rel="noreferrer"><div class="thb-social-label-container"><div class="thb-social-icon-container"><i class="thb-icon-twitter"></i></div><div class="thb-social-label">Twitter</div></div> </a></div><div class="thb-social-link-wrap"> <a href="https://instagram.com/socialitelife" target="_blank" class="thb-social-link social-link-instagram" rel="noreferrer"><div class="thb-social-label-container"><div class="thb-social-icon-container"><i class="thb-icon-instagram"></i></div><div class="thb-social-label">Instagram</div></div> </a></div><div class="thb-social-link-wrap"> <a href="https://pinterest.com/socialitelife" target="_blank" class="thb-social-link social-link-pinterest" rel="noreferrer"><div class="thb-social-label-container"><div class="thb-social-icon-container"><i class="thb-icon-pinterest"></i></div><div class="thb-social-label">Pinterest</div></div> </a></div><div class="thb-social-link-wrap"> <a href="https://youtube.com/channel/UC7ew27fEz_OXF4kkxczb3Eg" target="_blank" class="thb-social-link social-link-youtube" rel="noreferrer"><div class="thb-social-label-container"><div class="thb-social-icon-container"><i class="thb-icon-youtube"></i></div><div class="thb-social-label">Youtube</div></div> </a></div></div></div></div></nav>  <script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">(function(w, d, s, id) {
  w.PUBX=w.PUBX || {pub: "socialite_life", discover: true, lazy: true};
  var js, pjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id; js.async = true;
  js.src = "//main.pubexchange.com/loader.min.js";
  pjs.parentNode.insertBefore(js, pjs);
}(window, document, "script", "pubexchange-jssdk"));</script> <script type="text/javascript">var sbiajaxurl = "https://socialitelife.com/wp-admin/admin-ajax.php";</script> <aside id="newsletter-popup" class="mfp-hide theme-popup newsletter-popup light"><figure class="newsletter-image"><img width="500" height="500" src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2018/09/SL-500-square.jpg?resize=20%2C19&amp;ssl=1" class="attachment-theissue-square-x2 size-theissue-square-x2 thb-lazyload lazyload" alt="" loading="lazy" sizes="(max-width: 500px) 100vw, 500px" data-src="https://i0.wp.com/socialitelife.com/wp-content/uploads/2018/09/SL-500-square.jpg?resize=500%2C500&amp;ssl=1" data-sizes="auto" data-srcset="https://i0.wp.com/socialitelife.com/wp-content/uploads/2018/09/SL-500-square.jpg?w=500&amp;ssl=1 500w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2018/09/SL-500-square.jpg?resize=180%2C180&amp;ssl=1 180w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2018/09/SL-500-square.jpg?resize=90%2C90&amp;ssl=1 90w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2018/09/SL-500-square.jpg?resize=370%2C370&amp;ssl=1 370w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2018/09/SL-500-square.jpg?resize=20%2C20&amp;ssl=1 20w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2018/09/SL-500-square.jpg?resize=185%2C185&amp;ssl=1 185w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2018/09/SL-500-square.jpg?resize=400%2C400&amp;ssl=1 400w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2018/09/SL-500-square.jpg?resize=45%2C45&amp;ssl=1 45w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2018/09/SL-500-square.jpg?resize=300%2C300&amp;ssl=1 300w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2018/09/SL-500-square.jpg?resize=100%2C100&amp;ssl=1 100w, https://i0.wp.com/socialitelife.com/wp-content/uploads/2018/09/SL-500-square.jpg?resize=48%2C48&amp;ssl=1 48w" /></figure><div class="newsletter-content"><aside class="thb-article-subscribe thb-newsletter-form"><div class="thb-subscribe-icon-container"><svg version="1.1" class="thb-subscribe-icon" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
 viewBox="0 0 90 68" style="enable-background:new 0 0 90 68;" xml:space="preserve"> <path d="M89.9,7.9c0-4.3-3.6-7.9-7.9-7.9L7.8,0.1C3.5,0.1,0,3.8,0,8.1l0.1,52c0,4.3,3.6,7.9,7.9,7.9l74.2-0.1c4.3,0,7.8-3.6,7.8-8
 L89.9,7.9z M7.8,4.4l74.2-0.1c0.4,0,0.8,0.1,1.2,0.2L48.9,39.4c-1,1.1-2.4,1.6-3.9,1.6c-1.5,0-2.8-0.5-3.9-1.6L6.7,4.6
 C7,4.5,7.4,4.4,7.8,4.4z M82.2,63.6L7.9,63.8c-2,0-3.7-1.7-3.7-3.7l-0.1-52l34,34.4c1.8,1.8,4.3,2.9,6.8,2.9c2.5,0,5-1.1,6.8-2.9
 L85.7,7.9l0.1,52C85.8,61.9,84.2,63.6,82.2,63.6z M80.5,55.7L62.9,40c-0.8-0.7-2.2-0.7-2.9,0.2c-0.7,0.8-0.7,2.2,0.2,3l17.6,15.7
 c0.4,0.3,0.9,0.5,1.4,0.5c0.6,0,1.1-0.2,1.6-0.7C81.4,57.8,81.4,56.4,80.5,55.7z M26.9,40.3L9.5,55.8c-0.8,0.7-0.9,2.1-0.2,3
 c0.5,0.5,1,0.7,1.7,0.7c0.5,0,0.9-0.2,1.4-0.5l17.3-15.5c0.8-0.7,0.9-2.1,0.2-3C29.1,39.6,27.8,39.5,26.9,40.3z"/> </svg></div><h4> Subscribe to our newsletter!</h4><p> A weekly recap of pop culture delivered straight to your inbox every Friday evening.</p><form class="newsletter-form" action="#" method="post" data-security="b9b42d2ba9"> <input placeholder="Your E-Mail" type="text" name="widget_subscribe" class="widget_subscribe large"> <button type="submit" name="submit" class="btn large">SIGN UP</button><div class="thb-preloader"> <svg class="material-spinner" width="50px" height="50px" viewBox="0 0 66 66" xmlns="http://www.w3.org/2000/svg"> <circle class="material-path" fill="none" stroke-width="6" stroke-linecap="round" cx="33" cy="33" r="30"></circle> </svg></div></form><div class="thb-custom-checkbox"> <input type="checkbox" id="thb-newsletter-privacy-987" name="thb-newsletter-privacy" class="thb-newsletter-privacy"  checked='checked' > <label for="thb-newsletter-privacy-987"> I would like to receive news and special offers. </label></div></aside></div></aside><style>.wp-container-1 > .alignleft { float: left; margin-inline-start: 0; margin-inline-end: 2em; }.wp-container-1 > .alignright { float: right; margin-inline-start: 2em; margin-inline-end: 0; }.wp-container-1 > .aligncenter { margin-left: auto !important; margin-right: auto !important; }</style><style>.wp-container-2 > .alignleft { float: left; margin-inline-start: 0; margin-inline-end: 2em; }.wp-container-2 > .alignright { float: right; margin-inline-start: 2em; margin-inline-end: 0; }.wp-container-2 > .aligncenter { margin-left: auto !important; margin-right: auto !important; }</style><style>.wp-container-3 > .alignleft { float: left; margin-inline-start: 0; margin-inline-end: 2em; }.wp-container-3 > .alignright { float: right; margin-inline-start: 2em; margin-inline-end: 0; }.wp-container-3 > .aligncenter { margin-left: auto !important; margin-right: auto !important; }</style> <script type='text/javascript' src='https://socialitelife.com/wp-content/themes/theissue/assets/js/vendor/lazysizes.min.js?ver=1.6.7' id='lazysizes-js'></script> <script type='text/javascript' src='https://cdn.plyr.io/3.6.2/plyr.polyfilled.js?ver=1.6.7' id='plyr-js'></script> <script type='text/javascript' id='thb-app-js-extra'>var themeajax = {"url":"https:\/\/socialitelife.com\/wp-admin\/admin-ajax.php","l10n":{"of":"%curr% of %total%","just_of":"of","loading":"Loading","lightbox_loading":"Loading...","nomore":"No More Posts","nomore_products":"All Products Loaded","loadmore":"Load More","added":"Added To Cart","no_results":"No Results Found","results_found":"Results Found","results_all":"View All Results","copied":"Copied","prev":"Prev","next":"Next","pinit":"PIN IT","adding_to_cart":"Adding to Cart"},"svg":{"prev_arrow":"<svg version=\"1.1\" xmlns=\"http:\/\/www.w3.org\/2000\/svg\" xmlns:xlink=\"http:\/\/www.w3.org\/1999\/xlink\" x=\"0px\" y=\"0px\"\r\n\t width=\"30px\" height=\"30px\" viewBox=\"0 0 30 30\" enable-background=\"new 0 0 30 30\" xml:space=\"preserve\">\r\n<path class=\"thb-arrow-first\" d=\"M12.757,14.997l3.585,3.243c0.201,0.174,0.201,0.459,0,0.635c-0.203,0.175-0.532,0.175-0.734,0l-3.948-3.557\r\n\tc-0.203-0.175-0.203-0.459,0-0.635l3.948-3.557c0.202-0.175,0.531-0.175,0.734,0c0.201,0.175,0.201,0.459,0,0.635L12.757,14.997z\"\/>\r\n<path class=\"thb-arrow-second\" d=\"M12.757,14.997l3.585,3.243c0.201,0.174,0.201,0.459,0,0.635c-0.203,0.175-0.533,0.175-0.734,0l-3.948-3.557\r\n\tc-0.203-0.175-0.203-0.459,0-0.635l3.948-3.557c0.201-0.175,0.531-0.175,0.734,0c0.201,0.175,0.201,0.459,0,0.635L12.757,14.997z\"\/>\r\n<\/svg>\r\n","next_arrow":"<svg version=\"1.1\" xmlns=\"http:\/\/www.w3.org\/2000\/svg\" xmlns:xlink=\"http:\/\/www.w3.org\/1999\/xlink\" x=\"0px\" y=\"0px\"\r\n\t width=\"30px\" height=\"30px\" viewBox=\"0 0 30 30\" enable-background=\"new 0 0 30 30\" xml:space=\"preserve\">\r\n<path class=\"thb-arrow-first\" d=\"M13.659,11.76c-0.201-0.175-0.201-0.459,0-0.635c0.203-0.175,0.532-0.175,0.734,0l3.947,3.557\r\n\tc0.203,0.176,0.203,0.46,0,0.635l-3.947,3.557c-0.202,0.175-0.531,0.175-0.734,0c-0.201-0.176-0.201-0.461,0-0.635l3.585-3.243\r\n\tL13.659,11.76z\"\/>\r\n<path class=\"thb-arrow-second\" d=\"M13.659,11.76c-0.201-0.175-0.201-0.459,0-0.635c0.203-0.175,0.533-0.175,0.734,0l3.948,3.557\r\n\tc0.203,0.176,0.203,0.46,0,0.635l-3.948,3.557c-0.201,0.175-0.531,0.175-0.734,0c-0.201-0.176-0.201-0.461,0-0.635l3.585-3.243\r\n\tL13.659,11.76z\"\/>\r\n<\/svg>\r\n","added_arrow":"","close_arrow":"<svg xmlns=\"http:\/\/www.w3.org\/2000\/svg\" viewBox=\"0 0 64 64\" enable-background=\"new 0 0 64 64\"><g fill=\"none\" stroke=\"#000\" stroke-width=\"2\" stroke-miterlimit=\"10\"><path d=\"m18.947 17.15l26.1 25.903\"\/><path d=\"m19.05 43.15l25.902-26.1\"\/><\/g><\/svg>","pagination":"<svg version=\"1.1\" xmlns=\"http:\/\/www.w3.org\/2000\/svg\" class=\"thb-pagination-svg\" width=\"14px\" height=\"14px\" viewBox=\"0 0 16 16\" preserveAspectRatio=\"none\"><circle cx=\"8\" cy=\"8\" r=\"5.5\"><\/circle><\/svg>","preloader":"<svg class=\"material-spinner\" width=\"50px\" height=\"50px\" viewBox=\"0 0 66 66\" xmlns=\"http:\/\/www.w3.org\/2000\/svg\">\n   <circle class=\"material-path\" fill=\"none\" stroke-width=\"6\" stroke-linecap=\"round\" cx=\"33\" cy=\"33\" r=\"30\"><\/circle>\n<\/svg>"},"settings":{"infinite_count":"5","site_url":"https:\/\/socialitelife.com","current_url":"https:\/\/socialitelife.com\/the-week-in-drag-we-swear-its-not-all-trixie-mattel-content-say-gday-to-the-down-under-queens-nina-west-hits-comic-con-all-stars-fashion-and-more\/","fixed_header_scroll":"off","fixed_header_padding":"","general_search_ajax":"off","newsletter":"on","newsletter_length":"2","newsletter_delay":"10","newsletter_mailchimp":true,"page_transition":"on","page_transition_style":"thb-fade","page_transition_in_speed":"500","page_transition_out_speed":"250","shop_product_listing_pagination":"style1","right_click":"off","cart_url":false,"is_cart":false,"is_checkout":false,"touch_threshold":5,"mobile_menu_animation_speed":"0.3","thb_custom_video_player":"on","viai_publisher_id":""}};</script> <aside class="thb-search-popup" data-security="61fd06caa2"> <a class="thb-mobile-close"><div><span></span><span></span></div></a><div class="thb-close-text">PRESS ESC TO CLOSE</div><div class="row align-center align-middle search-main-row"><div class="small-12 medium-8 columns"><form method="get" class="searchform" action="https://socialitelife.com/"> <input type="text" name="s" class="search-field" placeholder="Type Here to Search" /></form><div class="thb-autocomplete-wrapper"><div class="thb-preloader"> <svg class="material-spinner" width="50px" height="50px" viewBox="0 0 66 66" xmlns="http://www.w3.org/2000/svg"> <circle class="material-path" fill="none" stroke-width="6" stroke-linecap="round" cx="33" cy="33" r="30"></circle> </svg></div></div></div></div></aside> <script src='https://stats.wp.com/e-202227.js' defer></script> <script>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:11.0',blog:'21367542',post:'72174',tz:'-5',srv:'socialitelife.com'} ]);
	_stq.push([ 'clickTrackerInit', '21367542', '72174' ]);</script> </div>  <script defer src="https://socialitelife.com/wp-content/cache/autoptimize/js/autoptimize_e9598c372c50275e873094f074ff958a.js"></script></body></html>